Java not recognized by Cisco Self-Provisioning Portal on Apple computers

Unanswered Question
Oct 31st, 2013
User Badges:

Have a Mac Mini running that had this problem under OSX 10.8 and is persisting in 10.9.  When this computers reaches the self-provisioning portal, after clicking submit on the MAC address registration, the following screen displays an erroneous error that Java isn't installed.


Have gone through updating Java from Apple (2013-005) as well as from Oracle/Java (1.7), and applied several variations of uninstalling and reinstalling Java, doesn't seem to make a difference.  From the top, the Mac Mini attaches to Wifi and the self-provisioning page appears with an authentication request.  User authenticates succesfully.  The next page displays the MAC address for the machine and a description field.  Upon filling out the description, the page is submitted.  The following page tha should complete the provisioning process, rather, displays an error that Java isn't installed and the user should go to java.com to complete the installation.  According to the Java.com, Java is installed. According to terminal (by executing the command "java -version"), Java is installed. Running other Java applications, like JDE, run perfectly well.  The self-provisioning page seems to be unaware of Java despite everything else.  Ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Tarik Admani Thu, 10/31/2013 - 21:41
User Badges:
  • Green, 3000 points or more

Seth,


Which browser are you using if Safari, by default Safari disables Java if it isnt completely up to date. Also after the install has the browser been restarted? Try checking the link here under the Safari section to see if you can enable it manually and try running through the SPW process.


http://java.com/en/download/help/enable_browser.xml


Thanks,

Tarik Admani
*Please rate helpful posts*

seth00005 Fri, 11/01/2013 - 07:53
User Badges:

Thanks. No dice. The instructions on that page also appear to be woefully out of date too. In Safari, on the preferences security tab, there is no checkbox for "Enable Java" (I think that is a Safari 6.0.4 thing on OS X 10.8 or thereabouts). In OS X 10.9 there's just the "allow plugins" checkbox and the "manage website settings" button. Assuming this is where it's at now, moving to the Java plugin in the list, they were already "allow". I went a step further and set it for the three websites listed (that include the provisioning portal domain) to "allow always". No luck. Then went to another step further and click "run in unsafe mode" for every item in the Java website list and again it made no difference. The self provisioning portal page still says that Java isn't installed :-(

For Firefox, the instructions on that page are out of date too. Under what I believe are the correct settings, the Java applet plug-in for 7.45 is set to "always activate". I assume this is the same thing as seeing the "disable" button in previous FF versions, indicating that the job applet plug-in is actively running.

The chrome instructions on the page are irrelevant because my OS X and hardware are 64-bit and so is Java but not chrome. Therefore Java doesn't run on chrome on this machine in the first place.

I don't know who's browser the self provisioning portal fires up since it fires up its own window, not a Firefox or Safari specific one. In windows for example the self-provisioning portal fires up a tab in IE. That actually makes it simpler to debug IMO.

Any more advice? Java seems to be running just fine for every thing else. What am I missing?


UPDATE (Just another thought)

Alternatively, could it be a the with WebKit? Or Cisco's implementation of WebKit (as far as whether any changes would have been required for OS X 10.9 in the way with kids is instantiated)? If or example the self provisioning portal is opening up its own "browser" by using the Safari webkit function (as opposed to opening a tab directly in Safari itself) could this be a bug in Safari itself, or a changed API that Cisco has failed to implement (considering the other incompatibilities various Cisco products have with OS X 10.9)? I just hope that the problem is something that I can fix with a workaround rather than waiting for a patch from either Apple or Cisco that may or may not come anytime soon? :-/

blenka Fri, 11/01/2013 - 16:57
User Badges:

Apple Safari version 6.0 is only supported on Mac OS X 10.7.4 and later versions of the operating system.


  If you are using Mac OS X clients with Java 7, you cannot download the  Agents using Google Chrome browser. Java 7 runs only on 64-bit browsers  and Chrome is a 32-bit browser. It is recommended to use either previous  versions of Java or other browsers while downloading the Agents.


If you are using Mac OS X clients with Java 7, you cannot download the  SPWs using Google Chrome browser. Java 7 runs only on 64-bit browsers  and Chrome is a 32-bit browser. It is recommended to use either previous  versions of Java or other browsers while downloading the SPWs.

seth00005 Mon, 11/04/2013 - 08:35
User Badges:

Thanks, but I may have been unclear in my original post. My default browser is Safari 7.0 in OS X 10.9.  I also have Firefox 24.0 installed, and I know that you can't use Chrome because of the 24 bit Java problem.  I've gone ahead and uninstalled Chrome too so there's no Chrome any longer on my system.  Just Safari 7.0 and Firefox 24.0 and Java 7.45.


Any idea why the self-provisioning portal says "Please install the latest Java..." after I click submit on the screen to register my hardware MAC address?  AFAICT, the Cisco page does not see that Java is installed.


I observe that in OS X anyhow, the Cisco self-provisioning portal page is a box up dialog box, not a separate tab in an open browser, like in Windows IE.  Therefore, it may also be helpful to know the mechanics of what Cisco's doing here, and why it's different than on Windows?


The specific error that the self-provisioning portal page throws as soon as the final page loads, is: "To continue, install and enable the latest Java version, and make sure the Java plug-in is not blocked. You can download and install Java from http://www.java.com/en/download. If you are unable to download Java, connect to a different network and try again."  Basically, can't start Java.  Any ideas?

Jacob Gibb Mon, 12/09/2013 - 14:27
User Badges:

I have the same exact issue with a Mac OS X running 10.9 and the latest version of Safari. This is also the case on a 10.8 Mac OS X workstation. We did find that running firefox on the machines seems to kick off the java process and install the SPW correctly although we manually have to reconnect to the provisioned SSID. Any fix you found for this outside of telling the users they must have Firefox or some other browser to provision thier device?

Tarik Admani Mon, 12/09/2013 - 15:01
User Badges:
  • Green, 3000 points or more

There is a bug on the cisco release notes that goes into the Safari 7 issue - Can you see if the following steps fixes the issue?


CSCuj26086

Java Applet fails to launch NSP or Mac Agent on Safari 7 browser available with Mac OSX 10.9.

Workaround   Explicitly  let it run by changing the website settings on the browser. The default  setting encourages users to whitelist individual sites/pages where JAVA  is used.

To let applet install agent/SPW, connect to ISE and get re-directed to CP page. Before clicking Click to Install Agent, go to:

Safari->Preferences->Security->Manage Website Settings->Java->Click on your ISE URL->Run in unsafe mode


http://www.cisco.com/en/US/docs/security/ise/1.2/release_notes/ise12_rn.html


thanks,

Tarik Admani
*Please rate helpful posts*

Jacob Gibb Tue, 12/17/2013 - 16:11
User Badges:

This solution did fix the issue with the Mac OS X using Safari. Thanks for the help!

Sent from Cisco Technical Support iPad App

aidin.spac Tue, 03/11/2014 - 19:36
User Badges:

Had the same problem, I did two things:

1. go to System Prefrences-> Java -> Advanced -> Perform certificate revocation -> Do not check

2. go to System Prefrences-> Java -> Security -> Medium

 

it worked for me on Firfox

Actions

This Discussion

Related Content