ACS 5.4 Cannot Install Patch 5

Unanswered Question
Nov 1st, 2013
User Badges:

Greetings. Just upgraded ACS 5.2 to 5.4 via SFTP and attempted to apply patch 5 but get error message "SSH connect error". Same SFTP server as used for the upgrade, so assumed the credentials had been removed in the upgrade process. Re-configured SFTP user/password, but still no success. Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jatin Katyal Fri, 11/01/2013 - 13:31
User Badges:
  • Cisco Employee,

Can you please get the "debug transfer 7"?


Are we using the same SFTP server for applying patch 5 or different?



~BR
Jatin Katyal

**Do rate helpful posts**

Tim Steele Thu, 06/26/2014 - 16:37
User Badges:

I assume you have long since had this issue resolved.  But, just in case there are others that read this post, here is a possible solution.   When you apply the patch, you need to use the "acs patch install..." command, not the "patch install..." command.  A valid patch file will produce this error when using the wrong syntax.
 

cciesec2011 Thu, 06/26/2014 - 17:05
User Badges:

Any "stupid" way of Cisco of doing things, the right-hand does not know what the left-hand is doing.

 

Why can't Cisco make it easier for everyone by making patching on the ACS just like how the ISE does it?  With the ISE, everything is done from the browser so that we don't have to go through questions like this one.

 

my 2c

leeswc Fri, 11/01/2013 - 13:31
User Badges:

Well, I already answered half the question by configuring the user/password and then syncing the host-key but now I'm getting the error message "Manifest file not found in the bundle".

Jatin Katyal Fri, 11/01/2013 - 13:38
User Badges:
  • Cisco Employee,

Basically, this error happens, if the file that got downloaded from Cisco site got corrupted. Did you check the checksum?

what web broswer you used to download patch 5?


~BR
Jatin Katyal

**Do rate helpful posts**

leeswc Fri, 11/01/2013 - 13:40
User Badges:

Firefox 24.0 same as used to download the 5.4 upgrade. Did not check the checksum. Will do as soon as I figure out how.

leeswc Fri, 11/01/2013 - 13:38
User Badges:

KI20604022AACSC/admin# debug transfer

KI20604022AACSC/admin# patch install 5-4-0-46-5.tar.gpg 5.4

Save the current ADE-OS running configuration? (yes/no) [yes] ?

Generating configuration...

Saved the ADE-OS running configuration to startup successfully

Initiating Application Patch installation...

6 [23794]: transfer: cars_xfer.c[47] [admin]: sftp copy in of

5-4-0-46-5.tar.gpg requested

6 [23794]: transfer: cars_xfer_util.c[578] [admin]: resolved server to

132.62.78.203

7 [23794]: transfer: cars_xfer_util.c[584] [admin]: copying

/5-4-0-46-5.tar.gpg from remote server: x.x.78.203

7 [24006]: transfer: sftp_copy.c[73] [daemon]: Executing SFTP command:

/usr/bin/scp [email protected]:/5-4-0-46-5.tar.gpg

/storeddata/Installing/.1383315760/5-4-0-46-5.tar.gpg

7 [23794]: transfer: cars_xfer_util.c[592] [admin]: sftp xfer succeeded

% Manifest file not found in the bundle

KI20604022AACSC/admin#

Actions

This Discussion