×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

what is the command that shows that port-fast is enabled on certain ports.

Unanswered Question
Nov 13th, 2013
User Badges:

How to see whether port-fast is enabled on a port or not ?


Here port fast is disabled globally.


switch0#sh span sum

Switch is in pvst mode

Root bridge for:

Extended system ID           is enabled

Portfast Default             is disabled


O/p of show spanning tree:


switch0#show spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority    1

             Address     00D0.5865.B7E7

             Cost        19

             Port        1(FastEthernet0/1)

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec


  Bridge ID  Priority    28673  (priority 28672 sys-id-ext 1)

             Address     000A.F3D2.55D2

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  20


Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1            Root FWD 19        128.1    P2p

Fa0/2            Altn BLK 19        128.2    P2p


Now i enable port-fast on Fa0/2. (Just doing trial and Error to understand things a better)


switch0(config)#interface fastEthernet 0/2

switch0(config-if)#spanning-tree portfast

%Warning: portfast should only be enabled on ports connected to a single

host. Connecting hubs, concentrators, switches, bridges, etc... to this

interface  when portfast is enabled, can cause temporary bridging loops.

Use with CAUTION


%Portfast has been configured on FastEthernet0/2 but will only

have effect when the interface is in a non-trunking mode.

switch0(config-if)#switchport mode access

switch0(config-if)#end


Now, where what is the command that shows that port-fast is enabled on certain ports.


REgards,

Chandu

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Abzal Sembay Wed, 11/13/2013 - 01:52
User Badges:
  • Silver, 250 points or more

Hi,


try this one:


#sh spanning-tree detail | inc FastEthernet|portfast


Hope it will help.

Best regards,
Abzal

chandra_rc16 Wed, 11/13/2013 - 03:56
User Badges:

Got it. Since the port-fast enabled ports doesn't participate in STP. There is no Fa0/1 port in o/p of sh span tree detail.


switch0#show spanning-tree detail


VLAN0001 is executing the ieee compatible Spanning Tree Protocol

  Bridge Identifier has priority of 0, sysid 1, 000A.F3D2.55D2

  Configured hello time 2, max age 20, forward delay 15

  Current root has priority 1

  Topology change flag not set, detected flag not set

  Number of topology changes 0 last change occurred 00:00:00 ago

            from FastEthernet0/1

  Times:  hold 1, topology change 35, notification 2

          hello 2, max age 20, forward delay 15

  Timers: hello 0, topology change 0, notification 0, aging 300


Port 2 (FastEthernet0/2) of VLAN0001 is designated forwarding

  Port path cost 19, Port priority 112, Port Identifier 112.2

  Designated bridge has priority 1, address 000A.F3D2.55D2

  Designated port id is 112.2, designated path cost 19

  Timers: message age 16, forward delay 0, hold 0

  Number of transitions to forwarding state: 1

  Link type is point-to-point by default


Regards,

Chandu

Actions

This Discussion