×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SG300-10 - Configuring DHCP Reservations based on MAC

Answered Question
Nov 25th, 2013
User Badges:

Hello all!


i have the SG300-10 for my home network, and i have everything setup EXCEPT for static reservations via DHCP


how exactly would you configure those?  i have several things configured for port-forwarding which requires static IPs.  i already have pools configured with proper starting points to leave me room for the several reservations i need, but i dont want to make a mistake and blow something up.


below is my config, what commands do i use to add those?  i want several in the 10 and 200 vlans.  1 for each of my wireless devices where i know the MAC, and also for my vlan 200 for my wired devices.



v1.3.5.58 / R750_NIK_1_35_647_358

CLI v1.0

set system mode router


file SSD indicator encrypted

@

ssd-control-start

ssd config

ssd file passphrase control unrestricted

no ssd file integrity control

ssd-control-end <omitted>

!

no cdp run

spanning-tree mode mst

vlan database

default-vlan vlan 99

exit

vlan database

vlan 1,10,200

exit

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

no lldp run

ip dhcp server

ip dhcp pool network User_200

address low 10.5.10.10 high 10.5.10.220 255.255.255.0

default-router 10.5.10.1

dns-server 68.105.28.12 68.105.29.12 68.105.28.11

exit

ip dhcp pool network Wireless_10

address low 10.5.11.10 high 10.5.11.15 255.255.255.0

default-router 10.5.11.1

dns-server 8.8.8.8 8.8.4.4

exit

no bonjour enable

bonjour interface range vlan 1

ip access-list extended U_Wireless_10

permit ip 10.5.10.0 0.0.0.255 10.5.10.1 0.0.0.255

permit ip 10.5.10.0 0.0.0.255 10.5.5.2 0.0.0.0

deny ip 10.5.10.0 0.0.0.255 10.0.0.0 0.255.255.255

deny ip 10.5.10.0 0.0.0.255 172.16.0.0 0.15.255.255

deny ip 10.5.10.0 0.0.0.255 192.168.0.0 0.0.255.255

permit ip any any

exit

hostname WesleyNetS1

management access-list Management

permit

exit


here is verification info:


[quote]

show ver

SW version    1.3.5.58 ( date  10-Oct-2013 time  17:15:41 )

Boot version    1.3.5.06 ( date  21-Jul-2013 time  15:12:10 )

HW version    V02



dir

Directory of flash:


File Name      Permission Flash Size Data Size        Modified

------------------- ---------- ---------- --------- -----------------------

backup-config           rw       131040     13162    25-Nov-2013 21:55:24

backuplo                rw       327600      26      10-Oct-2013 17:16:01

dhcpdb.sys              r-       65520       --      10-Oct-2013 17:18:12

dhcpsn.prv              --       65520       --      02-May-2013 14:55:10

directry.prv            --       65520       --      02-May-2013 14:55:10

image-1                 rw      6976867    6976867   25-Nov-2013 21:15:32

image-2                 rw      6976867    6976867   25-Nov-2013 21:26:41

mirror-config           rw       131040     4351     22-Sep-2013 06:52:13

startup-config          rw       262080     15333    25-Nov-2013 22:42:55

syslog1.sys             r-       65520       --      12-Nov-2011 23:34:37

syslog2.sys             r-       65520       --      12-Nov-2011 23:34:37


Total size of flash: 16252928 bytes

Free size of flash: 1119834 bytes

[/quote]

Correct Answer by Tom Watts about 3 years 8 months ago

Hi Wesley, I believe for the static host, you need to configure all of the options. option 3 and option 6 for default router and dns respectively.



-Tom
Please mark answered for helpful posts

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Brandon Svec Tue, 11/26/2013 - 10:28
User Badges:
  • Silver, 250 points or more
  • Community Spotlight Award,

    Small Business, February 2016

Hi Wesley, refer to CLI guide:

http://www.cisco.com/en/US/docs/switches/lan/csbms/sf30x_sg30x/administration_guide/CLI_300_1_3.pdf


I think this is what you want:


Syntax

address ip-address {mask | prefix-length} {client-identifier unique-identifier | hardware-address mac-address}

no address

Parameters

  • address—Specifies the client IP address.

  • mask—Specifies the client network mask.

  • prefix-length—Specifies the number of bits that comprise the address prefix. The prefix is an alternative way of specifying the client network mask. The prefix length must be preceded by a forward slash (/).

  • unique-identifier—Specifies the distinct client identification in dotted hexadecimal notation. Each byte in a hexadecimal character string is two hexadecimal digits. Bytes are separated by a period or colon. For example, 01b7.0813.8811.66.

  • hardware-address—Specifies the MAC address.






-- please remember to rate and mark answered helpful posts --

Wesley Brighton Thu, 11/28/2013 - 11:09
User Badges:

Tom/Brandon/anyone


does anyone have a better solution for this?


or is this just a limitation of the IOS code that it does not allow DHCP reservation/assignments from within the vlan and static assigns are considered "outside" dhcp server?


that would mean a lot of duplicated work of assigning default router/dns/etc for every static host i want, which i am trying to avoid.

Wesley Brighton Tue, 11/26/2013 - 12:04
User Badges:

ok, so i was able to successfully add the static address...



show ip dhcp binding

DHCP server enabled.

The number of used (all types) entries is 1

The number of static entries is 1


IP address     Hardware address   Lease expiration     Type      State

---------------- ------------------ ------------------ ----------- -------

10.5.10.9     01.54.42.49.d9.45.      Infinite        manual    allocat

42                                                ed



now when i check the device, it does successfully have that IP address, but it does not statically assign it from the dhcp pool with the correct dns servers and default gateway.


i want to configure static dhcp assigns from within the pool if that makes sense


the device shows the ip, but no dns/default router, which means it has no internet connectivity.

Correct Answer
Tom Watts Fri, 11/29/2013 - 07:52
User Badges:
  • Green, 3000 points or more

Hi Wesley, I believe for the static host, you need to configure all of the options. option 3 and option 6 for default router and dns respectively.



-Tom
Please mark answered for helpful posts

Wesley Brighton Sat, 11/30/2013 - 03:01
User Badges:

Tom,


i am afraid you are right, but that just feels wrong that "reserved" dhcp assignments cannot be done outside the dhcp scope/pool configuration, as it means you will be duplicating a lot of information.


seems like a real waste to me.  i cant ever remember having to do this on enterprise cisco equipment.

viningele Sat, 11/30/2013 - 08:40
User Badges:

If you add those params to the pool do you still have to manually add to each host?  I can live with filling out option 3 & 6 in the pool via the gui or better yet through cli so you can add multiple dns's but per static host is a bit much.  It should "import all" from the pool or better yet the server.

Actions

This Discussion