×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Configuring several VLANs on a Cisco 881

Unanswered Question
Nov 27th, 2013
User Badges:

Hi,


I already have VLAN 1 configured with DHCP and NAT/PAT working properly.

The router has the WAN port connected to the Internet, and the Fa 0 connected to the LAN.


Now I define interface vlan 2 with a new address for a new IP range, and a new DHCP pool.


Now I use the same port (fa 0) as trunk, so I can use both VLANs there.


Is this apporach correct, or should I use two interfaces as access ports, one for VLAN1 and other for VLAN2?


Thank you in advance for your help!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Collin Clark Wed, 11/27/2013 - 11:44
User Badges:
  • Purple, 4500 points or more

Trunking is the correct approach. Using multiple switchports will work also, however I prefer trunking. It's not as easy to create loops with a single connection.   If you need more bandwidth and/or redundancy you can simply create a port channel and move multiple links into it.


Hope it helps.

gabrielblanco1 Wed, 11/27/2013 - 23:23
User Badges:

Hi and thank you for your answer.


That is what I did, but the Router 881 is a bit special and the ports for the LAN connection operate like a switch.


I have one port trunking, but the configuration is not like in a router, is like in a switch.

And all the links between the switches until the final destination are trunking as well.


Just the final switch has an access port for the VLAN2, where the device is, but it does not get contact with the router.


Might be the type of router? any configuration in the way through different switches?


If I get the solution I will post it, but would like some more tips


Thank you!

gabrielblanco1 Wed, 11/27/2013 - 23:42
User Badges:

Hi,


I did check it.


I am wondering if it can be done without using two interfaces on the router. However I could try it.


I paste here part of my configuration


ip dhcp pool VLAN

   network 192.168.132.0 255.255.255.0

   default-router 192.168.132.1

   dns-server 195.159.0.100 195.159.0.200 8.8.8.8

   lease 30

!

ip dhcp pool VLAN2

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 195.159.0.100 195.159.0.200 8.8.8.8

   lease 30

!


interface FastEthernet0

switchport mode trunk

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4


interface Vlan1

description LAN

ip address 192.168.132.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan2

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly


Thanks!

cadet alain Thu, 11/28/2013 - 03:02
User Badges:
  • Purple, 4500 points or more

Hi,

Is vlan 2 getting a dhcp address? ---> sh ip dhcp binding

if not debug ip dhcp server packet to see if it receives the dhcp discover messages and what it does with them

if so  is vlan 2 host natted when going to internet ? ---> sh ip nat translation | i x.x.x.x where x.x.x.x is vlan 2 host

if not then post sh run | s nat and sh access-list


Regards


Alain



Don't forget to rate helpful posts.

gabrielblanco1 Thu, 11/28/2013 - 03:07
User Badges:

Hi,


I tried with static IP address as well. But did not work.


Regarding the NAT, I did not get to the point of checking it, since I do not have connection from the router. I cannot ping from the router to the host, and there is no NAT there

cadet alain Thu, 11/28/2013 - 03:49
User Badges:
  • Purple, 4500 points or more

Hi,

So you can't ping your router from this host in vlan 2 ?

Can you provide a quick diagram of your topology and the entire running config from router as a  start


Regards


Alain



Don't forget to rate helpful posts.

anish.antony Wed, 04/15/2015 - 00:49
User Badges:

Hi Guys 

 

 

Did any one get the solution to this ?

i have a similar set up and would like to know if it works

LUKASZ KITA Thu, 11/28/2013 - 08:28
User Badges:

Hello,
What about the sub interfaces?
Did you try it.


Sent from Cisco Technical Support Android App

Actions

This Discussion

Related Content