×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

VoIP call between two 2901 over VPN tunnel failed - what to do?

Unanswered Question
Nov 27th, 2013
User Badges:

I have two small phone system iwth 2901 router and SPA502G phones. The systems are identical.

Internal calls works fine, but when attempt to call other system - call failed before ip connect established.

The other side described as voip dial-peer:


======

dial-peer voice 232 voip

destination-pattern 232

session target ipv4:10.108.196.201

voice-class codec 1

======


The ip address of other side (10.108.196.201) is available through the vpn tunnel type L2TP.

Ping always successful:


=====

#ping 10.108.196.201

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.108.196.201, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/42/52 ms

=====


In the reverse direction it is also all ok with IP and ping.


The VPN interface on other (server) side is reported as:

=====

#sh int Virtual-Access2.1

Virtual-Access2.1 is up, line protocol is up

  Hardware is Virtual Access interface

  Internet address is 10.108.195.1/30

  MTU 1464 bytes, BW 10000 Kbit/sec, DLY 100000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP Open

  Open: IPCP

  PPPoVPDN vaccess, cloned from Virtual-Template1

  Vaccess status 0x0

  Protocol l2tp, tunnel id 53685, session id 63166

  Keepalive set (10 sec)

     300 packets input, 6746 bytes

     316 packets output, 7009 bytes

  Last clearing of "show interface" counters never

=====


But when I call the number 232, I get call failed with cuse code 38 (Network Failure).

And no any activity detected on VPN interface (by debug ip packet detailed), it seems that call failed before send any bytes to VPN tunnel.


The output of debug voice ccapi in attached file.


What can I do to troubleshoot this problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Dennis Mink Wed, 11/27/2013 - 19:31
User Badges:
  • Blue, 1500 points or more

I suspect you do not have any h323 bind commands on your interfaces that connect the two gateways 

10.108.196.201 and this end.


send us the configs.



Thanks



=============================
Please remember to rate useful posts, by clicking on the stars below. 

=============================

SergSibIng Wed, 11/27/2013 - 19:55
User Badges:

Ok, I place now the "h323-gateway voip bind srcaddr" command to config of interfaces on both sides:


======

interface Vlan640

description phones-R1

ip address 10.108.204.1 255.255.255.224

h323-gateway voip bind srcaddr 10.108.204.1

end

======


and other side:

======

interface Vlan600

description inter-router communication

ip address 10.108.196.201 255.255.255.252

ip ospf network point-to-point

h323-gateway voip bind srcaddr 10.108.196.201

end

======


wuth no effect.

The Disconnect Cause code is again 38.

Maybe it is importatnt that the interface Vlan640 is also the local SIP registrar interface?

The LTE modem which runs VPN client is connected to this vlan with address 10.108.204.30. and the route to other side is:

=====

ip route 10.108.196.0 255.255.255.0 10.108.204.30

=====


Maybe I should make new vlan to external link in this case?    

SergSibIng Sun, 12/01/2013 - 16:24
User Badges:

The problem is located, now all wokrs fine.

The decigion is to make static routes for acces from phone to phone, not only from router to router.

Actions

This Discussion