×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CUCM doesn't show the translated number

Answered Question
Nov 27th, 2013
User Badges:

Hey guys,


I had this working on my Call Manager and not sure what has happened, was hoping someone could help.


I have a number of translation patterns configured so that if a user dials another user by their external DID number, the CM routes the call internally.


This still works - however after dialling the full external number, once the dialling is finished we used to see the translated (shortened internal) number of the phone but now we are only seeing exactly what was dialled.


Example:

Internal user has extension 2000, this extension has a DID of number 073072000


If I am on extension 2200 and I dial 073072000 then on my phones display it would change to 2000 as soon as I finished dialling digits.


Now for some reason it is no longer changing the number to 2000 after I finish dialling - it just displays the actual dialled digits of 073072000.


I know that the translation pattern is working, due to call access restrictions the call would normally be blocked.  It just is not showing the translated pattern on the phone display.


The pattern is configured as:


007307.2XXXX


The Called Party Transformation is set to discard PreDot.


Thoughts?


Correct Answer by Suresh Subramanian about 3 years 8 months ago

"Always Display Original Dialed Number" should be set False in callmanager service parameters. Please check

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Suresh Subramanian Wed, 11/27/2013 - 20:12
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Mobile User, October 2015

"Always Display Original Dialed Number" should be set False in callmanager service parameters. Please check

Eric Fuhrmann Wed, 11/27/2013 - 21:36
User Badges:

Thanks this was the setting I had changed!


I had turned it to True as this meant incoming calls from UCCX to agents then shows the callers number and not the CTI port that sends the call over to CUCM - which is annoying.

Sucks you can only have it one way or the other system wide.

Actions

This Discussion