×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Noob and his Ebay 831 Router

Answered Question
Nov 27th, 2013
User Badges:


I picked up an 831 Ethernet Router for 5$ on ebay just to set up two static IPs on my home network--simple boring. The manual says to hook up my PC one of the ethernet ports and set it to DHCP. This returns a odd DHCP value, 169.254.92.156 or 169.254.50.157. I expected 10.10.10.x




What do you think is going on? Did the last owner config the router with this strange subnet? Or is it borked?




Can I reset the modem without having to get the console cable?




What's more, I assumed this router could set up basic NAT static IP for the ethernet ports. But the manual only mentions DHCP. Searches on NAT and static IP didn't return any How-To or other useful getting started links.




The network is very simple. I have a cable modem and two PCs I want on this router. Any reason I can't expect to fix this?

<div class="mcePaste" id="_mcePaste" style="position: absolute; left: -10000px; top: 0px; width: 1px; height: 1px; overflow: hidden;" mcestyle="position: absolute; left: -10000px; top: 0px; width: 1px; height: 1px; overflow: hidden;"></div>

Correct Answer by johnnylingo about 3 years 8 months ago

It's been years since I've played with the 830 series, but if I recall there's 4 LAN ports and 1 WAN port.  The 4 LAN ports are grouped together in to a virtual interface called "Ethernet0" and the WAN port will be "Ethernet1". 


Honestly, my suggestion on the 831 is to toss it and get an 851 or 871 instead.  In addition to the weird interface naming, there's very limited software support both in terms of IOS and GUI-based management.  Also, they're limited to something like 4 Mbps of throughput.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
johnlloyd_13 Wed, 11/27/2013 - 22:21
User Badges:
  • Blue, 1500 points or more

hi chris,


the 169.254.x.x is an auto assigned IP (APIPA) when windows machine can't get an IP via DHCP.


i believe, there's no reset button on this kind of router and you'll need to a console cable to see if the router boots properly.


once you get a console connection, we could set up your router using CLI or do a basic setup for GUI management (whichever you're comfortable with).

Correct Answer
johnnylingo Fri, 11/29/2013 - 22:52
User Badges:
  • Bronze, 100 points or more

It's been years since I've played with the 830 series, but if I recall there's 4 LAN ports and 1 WAN port.  The 4 LAN ports are grouped together in to a virtual interface called "Ethernet0" and the WAN port will be "Ethernet1". 


Honestly, my suggestion on the 831 is to toss it and get an 851 or 871 instead.  In addition to the weird interface naming, there's very limited software support both in terms of IOS and GUI-based management.  Also, they're limited to something like 4 Mbps of throughput.

Dennis Mink Mon, 12/02/2013 - 18:52
User Badges:
  • Blue, 1500 points or more

can you attach the config you have so far




=============================
Please remember to rate useful posts, by clicking on the stars below. 

=============================

Chris Simon Thu, 12/05/2013 - 17:10
User Badges:

Thank you for all your replies.

First, The cheapness of these old routers really suit my purpose. This unit will be part of a presentation I've been working up for my local Public Library. So, really, the cheaper the better--provided they work. In the end I hope to explain setup of a Dynamic DNS web server with your own URL all from used eBay parts and Linux. There are some crazy great deals out there, and some real nutty trends (I've bid on several 871s that went < 50$, and had several my 75$ offers rejected.


Second, my immediate goal seemed simple enough. I want to set a static IP for each of two computers, and a wireless modem, I fully expected the GUI web portal at 10.10.10.1 to handle this. But I find the Cisco Router Web Setup documentation not relevant to what I'm experiencing, and I can't find any similar documentation at Cisco to explain console setup (PC to Router).


I'm new to Cisco products. I don't have any familiarity with Cisco terminology to efficiently navigate the site.


I'm working on PC laptop running Arch Linux and a RAID server (with the necessary connector) running CentOS6. So, I can follow instructions for CLI--if I can find them. Any help with links to docs or explanations of what I need to do to achieve the basic configuration goal will be a great help.

johnlloyd_13 Thu, 12/05/2013 - 18:43
User Badges:
  • Blue, 1500 points or more

hi chris,


if you can get a console session and issue a show run command from the 831, that'll be a great way to start.


also, kindly provide a brief description (or text network diagram) of what you would want to achieve.

Chris Simon Thu, 12/26/2013 - 18:51
User Badges:

Ok. I've managed to figure out how to connect to the router and get the requested info, but there's not much to my configuration.


    Router>enable


    Router#show run

    Building configuration...


    Current configuration : 580 bytes

    !

    version 12.2

    no service pad

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname Router

    !

    logging queue-limit 100

    !

    ip subnet-zero

    !

    !

    ip audit notify log

    ip audit po max-events 100

    no ftp-server write-enable

    !

    !

    !

    !


I've been trying to reset the router so I can use Cisco Router Web Setup as described by the quick start page I cited above.


As I said, I was able to connect and I entered the device configuration dialog just as I found instructions in this link. Did I unwittingly circumvent CRWS when I entered this information? The only real difference is this setup assigns the router IP as 10.1.1.1. But it doesn't seem to make a difference using 10.10.10.1 or 10.1.1.1 in a browser. (the router never gives the client--CentOS--an IP). I followed some advice from stackexchange to reset the password as described here in the hopes this would reset the default configuration. This was not successful.


However, now I feel confident I can follow a command prompt configuration script if I have the right one. The trouble is searching for instructions with 831 only turns up this quick start guide I mentioned above. I found these documents here at Cisco, but I don't know all the Cisco-terms to read these pages and know they're what I want


Configuring Wide Area Network Connections (setup the 831 to connect to the cable modem)

Configuring DHCP, DDNS, and WCCP Services (setup DDNS)

Configuring Network Address Translation and Static Port Address Translation to Support an Internal Web Server (setup NAT, static IP for Internal Web Server)


Can I cobble together a configuration for the 831 from these pages given where I'm starting from? Will these help me setup NAT on the four ethernet ports (two client compters and one web server) with DDNS on the 831 connected to my IPS's Cable modem?

pieterh Mon, 12/30/2013 - 13:19
User Badges:

.???
You were able to "enable"
So there is no enable password set?
To reset the default config do "write erase" and reload

Sent from Cisco Technical Support iPad App

Chris Simon Mon, 12/30/2013 - 17:09
User Badges:

@Pieterh, Thanks for the reply. I performed the actions you  described. Unfortunately these did not restore the missing CRWS  functionality as described in the quickstart guide linked above. And  this may be the result of not being able to get an IP, so the router  remains unreachable.


I'm connected via the console cable and with a  cross-over cable to port 4. I've disabled Network Manager on CentOS and  I'm using a network-script configured to DHCP and the command  `/etc/init.d/network restart` to get the IP.


// EDIT:

Also, the eBay seller has responded to my frustration with this:

"When it comes to these routers there is no "factory reset", there are  either configs on them or no configs on them. [...] As far as the web  interface is concerned, you still need to console into the router and do  some configuring to enable the web interface."


From what I've experienced, this sounds about right. WHICH leads me back to my last question. Can I just pick and choose among the How-tos I find here to cobble together the setup I need (described above). Maybe someone familiar with the 831 can take a look at these links and tell me if they apply to or not and why. I'm not asking really for someone to go over these links and guarantee they'll work. More that I'm on the right track with how I can use this web site and if I'm understanding these documents correctly.


For example, the last link has these first few messages which are either helpful or useless depending on how well written the documentation is on the site:

Prerequisites


Requirements


There are no specific requirements for this document.


Components Used


This document is not restricted to specific software and hardware       versions.


cadet alain Wed, 01/01/2014 - 06:41
User Badges:
  • Purple, 4500 points or more

Hi,

Tell us the IP of your modem,which ip addressing you want for your LAN and what ports you want to forward on your server and we willprovide you a CLI running-config to achieve your needs.


Regards


Alain



Don't forget to rate helpful posts.

Chris Simon Wed, 01/01/2014 - 10:16
User Badges:

Cadet Alain said,

Tell us the IP of your modem,which ip addressing you want for your LAN  and what ports you want to forward on your server and we willprovide you  a CLI running-config to achieve your needs.


Have I found IT heaven? haha.


Sure.

1 Three networking devices:

1.1 ISP provided cable modem with dynamic IP served from the cable provider/ISP ($39/mo)

1.2 This Cisco 831 router (10.10.10.1) ($19.50)

1.2.1 E1 Port connected to (1.1)

1.2.2 E0 Ports 1-4 connected to each,

1.2.2.1 Public HTTP Server (static 10.10.10.2) ($150, 2004 5-disk RAID)

1.2.2.2 Belkin WiFi Router (static 10.10.10.3) ($24)

1.2.2.3 General use (static 10.10.10.4)

1.2.2.4 General use (static 10.10.10.5)


The Public HTTP Server must then be accessible from my own url. I currently have ZoneEdit. Their site claims I can setup DDNS [1] ($12/yr).


----

That's what I'm trying to put together for this presentation. Cheap, Huh? ~$200 equipment and $492 + $9 DNH = $701 to host your own web site for a year. I think I paid almost that for a 500MB hard disk drive once. ahaha.


----

[1]: http://zoneedit.com/dynamicDNS.html

cadet alain Wed, 01/01/2014 - 12:22
User Badges:
  • Purple, 4500 points or more

int e1

description To Cable Modem

ip address x.x.x.x x.x.x.x  IP address in same subnet as ISP modem

ip dhcp client client-id ethernet1

ip nat outside

no shutdown


int vlan 1

ip address 10.10.10.1 255.255.255.0

ip nat inside


ip dhcp excluded-address 10.10.10.1 10.10.10.5

no ip dhcp conflict logging

ip dhcp pool mypool

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server x.x.x.x   where x.x.x.x is ISP cable modem IP address


access-list 1 permit 10.10.10.0 0.0.0.255

ip nat inside source list 1 interface ethernet1

ip nat inside source static tcp 10.10.10.2 80 interface ethernet1 80


You'll need to port forward from Internet to dhcp address of ethernet1 on tcp port 80

To see this IP : sh ip int brief

Test this first and tell us if:

-client can get ipconfig from the 831 with correct settings

-cisco 831 can ping external IP like 8.8.8.8

-client can ping Cable Modem

-client can ping external IP 8.8.8.8

-you can access webserver from outside on WAN IP from Cable Modem

If everything is ok then you'll do the dyndns on your cable Modem and you'll do a static dhcp lease for cisco 831

on cable modem.


Regards


Alain



Don't forget to rate helpful posts.

Chris Simon Wed, 01/01/2014 - 16:42
User Badges:

@cadet alain

"If everything is ok then you'll do the dyndns on your cable Modem"


Time out. I don't think this cable modem is user configurable (Arris TM-822)[1]. Its just whatever the Cable Company provided when I signed up for the service.


The 800 series is advertised as a telecommuter product [2]. Surly as a telecommuting solution it would be necessary to have some "modem" such as DSL or Cable...?


Can you please explain your choice to push this config to the access point?


[1]: http://www.arrisi.com/products/product.asp?id=80

[2]: http://www.cisco.com/en/US/prod/collateral/routers/ps380/ps4874/product_data_sheet09186a008010e5c5.html

cadet alain Wed, 01/01/2014 - 23:22
User Badges:
  • Purple, 4500 points or more

Hi,

The AP is the Belkin in your topology provided you can put it in AP mode only otherwise you'll have to do some more configs and your wifi clients will be on a different subnet.

Did you try the config I provided then we'll take care of dyndns.


Regards


Alain



Don't forget to rate helpful posts.

cadet alain Thu, 01/02/2014 - 13:58
User Badges:
  • Purple, 4500 points or more

Hi,

enable

config t

then type all commands I gave.

all commands under int e1 and int vlan 1 are interface config commands

when in global config type int x to get into interface config mode

you have no router config commands here and others are global config commands which put you in some submodes.

the mode you're in is in the prompt in parenthesis.


Regards


Alain


Don't forget to rate helpful posts.

Chris Simon Thu, 01/02/2014 - 14:11
User Badges:

@cadet alain,

ip address x.x.x.x x.x.x.x  // IP address in same subnet as ISP modem

This is not a static IP. Its dynamic--this value will change. I'm sorry if I didn't make that clear from the beginning.

cadet alain Thu, 01/02/2014 - 14:23
User Badges:
  • Purple, 4500 points or more

Hi,

sorry I gave you wrong command, it is ip address dhcp  as your isp modem is dhcp server.


Regards


Alain



Don't forget to rate helpful posts.

Chris Simon Thu, 01/02/2014 - 16:14
User Badges:

@cadet alain,

Turns out IOS 12.2 doesn't have several of these commands. For the first example, I think I found a substitute:

     ? ip dhcp client client-id ethernet1         // this appears to be IOS 12.4

     # ip address dhcp client-id ethernet1    // I changed it to this



Unfortunately I can't find a substitute for vlan in 12.2 documentation .

? int vlan 1                    // this command won't work

# ip address 10.10.10.1 255.255.255.0          // router ip

# ip nat inside               // NAT


/** I see the "excluded-address" reflects the four ethernet ports which I hope to use static 10.10.10.2-5. Why `mypool`? There's no DHCP addresses in this config. Delete this section?

**/

# ip dhcp excluded-address 10.10.10.1 10.10.10.5

# no ip dhcp conflict logging

# ip dhcp pool mypool


# network 10.10.10.0 255.255.255.0       // back to the router

# default-router 10.10.10.1


/** This block is the planned DDNS? As you suggested above, put this off until NAT is working. Delete?

**/

# dns-server x.x.x.x   where x.x.x.x is ISP cable modem IP address

# access-list 1 permit 10.10.10.0 0.0.0.255


/** Back to the NAT config **/

# ip nat inside source list 1 interface ethernet1

# ip nat inside source static tcp 10.10.10.2 80 interface ethernet1 80



Again, I'm a noob so getting these bold sections to map onto the 12.2 NAT config I found here on site is blowing my mind,

# ip nat inside source static local-ip  global-ip

# interface type number

# ip nat inside

# interface type number

# ip nat outside



[1]: http://www.cisco.com/en/US/docs/ios-xml/ios/ipaddr_dhcp/configuration/12-4t/config-dhcp-client.html

[2]: http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfdhcp.html

[3]: http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfipadr.html/vlan

pieterh Fri, 01/03/2014 - 00:18
User Badges:

>>> ? int vlan 1 // this command won't work <<<

That will be because the router is only a router, not a switch

the 4-port switch built into this router does not support multiple VLAN's


>>>

Why `mypool`? There's no DHCP addresses in this config. Delete this section?

**/

# ip dhcp excluded-address 10.10.10.1 10.10.10.5

# no ip dhcp conflict logging

# ip dhcp pool mypool


# network 10.10.10.0 255.255.255.0 // back to the router

# default-router 10.10.10.1

<<<

These commands setup the router as dhcp server for the LAN ports.

If you use only static adresses here you can remove all references

The default-router command used here defines the default router for the dhcp clients in this pool / network 10.10.10.0/24

you can also assign other dhcp-options heer like a nameserver or dns domain-suffix for the clients.

the exclude command reserves space for the router address itself (10.10.10.1) and some room for other static adresses.

pieterh Fri, 01/03/2014 - 00:46
User Badges:

by the way,

the reason for not getting a dhcp-address may be caused by the autonegotiate handshake between client and router.

In some situations the dhcp-request on the client times out before the speed/duplex negotiation has finished, or because this handshake has resulted in a mismatch.

try setting speed/duplex fixed -> NB! either BOTH sides fixed or both sides auto.

Chris Simon Fri, 01/03/2014 - 09:14
User Badges:

@pieterh

...you can also assign other dhcp-options heer like a nameserver or dns domain-suffix for the clients.

is a DHCP pool necessary for DDNS (Dynamic DNS)?

I shouldn't think so, but I an a noob.


----

Also, Found another set-up for IOS 12.0 for modem to 805 router with very explict instructions--very noob friendly (^_^)

(http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080093e51.shtml)


PS. I just noticed my replies are running out of <------> room!!


//redundant

pieterh Sun, 01/05/2014 - 23:46
User Badges:

>>>

is a DHCP pool necessary for DDNS (Dynamic DNS)?

I shouldn't think so, but I an a noob.

<<<


the DHCP pool is for the local lan

DDNS is needed for the public internet to find you by name.especially if your provider issues you changing adresses (dhcp on provider side).

if you have got a fixed address at your provider, then you can register a fixed DNS entry.

Chris Simon Tue, 01/14/2014 - 18:00
User Badges:

We've discussed quite a few things here, the AP is a DHCP server, inside local addresses are static (and not DHC)P, and no vlan for this 831 that's not a switch. I've edited the original recommended commands but there are still a few questions (n).

Router> enable

Router(config)# conf t                                      


Router(config)# int e1

Router(config)# description ToCableModem

Router(config)# ip address dhcp client-id ethernet1      

Router(config)# ip nat outside

Router(config)# no shutdown


/** (1) Delete this since this doesn't do vlan?

Router(config)# int vlan                                   

Router(config)# ip address 10.10.10.1 255.255.255.0

Router(config)# ip nat inside

**/


/** (2) delete this as per pieterh...?

# ip dhcp excluded-address 10.10.10.1 10.10.10.5

# no ip dhcp conflict logging

# ip dhcp pool mypool

**/


/** (3) Is this complete BS? **/

Router(config)# ip nat inside source static 10.10.10.10.2 dhcp

Router(config)# ip nat inside source static 10.10.10.10.3 dhcp

Router(config)# ip nat inside source static 10.10.10.10.4 dhcp

Router(config)# ip nat inside source static 10.10.10.10.5 dhcp


Router(config)# interface ethernet1

Router(config-if)# ip nat inside


Router(config)# interface ethernet0

Router(config-if)# ip nat outside


Router(config)# network 10.10.10.0 255.255.255.0

Router(config)# default-router 10.10.10.1


Is this enough to simply map the inside local addresses to the inside global address (dynamic IP at the cable model, right?)


My cisco-vocabulary is improving. Learn something new--again!

pieterh Tue, 01/14/2014 - 23:25
User Badges:

no this line wont work

Router(config)# ip nat inside source static 10.10.10.10.2 dhcp


change the "dhcp" to "interface Ethernet0 overload"

this tells rhe router to use the adress of the outside interface for NAT.


more flexible would be to use an access-list


access-list 102 permit ip 10.10.10.10.0 0.0.0.255 any

route-map INTERNET permit 10
match ip address 102

ip nat inside source route-map INTERNET interface Ethernet0 overload


by tuning the access list you can select wich hosts can do NAT for outgoing traffic.

Chris Simon Thu, 01/16/2014 - 16:49
User Badges:

I did a quick search for this "access list NAT for outbound traffic". I see the issue is quite extensive and relevant [1] [2] Of course, these links are from the initiated. I'm not sure why my hosts would be "do(ing) NAT for outgoing trarric". I thought I was setting up the router to do this...? And reading another Cisco page has this comment on access lists:

Inbound and Outbound Access List Overview

By default, all traffic from a higher-security interface to a  lower-security interface is allowed. Access lists let you either allow  traffic from lower-security interfaces, or restrict traffic from  higher-security interfaces. [3]

Shouldn't I want to allow traffic from higher-security (my home network) to lower security (the world) by default, therefore all hosts? Does that make sense?

cadet alain Mon, 01/20/2014 - 03:40
User Badges:
  • Purple, 4500 points or more

Hi,

The link you provided the exerpt from is for an ASA which is a firewall not for a router.

By default routers don't filter any traffic whether it be from LAN to WAN or from WAN to LAN but if you use RFC1918 in your LAN then you need NAT( dynamic for LAN to WAN and return) or static for WAN to LAN(and return as the private IP addresses are non routeable on the Internet.


Regards


Alain



Don't forget to rate helpful posts.

pieterh Wed, 01/22/2014 - 13:15
User Badges:

my formulation is wrong,
What I meant is not the hosts do nat,
But the hosts are alowed to be NATted by the router.

Sent from Cisco Technical Support iPad App

Actions

This Discussion

Related Content