×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Need clarification regarding ip address assignment to Vlans

Unanswered Question
Nov 27th, 2013
User Badges:

Hi,

    I want to know one things about methods we can assign ip address to switch virtual interfaces



Core-Switch#sh ip int bri

Interface                  IP-Address      OK? Method Status                Prot

ocol

FastEthernet0/0            unassigned      YES TFTP   administratively down down


FastEthernet0/1            unassigned      YES TFTP   administratively down down


FastEthernet1/0            unassigned      YES unset  administratively down down


FastEthernet1/1            unassigned      YES unset  up                    up

.      

.

.

FastEthernet1/15           unassigned    YES unset  up                    down


Vlan1                          unassigned     YES TFTP   up                    up


Vlan100                    172.28.100.3    YES TFTP   up                    down


Vlan110                    172.28.110.3    YES TFTP   up                    down


Vlan120                    172.28.120.3    YES TFTP   up                    down


Vlan130                    172.28.130.3    YES TFTP   up                    down


Vlan140                    172.28.140.3    YES TFTP   up                    down


Vlan150                    172.28.150.3    YES TFTP   up                    down


Vlan160                    172.28.160.3    YES TFTP   up                    down


Vlan200                    172.28.200.3    YES TFTP   up                    down

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Damien Miller Wed, 11/27/2013 - 21:45
User Badges:

Hello Mohammed,


Can you provide a "sh version" and running configuration as well as rephrase your question.  From the outputs that you have provided it is not clear what you are asking for clarification on.

mdaswathali Wed, 11/27/2013 - 22:11
User Badges:

Hi damien,

         for your ref i am posting the output of show version command and Show Run-conf,

Now I will brief my question here . I have a swith configuration file in switch's flash system, I manually copied the config file from flash to a runnig configuration . After copying as a running config from flash, when i checked,  all the virtual interfaces are assigned with ip and but i am not able to ping the Vlan ips



Core-Switch#show vers

Core-Switch#show version

Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(6)T, RELEASE SO

FTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Thu 23-Feb-06 00:08 by ccai


ROM: ROMMON Emulation Microcode

ROM: 3600 Software (C3660-IK9O3S-M), Version 12.4(6)T, RELEASE SOFTWARE (fc1)


Core-B uptime is 1 minute

System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0

x0, BOOT_COUNT 0, BOOTDATA 19

System image file is "tftp://255.255.255.255/unknown"



This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.


A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


If you require further assistance please contact us by sending email to

[email protected].


Cisco 3660 (R527x) processor (revision 1.0) with 155648K/8192K bytes of memory.

Processor board ID FTX0945W0MY

R527x CPU at 250MHz, Implementation 40, Rev 1.2, 512KB L2 Cache



3660 Chassis type: ENTERPRISE

18 FastEthernet interfaces

DRAM configuration is 64 bits wide with parity enabled.

125K bytes of NVRAM.

8192K bytes of processor board System flash (Read/Write)


Configuration register is 0x2102


Core-Switch#



The running-configuration is given below :



Core-B#sh run

Building configuration...


Current configuration : 2065 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Core-B

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

no ip icmp rate-limit unreachable

ip tcp synwait-time 5

!

!

ip cef

no ip domain lookup

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree vlan 100 priority 16384

spanning-tree vlan 110 priority 16384

spanning-tree vlan 120 priority 16384

spanning-tree vlan 130 priority 16384

spanning-tree vlan 140 priority 8192

spanning-tree vlan 150 priority 8192

spanning-tree vlan 160 priority 8192

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1/0

shutdown

!

interface FastEthernet1/1

switchport mode trunk

!

interface FastEthernet1/2

switchport mode trunk

!

interface FastEthernet1/3

!

interface FastEthernet1/4

!

interface FastEthernet1/5

!

interface FastEthernet1/6

!

interface FastEthernet1/7

!

interface FastEthernet1/8

!

interface FastEthernet1/9

!

interface FastEthernet1/10

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Vlan1

no ip address

!

interface Vlan100

ip address 172.28.100.3 255.255.255.0

!

interface Vlan110

ip address 172.28.110.3 255.255.255.0

!

interface Vlan120

ip address 172.28.120.3 255.255.255.0

!

interface Vlan130

ip address 172.28.130.3 255.255.255.0

!

interface Vlan140

ip address 172.28.140.3 255.255.255.0

!

interface Vlan150

ip address 172.28.150.3 255.255.255.0

!

interface Vlan160

ip address 172.28.160.3 255.255.255.0

!

interface Vlan200

ip address 172.28.200.3 255.255.255.0

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

--More--

Karthick Murugan Wed, 11/27/2013 - 22:28
User Badges:
  • Cisco Employee,

Hi,


It looks like all your VLANs are in UP/DOWN so it wont ping for sure. We need atleast one interface to be part of the VLANs to bring-up the VLAN.


Please check "show spanning-tree vlan 100" You should see atleast one interface in forwarding state.




Thanks & Regards,
Karthick Murugan
CCIE#39285

Actions

This Discussion