×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

basic Cisco 887VA Config

Unanswered Question
Nov 28th, 2013
User Badges:

HI i am currently banging my head against a desk trying to figure out what i am missing here, I am trying to configure A Cisco 887VA router to connect to the internet:

I can get the router to ping www.google.com

I can ping the internal LAN (192.168.0.2)

I can see the router from the LAN

I can see the router from the internet


So my problems are:

1/ I can’t get the router to pass information from the LAN to the WAN (I can’t see the internet from the LAN)

2/ I can’t get the username & password to work for the “IP http server”


What am i doing wrong here? Any help would be greatly appreciated…




The Router version Info is:


Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.2(4)M4, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Thu 20-Jun-13 16:47 by prod_rel_team


ROM: System Bootstrap, Version 12.4(22r)YB5, RELEASE SOFTWARE (fc1)


Telstra-ADSL_Router uptime is 2 hours, 26 minutes

System returned to ROM by reload at 00:15:44 UTC Fri Nov 29 2013

System image file is "flash:c880data-universalk9-mz.152-4.M4.bin"

Last reload type: Normal Reload

Last reload reason: Reload Command




This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.


A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


If you require further assistance please contact us by sending email to

[email protected].


Cisco 887VA (MPC8300) processor (revision 1.0) with 236544K/25600K bytes of memory.

Processor board ID FGL17382417


1 DSL controller

1 Ethernet interface

4 FastEthernet interfaces

1 ATM interface

1 Virtual Private Network (VPN) Module

256K bytes of non-volatile configuration memory.

125440K bytes of ATA CompactFlash (Read/Write)



License Info:


License UDI:


-------------------------------------------------

Device#   PID                   SN

-------------------------------------------------

*0        CISCO887VA-SEC-K9     FGL17382417



License Information for 'c880-data'

    License Level: advipservices   Type: Permanent

    Next reboot license Level: advipservices



Configuration register is 0x2142









The current Configuration is:


Telstra-ADSL_Router#show config

Using 2705 out of 262136 bytes

!

! Last configuration change at 02:08:19 UTC Fri Nov 29 2013 by admin

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Telstra-ADSL_Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

memory-size iomem 10

!

crypto pki trustpoint TP-self-signed-3115301035

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3115301035

revocation-check none

rsakeypair TP-self-signed-3115301035

!

!

crypto pki certificate chain TP-self-signed-3115301035

certificate self-signed 01 nvram:IOS-Self-Sig#5.cer

no ip source-route

!

!

!

!



!

ip dhcp excluded-address 192.168.0.0 192.168.0.10

!

ip dhcp pool lan

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 139.130.4.4 203.50.2.71

lease infinite

!

!

!

no ip bootp server

ip domain name leary.net.au

ip name-server 139.130.4.4

ip name-server 203.50.2.71

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

license udi pid CISCO887VA-SEC-K9 sn FGL17382417

!

!

archive

log config

  hidekeys

username (username) password 0 (password)

!

!

!

!

!

controller VDSL 0

!

ip ssh time-out 90

ip ssh authentication-retries 2

!

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface ATM0

description --- Internode ADSL ---

no ip address

no atm ilmi-keepalive

pvc 8/35

  tx-ring-limit 3

  encapsulation aal5snap

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Vlan1

description --- Ethernet LAN ---

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip nat enable

ip virtual-reassembly in

ip tcp adjust-mss 1420

!

interface Dialer0

description --- Internode ADSL ---

ip address (Public IP Address) (Subnet)

ip mtu 1460

ip nat outside

ip virtual-reassembly in

encapsulation ppp

ip tcp adjust-mss 1420

dialer pool 1

dialer-group 1

ppp chap hostname (ISP Username)

ppp chap password 0 (ISP password)

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

!

!

no ip nat service sip udp port 5060

ip nat inside source list NAT interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip access-list extended MGMT-IN

permit ip (Public IP Address) (Subnet) any

permit ip 192.168.0.0 0.0.0.255 any

ip access-list extended NAT

permit ip 192.168.0.0 0.0.0.255 any

!

no cdp run

!

!

control-plane

!

!

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

access-class MGMT-IN in

login local

transport input all

!

scheduler max-task-time 5000

sntp server 192.168.0.9

!

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion