Connect Hg2845 to cisco 3560-x switch to distribute internet

Unanswered Question
Dec 5th, 2013
User Badges:

Hello All,

First of all I am a novice when it comes to cisco switches and routers.


I will provide you the setup I have :


1) 1x Huawei HG2845 wireless modem/ router with Fiber connection coming from the Vendor. It is a shared connection

IP Address: 192.168.100.1


I can access the wireless connection on my devices to access the internet from this Huawei device.



2) 1x Cisco 3560-X PoE switch which is brand new [not configured] with connections to the end users

IP Address : 10.0.0.1 [default IP of cisco, I believe]


I connected the HG2845 to the Cisco via a straight through cable. I connected it to the 39th port of the switch [Gigabit Ethernet 0/39]. There is no specfic Up/Downlink ports with this switch.




What are the settings/commands I would require to do in order for


          a) the internet to be available to the devices connected via the switch ?

          b) Do I require any other devices for this to work?




Looking forward for techies reply.


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Loading.
cadet alain Fri, 12/06/2013 - 02:09
User Badges:
  • Purple, 4500 points or more

Hi,

1° on switch:

-on port connected to Huawei:

int g0/39

no switchport

ip address 192.168.100.x 255.255.255.0

-in global config:

ip routing

ip route 0.0.0.0 0.0.0.0 192.168.100.1


2° on Huawei:

-configure a route for the client subnet behind the switch pointing to the ip address of the switch(192.168.100.x)


All of this is assuming that the Huawei can NAT not directly connected networks otherwise you'll have to insert a router or firewall in between that will nat the switch subnet.

Of course you could change other stuff on the switch but they are not mandatory for your topology to work( change the vlan assignment,configure switch as vtp transparent,change the management vlan,...)


Regards


Alain


Don't forget to rate helpful posts.

abidpandhakkil Fri, 12/06/2013 - 03:47
User Badges:

Dear Alain,


Thank you for your response.


As per your guidance:


On Int G0/39

Ip address 192.168.100.2 255.255.255.0


## It gives the message : %IP-4-DUPADDR: Duplicate address 192.168.100.1 on GigabitE

thernet0/39, sourced by 200b.c771.a491 #######


Anyhow, I have completed the rest of the commands as well on the Switch. However, I have concerns regarding setting up the Huawei route. Please find attached 2 pics from the huawei panel



PS: I have a Cisco 1941 as well if introducing that helps in the connectivity.


Looking forward for your reply.


Thanks

cadet alain Fri, 12/06/2013 - 03:57
User Badges:
  • Purple, 4500 points or more

Hi,

Can you provide the running config of the switch and specify the IP config  of huawei.

How are your 2 devices connected ?


Regards


Alain



Don't forget to rate helpful posts.

abidpandhakkil Fri, 12/06/2013 - 05:46
User Badges:

Running Config of switch can be found below: Pls note that I changed the Gi0/39 to switchport mode access from no switchport.


There are 4 LAN ports for the Huawei:


LAN3 is connected to Switch via RJ45 on Gi0/39





-------------

For Huawei IP


LAN IP : 192.168.100.1


DHCP : TURNED OFF


DNS : 192.168.100.1


WAN IP : ISP IP [NoT Dedicated]



---------------------

Cisco 3560 Catalyst Config:



Version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname switch2

!

boot-start-marker

boot-end-marker

!

!

!

!

no aaa new-model

system mtu routing 1500

ip routing

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

shutdown

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

!

interface GigabitEthernet0/14

!

interface GigabitEthernet0/15

!

interface GigabitEthernet0/16

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface GigabitEthernet0/29

!

interface GigabitEthernet0/30

!

interface GigabitEthernet0/31

!

interface GigabitEthernet0/32

!

interface GigabitEthernet0/33

!

interface GigabitEthernet0/34

!

interface GigabitEthernet0/35

!

interface GigabitEthernet0/36

!

interface GigabitEthernet0/37

!

interface GigabitEthernet0/38

!

interface GigabitEthernet0/39

switchport mode access

!

interface GigabitEthernet0/40

!

interface GigabitEthernet0/41

!

interface GigabitEthernet0/42

!

interface GigabitEthernet0/43

!

interface GigabitEthernet0/44

!

interface GigabitEthernet0/45

!

interface GigabitEthernet0/46

!

interface GigabitEthernet0/47

!

interface GigabitEthernet0/48

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface GigabitEthernet1/3

!

interface GigabitEthernet1/4

!

interface TenGigabitEthernet1/1

!

interface TenGigabitEthernet1/2

!

interface Vlan1

ip address dhcp

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.100.1

ip http server

ip http secure-server

!

!

!

line con 0

line vty 5 15

!

end


----------------------



Please let me know if you need any further info:



Thanks

Actions

This Discussion

Related Content