Will a Cisco SMB SG300 Switch support DHCP Option 156?

Answered Question
Dec 5th, 2013
User Badges:
  • Bronze, 100 points or more
  • Community Spotlight Award,

    Small Business, May 2015

Hi All,


Is it possible to configure option 156 on a Cisco Sx300 DHCP scope? Its for Shoretel IPT's.. I noticed that the option isn't available via the GUI. But I tried it the other day on a switch with the latest firmware release via the CLI and it nearly worked but I couldn't get the switch to accept the exact string i needed.. For example below (on Cisco classic):


option 156 ascii "ftpservers=172.16.250.21, country=7, language=4, layer2tagging=1, vlanid=100"


Any pointers gratefully received..

Thanks in advance


Matt

Correct Answer by Tom Watts about 3 years 8 months ago

Hi Matthew, the supported DHCP server options are as follows-

1,3,4,6, 12, 15, 44, 46, 50, 51, 53. 54, 55, 56, 58, 59 and 61.




-Tom
Please mark answered for helpful posts

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Tom Watts Thu, 12/05/2013 - 10:38
User Badges:
  • Green, 3000 points or more

Hi Matthew, the supported DHCP server options are as follows-

1,3,4,6, 12, 15, 44, 46, 50, 51, 53. 54, 55, 56, 58, 59 and 61.




-Tom
Please mark answered for helpful posts

Matthew Needs Fri, 12/06/2013 - 06:09
User Badges:
  • Bronze, 100 points or more
  • Community Spotlight Award,

    Small Business, May 2015

Thanks Tom very helpful.. Shame its not supported but at least I know for future reference.


Have a good weekend


Matt

c923943 Sat, 01/04/2014 - 17:24
User Badges:

Hi Tom / everyone,


Is this still the case for the lastest firmware release?  The Release Notes for 1.3.5.x on the SG300 seem to indicate that the DHCP server has been updated to allow custom options to be defined:


  • Updated DHCP Server to add support for user-defined options for Sx300 and Sx500.


I'm currently using the DHCP Relay and a centralised DCHP Server on some spare hardware to provide these custom DHCP options through to hosts behind a number of SG300 switches because of the limitations of the current firmware. 


However if the latest firmware allowed custom DHCP options to be configured and served natively, that would let me rationalise hardware and turn one more energy guzzling power supply off!


Any info or thoughts from others who have upgraded would be welcomed.  As everything is working now - I'd prefer to only go through the upgrade process if I know I'm getting some additional value from it (or at least till its had some time for others to test it out for me )


This thread was the closest I could find in terms of DHCP server specific and the right timeliness of posts (i.e. 1.3.5.x release last November).


Regards

Nathan

Tom Watts Tue, 01/07/2014 - 16:31
User Badges:
  • Green, 3000 points or more

Well, I configured option 156 on the switch. If it works or not, I have no idea.


ip dhcp server

ip dhcp pool network test

address low 192.168.1.200 high 192.168.1.225 255.255.255.0

lease infinite

option 156 hex



-Tom
Please mark answered for helpful posts

Matthew Needs Wed, 01/08/2014 - 00:12
User Badges:
  • Bronze, 100 points or more
  • Community Spotlight Award,

    Small Business, May 2015

Hi Both,


I should be in a position to test this today.. I'll keep you posted.


Matt

Matthew Needs Tue, 01/14/2014 - 08:56
User Badges:
  • Bronze, 100 points or more
  • Community Spotlight Award,

    Small Business, May 2015

Hi All,


I've tried this.. But i cant get it to work im afraid :o(. Here's what I get..


Commands Entered:


ip dhcp pool network 172.16.17.0

option 156 ascii "ftpservers=172.16.250.21, country=7, language=4, layer2tagging=1, vlanid=100"


Output:


switch4221e7(config-dhcp)#$7, language=4, layer2tagging=1, vlanid=100"

DHCP server option parameters mismatch. This code 156 must be from other type.


I've tried all kinds of different CLI combinations but nothing seems to work.. The switch wont allow me to add any kind of ascii data under option 156. You could use option 66 as an alternative to 156 for Shoretel IPT's but it's not referenced as a supported option in the Cisco SX300 manual which is interesting? The commands are available in CLI & GUI. For option 66 you would need an external DNS server on which you would add a host record for the PBX Director (CPU). The SX300 does not support DNS Server.


Hope it helps someone! Please feel free to correct me if anyone gets this working or thinks im wrong in any way.. Id love to get this working.


All the best


Matt

c923943 Thu, 01/16/2014 - 21:06
User Badges:

Thanks Matt for giving it a try!


Looks like I will keep my current setup using a centralised DHCP server and distributed Relay setup, and remain on the 1.1.2.0 firmware.  If it ain't broke ...


Regards

Nathan

Matthew Needs Wed, 01/22/2014 - 02:07
User Badges:
  • Bronze, 100 points or more
  • Community Spotlight Award,

    Small Business, May 2015

Got an update for you Nathan.. It's good news! I've got option 156 working for Shoretel IPT's on an Sx300.. . A eureka moment really.. If you convert the DHCP Option 156 ASCII to HEX it all works perfectly! Simple really but its funny the things you miss sometimes. The Sx300 will not accept ASCII format although it is an option in CLI.


Here's an example for Voice VLAN 2. (Data on VLAN 1)


ASCII - HEX Convert.JPG


Switch Config: (Important parts anyway)


vlan database

vlan 2

exit

!

ip dhcp server

ip dhcp pool network Data

address low 172.16.1.11 high 172.16.1.100 255.255.255.0

default-router 172.16.1.6

option 156 hex 667470736572766572733d3137322e31362e322e372c20636f756e7472793d372c206c616e67756167653d342c206c617965723274616767696e673d312c20766c616e69643d32 description Shoretel

exit

ip dhcp pool network Voice

address low 172.16.2.11 high 172.16.2.100 255.255.255.0

default-router 172.16.2.6

option 156 hex 667470736572766572733d3137322e31362e322e372c20636f756e7472793d372c206c616e67756167653d342c206c617965723274616767696e673d312c20766c616e69643d32 description Shoretel

!

!

interface vlan 1

ip address 172.16.1.6 255.255.255.0

no ip address dhcp

!

interface vlan 2

name Voice

ip address 172.16.2.6 255.255.255.0

!

interface fastethernet1

switchport trunk allowed vlan add 2

!

interface fastethernet2

switchport trunk allowed vlan add 2

!


Good luck!


Hope it helps


Matt

Actions

This Discussion