cisco nac agent for windows 8.1

Unanswered Question
Dec 7th, 2013

            i have cisco nac agent with ISE 1.2 , i have some issues with windows 8.1 for example agent didn't popup.

is this vesrion supported with windows 8.1 ?

i tried to update agent from ISE but i can't see another version , also i downloaded 4.9.3 but when trying to import it in ISE it gives "error unzipping package"      

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
nginjupa Sun, 12/08/2013 - 19:51

Hi Ibrahim,

As per the compatibility matrix Cisco NAC Agent version on ISE 1.2 is supported for Windows 8 with IE 10. It means that you are on the supported version only.

For the agent not popping up , can you please check the below settings.

1)In Windows 8, Internet Explorer 10 has two modes: Desktop and Metro. In Metro mode, the ActiveX plugins are restricted. You cannot download the Cisco NAC Agent in Metro mode. You must switch to Desktop mode, ensure ActiveX controls are enabled, and then launch Internet Explorer to download the Cisco NAC Agent. (If users are still not able to download Cisco NAC agent, check and enable "compatibility mode.")

2)When you create a Cisco ISE client provisioning policy to accommodate Windows 8, you must specify the "Windows All" operating system option.

3)Windows 8 RT is not supported.

ibrahim_hassan Thu, 12/26/2013 - 01:57

we upgraded to latest ISE 1.2 patch 4 and agent to which support windows 8.1 as per its release notes.

but still have problems with agent working , it didn't open automatically and need to be opened from its shortcut.

this issue appeared with some users not all.

ibrahim_hassan Thu, 01/02/2014 - 02:04

any help please , we upgraded to patch 5 but still some users can't find Agent in startup list and must be opened manually.

Ahmad Murad Thu, 01/02/2014 - 09:46


We face this problem and we use the new NAC agent which is 4.9.4 as I remember so you need to crete new client provisioning policy for windows 8.1 and the new NAC and compliance agent.

Also the ISE patch must be installed, try the latest patch which is 5.


Sent from Cisco Technical Support iPad App

ibrahim_hassan Tue, 06/10/2014 - 04:23

Currently we use patch 8 and agent version and we still have the issue.

the issue is random (for example , appeared on machine X today but tomorrow working properly!)

Ahmad Murad Wed, 06/11/2014 - 14:53

Do you still face the error message appears on the NAC agent that the OS is not supported? If yes, then you need to know the exact version of your Windows 8/8.1 machines.

Can you please submit here a snip of the error message along with System Properties from the machine facing the problem?




mohanak Fri, 06/27/2014 - 10:40
Supported Cisco NAC Appliance Versions
Supported Browsers182
Java Version 183
Cisco NAC Agent 184
Web Login 185
Web Agent
L3 MAC (ActiveX/ Applet)
Web Agent (ActiveX/Applet) 186

4.9(4) / /

Internet Explorer 10187
Firefox 20.x

1.6_0_18 188

4.9(3) / /

Internet Explorer 10
Firefox 20.x


182.ActiveX is supported only on the 32-bit versions of Internet Explorer .

183.Java version 1.5 is the minimum version required for Java Applet support.

184.Testing on international languages has been verified with ActiveX. Although Cisco believes the installer runs successfully in the foreign language with Java, this has not been verified. In the event of a Java installer issue, Cisco NAC Agent installation on international language operating systems defaults to English.

185.Web login is not supported on 64-bit versions of Internet Explorer.

186.The temporal Cisco NAC Web Agent can be launched from the Web Login Facilitator using ActiveX from the Internet Explorer versions or via Java applet from the web browsers listed as supported for Windows systems.

187.You cannot install the Cisco NAC Agent or Web Agent using Metro Mode in Internet Explorer 10.

188.Java version 1.6_0_18 can cause a certificate authentication error. Refer to the caveat CSCte58249 in Release Notes for Cisco NAC Appliance, Version 4.7(2) for more information.


This Discussion