MESH AP not joining to the correct WLC

Unanswered Question
Dec 9th, 2013
User Badges:

Dears


I am  facing this issue.


We have location A and B  in offshore. They have fiber connectivity to our HQ.

Both location has different WLCs and APs associated to the local WLCs. There is APS,RAP & mesh AP.

Everything is workng fine.


We have a mesh AP in one of the ship which is moving between location A and B.



When the ships is A location, its associating to the WLC in A.

When we move to location B then also its associating to the WLC in B.


Both locatiions has local DHCP pools and AP is getting correct IPs from the local DHCP pool.

Options are configured properly on both pools.


If I set manually B WLC as primary and A WLC as secondary, Immediately its joined B WLC.



We need the AP to join automatically based upon the location where the ship is.



Can you please help me.


Regards

Deva

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Scott Fella Mon, 12/09/2013 - 06:22
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

You should not set the mesh ap high availability on the AP since the ship moves between two different sites. The AP will know of both WLC's if the WLC's are in the same mobility group.  You can set the primary and secondary on the Wireless tab > General Configuration and give that a try, but you need to remove the high availability on the mesh AP that moves between the sites.


Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

dnspacket1 Mon, 12/09/2013 - 06:34
User Badges:

Dear Scott,


Thanks for your update.

When the ships is in A location, its associating to the WLC in A.

When we move to location B then also its associating to the WLC in A.

If I set manually B WLC as primary and A WLC as secondary, Immediately its joined B WLC.



Do we have any other methods to automatically join the AP to local WLC  ?

There is 10 KM distance between A and B


If ship is in A location   WLC should be A

If ship is in B location   WLC should be B


Is there any way to make like this ?


Regards

Deva

Scott Fella Mon, 12/09/2013 - 06:50
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

You can try to configure the wlc's to be in different mobility groups. You can also disable ap fallback since the maps have to reassociate anyways to the rap

Sent from Cisco Technical Support iPhone App

dnspacket1 Mon, 12/09/2013 - 07:00
User Badges:

Dear scott,


I will try this options and update you soon


Regards

Deva

dnspacket1 Sat, 12/14/2013 - 10:59
User Badges:

Dear Scott,


Now the picture is more clear.


Seems  that MAP  keeps in memory which WLC was primary last time and try to  stick to it regardless of what was provided  via DHCP opt 43


After I set manually  A WLC as primary and B WLC as secondary  MAP  joining  A WLC after unit  was restarted .

When the vessel move to the B location,  still MAP joining  A WLC.

Then I set manually  B WLC as primary and A WLC as secondary  MAP  joining  B WLC after unit  was restarted .


Seems  that  Cisco was always considering APs  for use only at  fixed  locations and not for  scenario which we are facing here – AP on the  vessels is moving across geographical locations. 

It appears that  Cisco   concept for DHCP opt 43 is  kind of   assistance  option at   initial AP deployment  and not for selecting primary WLC if AP is moving  from one place to another. Once AP is connected to WLC it is supposed  to be manually configured for WLCs list



I wil try the folloeing options..

WLC's to be in different mobility groups

Bridge Group Names is the same on both WLCs A and B ?


Will keep you posted latest update


Regards

Deva

Scott Fella Sat, 12/14/2013 - 11:06
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

With MESH, an how the design is for regular access points, its not designed to keep switching WLC's.  That feature of what the AP is doing, is so that you never loose and AP and it makes the wireless stable. 


You need to keep the BGN the same, but I would change the mobility group and also disable AP Fallback.


Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

dnspacket1 Wed, 01/22/2014 - 04:46
User Badges:

Dear scott,


We are using the same BGN

Already the mobility group are different


We cannot disable the AP fall back options since the location is in off shore and we cannot afford any connectivity lose.


Do we have any other methods to fix this issue ?


Regards

Deva

Scott Fella Wed, 01/22/2014 - 04:58
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

I don't see any method to fix this since what your seeing is really how Cisco design this. The issue is the fact that the AP will either know of its primary or will decide what WLC it will join. There is a process the AP's go through when the MAP has lost the RAP and when it finally finds an available RAP. The one thing you can try is not set the high availability on the access point itself but set the backup primary controller on the WLC itself. Under the Wireless tab in the General configuration look at the right side. So when an AP joins that ELC, that WLC can tell that MAP that this is your primary and the other WLC is your secondary. See if that works.

Sent from Cisco Technical Support iPhone App

Actions

This Discussion