Point-to-Point Frame Relay OSPF question....please help. :-)

Unanswered Question
Dec 9th, 2013
User Badges:

I'm having some difficulty setting up the last part of my point-to-point frame-relay network.  I've been obsessing about voice so much the last several months that I have probably forgotten the basics of frame-relay over an OSPF point-to-point network.  I have successfully setup OSPF connectivity between HQ-RTR and BR2-RTR, but BR1-RTR is not coming up online within the OSPF topology.  My links are all in up/up status (including on BR1-RTR), but I'm just not sure what I've done wrong since the configurations pretty much match across the board.  BR2's serial interface and router OSPF config should match since HQ-RTR is a the hub in this hub and spoke OSPF topology, but I'm out of ideas.  Can anyone see what I've done wrong?  Again, OSPF is fully connected and neighbor'd up between BR2 and HQ.  I've taken the liberty of pasting the config of the frame relay switch I'm using as my IP-WAN/PSTN as well.


This network is for my CCIE-Voice/Collaboration lab.  But all help would be very much appreciated.  Please excuse my ignorance in this supposedly rather simple network setup.  Keep in mind, I have IPBASE running as the IOS for BR1, but my short research has shown that this shouldn't affect OSPF routing in this network. 


Eric


============================================                  

HQ-RTR#show run
Building configuration...

Current configuration : 6669 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ-RTR
!
boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.124-22.YB8.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 512000 informational
enable secret 5 $1$9FSi$K96RZb3sIlZuEFdsc1URD0
!
no aaa new-model
no network-clock-participate wic 2
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 192.168.11.1 192.168.11.10
ip dhcp excluded-address 192.168.12.1 192.168.12.10
ip dhcp excluded-address 192.168.13.1 192.168.13.10
ip dhcp excluded-address 192.168.14.1 192.168.14.10
ip dhcp excluded-address 192.168.16.1 192.168.16.10
ip dhcp excluded-address 192.168.17.1 192.168.17.10
!
ip dhcp pool HQ-BR1-Pool
   import all
   network 192.168.11.0 255.255.255.0
   option 150 ip 10.10.210.10
   default-router 192.168.11.1
   domain-name proctorlabs.com
   dns-server 8.8.4.4 8.8.8.8
   lease 8
!
ip dhcp pool BR2-Pool
   import all
   network 192.168.12.0 255.255.255.0
   option 150 ip 10.10.202.1
   default-router 192.168.12.1
   domain-name proctorlabs.com
   dns-server 8.8.4.4 8.8.8.8
   lease 8
!
ip dhcp pool PSTN-Pool
   import all
   network 192.168.13.0 255.255.255.0
   option 150 ip 10.10.100.2
   default-router 192.168.13.1
   domain-name proctorlabs.com
   dns-server 8.8.4.4 8.8.8.8
   lease 8
!
ip dhcp pool Laptop-Pool
   import all
   network 192.168.14.0 255.255.255.0
   default-router 192.168.14.1
   domain-name proctorlabs.com
   dns-server 8.8.4.4 8.8.8.8
   lease 8
!
ip dhcp pool WIRELESS-HOME
   import all
   network 192.168.16.0 255.255.255.0
   default-router 192.168.16.1
   dns-server 8.8.8.8 4.2.2.2
   domain-name proctorlabs.com
   lease 8
!
!
no ip domain lookup
ip domain name proctorlabs.com
ip inspect name CBAC-FW tcp timeout 3600
ip inspect name CBAC-FW udp timeout 3600
ip inspect name CBAC-FW http java-list 1 timeout 3600
ip inspect name CBAC-FW https timeout 3600
ip inspect name CBAC-FW icmp
ip inspect name CBAC-FW ddns-v3
ip inspect name CBAC-FW smtp
ip inspect name CBAC-FW pop3
ip inspect name CBAC-FW pop3s
ip inspect name CBAC-FW imap
ip inspect name CBAC-FW ftps
ip inspect name CBAC-FW ntp
ip inspect name CBAC-FW ftp timeout 3600
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
log config
  hidekeys
!
!
crypto isakmp policy 10
encr 3des
authentication pre-share
group 2
!
!
!
crypto ipsec client ezvpn Voice-vRack
connect manual
group proctorgroup key proctorlabs_rental
mode network-plus
peer 74.126.20.247
xauth userid mode interactive
!
!
!
controller T1 0/2/0
!
controller T1 0/2/1
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
description (Outside Public Interface)
ip address dhcp
ip access-group FW-IN in
no ip unreachables
ip mtu 1300
ip nat outside
ip inspect CBAC-FW out
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
crypto ipsec client ezvpn Voice-vRack
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.11
description (Inside Private Interface)
encapsulation dot1Q 11
ip address 192.168.11.1 255.255.255.0
ip nat inside
ip virtual-reassembly
crypto ipsec client ezvpn Voice-vRack inside
!
interface GigabitEthernet0/1.12
description (Inside Private Interface)
encapsulation dot1Q 12
ip address 192.168.12.1 255.255.255.0
ip nat inside
ip virtual-reassembly
crypto ipsec client ezvpn Voice-vRack inside
!
interface GigabitEthernet0/1.13
description (Inside Private Interface)
encapsulation dot1Q 13
ip address 192.168.13.1 255.255.255.0
ip nat inside
ip virtual-reassembly
crypto ipsec client ezvpn Voice-vRack inside
!
interface GigabitEthernet0/1.14
description (Inside Private Interface)
encapsulation dot1Q 14
ip address 192.168.14.1 255.255.255.0
ip nat inside
ip virtual-reassembly
crypto ipsec client ezvpn Voice-vRack inside
!
interface GigabitEthernet0/1.15
description LAB-SERVERS
encapsulation dot1Q 15
ip address 192.168.15.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface GigabitEthernet0/1.16
description WIRELESS-HOME
encapsulation dot1Q 16
ip address 192.168.16.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface GigabitEthernet0/1.17
description LAB-HQ-PHONES
encapsulation dot1Q 17
ip address 192.168.17.1 255.255.255.0
ip helper-address 192.168.15.11
ip nat inside
ip virtual-reassembly
!
interface Serial0/3/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3/1
description HQ-RTR_IP-WAN
no ip address
encapsulation frame-relay IETF
clock rate 2000000
frame-relay lmi-type ansi
!
interface Serial0/3/1.1 point-to-point
ip address 10.1.1.1 255.255.255.128
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 103
!
interface Serial0/3/1.2 point-to-point
ip address 10.1.1.129 255.255.255.128
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 102
!
interface Virtual-Template1 type tunnel
ip unnumbered Loopback0
shutdown
tunnel mode ipsec ipv4
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.1.0 0.0.0.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 dhcp
no ip http server
no ip http secure-server
!
!
ip nat inside source list 101 interface GigabitEthernet0/0 overload
!
ip access-list extended FW-IN
permit udp any any eq bootpc
deny   ip 10.0.0.0 0.255.255.255 any log
deny   ip 172.16.0.0 0.15.255.255 any log
deny   ip 192.168.0.0 0.0.255.255 any log
deny   ip 224.0.0.0 15.255.255.255 any log
deny   ip host 0.0.0.0 any log
deny   ip host 255.255.255.255 any log
deny   ip 169.254.0.0 0.0.255.255 any log
deny   ip 127.0.0.0 0.255.255.255 any log
permit esp host 74.126.20.247 any
permit tcp any any eq telnet
permit esp host 209.124.41.247 any
permit udp host 74.126.20.247 any eq isakmp
permit udp host 209.124.41.247 any eq isakmp
permit udp host 74.126.20.247 any eq non500-isakmp
!
access-list 101 deny   ip 192.168.0.0 0.0.255.255 10.10.0.0 0.0.255.255
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
!
!
!
!
!
!
!
control-plane
!
!
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 30 0
privilege level 15
password cisco
logging synchronous
login
transport input telnet ssh
line vty 5 15
exec-timeout 30 0
privilege level 15
password cisco
logging synchronous
login
transport input telnet ssh
!
scheduler allocate 20000 1000
end

HQ-RTR#

===================================================

BR2_RTR#sh run
Building configuration...


Current configuration : 3643 bytes
!
! Last configuration change at 04:09:53 UTC Tue Dec 10 2013
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BR2_RTR
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/0
enable secret 5 $1$kYuC$TYARPnIw8mjqiVM3CqM15.
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 192.168.50.1 192.168.50.10
ip dhcp excluded-address 192.168.40.1 192.168.40.49
ip dhcp excluded-address 192.168.40.70 192.168.40.254
!
ip dhcp pool BR2-PHONES
network 192.168.40.0 255.255.255.0
default-router 192.168.40.1
option 150 ip 192.168.40.1
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FTX1328A0D3
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/1/1
description BR2-RTR_IP-WAN
no ip address
encapsulation frame-relay IETF
no fair-queue
frame-relay lmi-type ansi
!
interface Serial0/1/1.1 point-to-point
ip address 10.1.1.2 255.255.255.128
frame-relay interface-dlci 301
!
interface FastEthernet1/0
description BR2-PHONE1
switchport mode trunk
switchport voice vlan 40
no ip address
spanning-tree portfast
!
interface FastEthernet1/1
description BR2-PHONE2
switchport mode trunk
switchport voice vlan 40
no ip address
spanning-tree portfast
!
interface FastEthernet1/2
no ip address
!
interface FastEthernet1/3
no ip address
!
interface FastEthernet1/4
no ip address
!
interface FastEthernet1/5
no ip address
!
interface FastEthernet1/6
no ip address
!
interface FastEthernet1/7
no ip address
!
interface FastEthernet1/8
no ip address
!
interface FastEthernet1/9
no ip address
!
interface FastEthernet1/10
no ip address
!
interface FastEthernet1/11
no ip address
!
interface FastEthernet1/12
no ip address
!
interface FastEthernet1/13
no ip address
!
interface FastEthernet1/14
no ip address
!
interface FastEthernet1/15
no ip address
!
interface GigabitEthernet1/0
no ip address
!
interface Vlan1
no ip address
!
interface Vlan40
description BR2-PHONES
ip address 192.168.40.1 255.255.255.0
!
interface Vlan50
description BR2-DATA
ip address 192.168.50.1 255.255.255.0
!
router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 10.1.1.0 0.0.0.255 area 0
network 192.168.40.0 0.0.0.255 area 0
network 192.168.50.0 0.0.0.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
telephony-service
max-ephones 4
max-dn 16
ip source-address 3.3.3.3 port 2000
network-locale ES
time-zone 23
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
banner motd ^CBR2 ROUTER CUCME/CUE^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 194
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
password cisco
login
transport input all
line vty 5 15
password cisco
login
transport input all
!
scheduler allocate 20000 1000
ntp server 192.168.15.11
end

BR2_RTR#

===================================================

PSTN_IP-WAN_RTR#sh run
Building configuration...


Current configuration : 3873 bytes
!
! Last configuration change at 03:31:01 UTC Tue Dec 10 2013
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PSTN_IP-WAN_RTR
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 0
enable secret 5 $1$4Dcc$8EzTSAQ0pvm1835G7xoej1
!
no aaa new-model
no network-clock-participate wic 0
network-clock-participate wic 2
dot11 syslog
ip source-route
!
!
!
ip dhcp excluded-address 192.168.100.1 192.168.100.10
!
ip dhcp pool PSTN-PHONE
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
option 150 ip 192.168.100.1
!
!
ip cef
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
!
frame-relay switching
isdn switch-type primary-ni
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2801 sn FTX1016Y07Z
!
!
controller T1 0/0/0
cablelength long 0db
!
controller T1 0/0/1
cablelength long 0db
!
controller T1 0/2/0
pri-group timeslots 1-3,24
!
controller T1 0/2/1
pri-group timeslots 1-3,24
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.13
description PSTN-PHONE_LAN
encapsulation dot1Q 13
ip address 192.168.100.1 255.255.255.0
!
interface FastEthernet0/1
description MGMT-CONNECTION-via-WIFI
ip address 192.168.1.10 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
description FR_to_HQ-RTR
no ip address
encapsulation frame-relay IETF
no fair-queue
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 102 interface Serial0/3/0 201
frame-relay route 103 interface Serial0/1/1 301
!
interface Serial0/1/1
description FR_to_BR2-RTR
no ip address
encapsulation frame-relay IETF
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 301 interface Serial0/1/0 103
!
interface Serial0/2/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
interface Serial0/2/1:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
interface Serial0/3/0
no ip address
shutdown
clock rate 64000
!
interface Serial0/3/1
description FR_to_BR1-RTR
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 201 interface Serial0/1/0 102
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
disable-eadi
!
!
tftp-server flash:P0030801SR02.bin
tftp-server flash:P0030801SR02.loads
tftp-server flash:P0030801SR02.sb2
tftp-server flash:P0030801SR02.sbn
tftp-server P0030801SR02.txt
!
control-plane
!
!
voice-port 0/2/0:23
!
voice-port 0/2/1:23
!
!
!
mgcp profile default
!
!
!
!
telephony-service
max-ephones 2
max-dn 10
ip source-address 192.168.100.1 port 2000
load 7960-7940 P00303020214
keepalive 10
max-conferences 4 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1
number 8087812321 secondary 7812321
label +8087812321
description PSTN-PHONE
!
!
ephone-dn  2
number 911 secondary 999
label 911+999
description EMERGENCY-911
!
!
ephone-dn  3
number 18005551234
label 18005551234
description 18005551234
!
!
ephone-dn  4
number 01161234567890
label 01161234567890
description 01161234567890
!
!
ephone-dn  5
number 7812321
label 7812321
description 7812321
!
!
ephone-dn  6
number 5005
label x5005
description OFFICE PHONE
!
!
ephone  1
mac-address 0008.A3FD.39FF
type 7960
button  1:1 2:2 3:3 4:4
button  5:5
!
!
!
banner motd ^C PSTN-IP-WAN ROUTER ^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
transport input all
line vty 5 15
password cisco
login
transport input all
!
scheduler allocate 20000 1000
ntp server 192.168.1.1
end

PSTN_IP-WAN_RTR#


===================================================


BR1_RTR#sh run
Building configuration...

Current configuration : 1959 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BR1_RTR
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$XzHB$zFFng9eqiJDuCOuaXjiZk/
!
no aaa new-model
!
resource policy
!
no ip subnet-zero
!
!
ip cef
--More--
*Dec 10 05:10:49.038: OSPF: Send hello to 224.0.0.5 area 0 on Serial0/1/1.1 from 10.1.1.130
!
!
no ip domain lookup
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/1/1
description BR1-RTR_IP-WAN
no ip address
encapsulation frame-relay IETF
no fair-queue
clock rate 64000
frame-relay lmi-type ansi
!
interface Serial0/1/1.1 point-to-point
ip address 10.1.1.130 255.255.255.128
frame-relay interface-dlci 201
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.21.0 0.0.0.255 area 0
network 192.168.22.0 0.0.0.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip route 0.0.0.0 255.255.255.128 10.1.1.129
!
no ip http server
!
!
control-plane
!
!
line con 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
scheduler allocate 20000 1000
!
end

BR1_RTR#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Eric Williamson Mon, 12/09/2013 - 21:34
User Badges:

Please note, the default static route was an old entry - but regardless I don't have anything connected except for the subnets directly connected to BR1.  See below...


BR1_RTR#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     10.0.0.0/25 is subnetted, 1 subnets
C       10.1.1.128 is directly connected, Serial0/1/1.1
S    0.0.0.0/25 [1/0] via 10.1.1.129
BR1_RTR#
*Dec 10 05:35:49.038: OSPF: Send hello to 224.0.0.5 area 0 on Serial0/1/1.1 from 10.1.1.130
BR1_RTR#

Rolf Fischer Mon, 12/09/2013 - 23:22
User Badges:
  • Blue, 1500 points or more

Hi,


PSTN_IP-WAN_RTR:


interface Serial0/1/0

frame-relay route 102 interface Serial0/3/0 201

!


interface Serial0/3/0

shutdown

!


interface Serial0/3/1

frame-relay route 201 interface Serial0/1/0 102


I guess you don't need further instructions ;-)


HTH

Rolf

Eric Williamson Tue, 12/10/2013 - 19:34
User Badges:

Thanks Rolf,


I'm an idiot.  :-(  **Egg on my face**  ....not the first time it's happened and it won't be the last.  That's why I love the world of Cisco, it makes you look stupid but you learn from your mistakes.  It's up and online now. :-)  Just a slight config change on the frame relay switch (PSTN_IP-WAN router) did it.


Thanks again buddy.


Eric

Rolf Fischer Tue, 12/10/2013 - 23:12
User Badges:
  • Blue, 1500 points or more

Eric,


you're welcome. Don't worry - we all have those moments of not seeing the wood for the trees ;-)

However, this gives a perfect example of the importance of troubleshooting methodology: Before you start tshoot upper-layer protocols, make sure that layer-2 is working. Sounds logical and simple but is often underestimated.

(I know: It's easy to be wise after the event.)


Good luck for your lab preperations!


Rolf

Actions

This Discussion