×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Clock Settings on Multiple PTP T1's

Unanswered Question
Dec 12th, 2013
User Badges:

We have used many Point-to-Point T1's in the past, where one end was bonded in a DS3.  I am setting up 2 T1's right now that are truely point-to

-point.  They are working, but I have a question.  I'm not sure if I have my clock set up correctly.  Here is the setup:




Router A (Corporate Office)Router B (Remote Office)
Router28112620
IOS15.0(1)M5 Adv IP Services12.3(18)
Cards

VWIC2-2MFT-T1/E1

2 x WIC-1DSU-T1
Clock sourceInternalLine


I thought my clock settings are correct, I tried using the following settings, but some of them do not show up in my config afterwards (I assume they are probably already at the default value):


2811:

controller T1 0/0/0

  framing esf (disappears)

  clock source internal

  linecode b8zs (disappears)

  channel-group 0 timeslots 1-24


2620:

Interface Serial0/0

service-module t1 framing esf (disappears)

service-module t1 clock source line (disappears)

service-module t1 linecode b8zs (disappears)

service-module t1 timeslots 1-24


Here are the pertinent pieces of the configs (sanitized):



Router A (Corporate) 2811Router B (Remote) 2620
Config

card type t1 0 0

!

network-clock-participate wic 0

network-clock-participate wic 1

!

dot11 syslog

ip source-route

!

ip cef

!

ip multicast-routing

no ipv6 cef

!

multilink bundle-name authenticated

!

voice-card 0

!

redundancy

!

controller T1 0/0/0

clock source internal

cablelength short 220

channel-group 0 timeslots 1-24

!

controller T1 0/0/1

clock source internal

cablelength short 220

channel-group 0 timeslots 1-24

!

interface FastEthernet0/0

ip address 10.1.252.102 255.255.255.252

duplex full

speed 100

!

interface Serial0/0/0:0

ip address 10.1.252.105 255.255.255.252

ip pim sparse-dense-mode

!

interface Serial0/0/1:0

ip address 10.1.252.109 255.255.255.252

ip pim sparse-dense-mode

!


router eigrp 7

network 10.0.0.0

ip subnet-zero

ip cef

!

ip multicast-routing

!

interface FastEthernet0/0

ip address 10.1.56.1 255.255.255.0

ip helper-address 10.1.2.10

no ip redirects

duplex auto

speed auto

!

interface Serial0/0

ip address 10.1.252.106 255.255.255.252

ip pim sparse-dense-mode

ip summary-address eigrp 7 10.1.56.0 255.255.252.0 5

service-module t1 timeslots 1-24

service-policy output axiom-voice

!

interface Serial0/1

ip address 10.1.252.110 255.255.255.252

ip pim sparse-dense-mode

ip summary-address eigrp 7 10.1.56.0 255.255.255.0 5

service-module t1 timeslots 1-24

service-policy output axiom-voice

!

router eigrp 7

passive-interface FastEthernet0/0

network 10.0.0.0

no auto-summary


When I monitor the interfaces, either using a show interface command, or monitoring software, I can see that more traffic is going over the second T1 (s0/1 and s0/0/1:0).  There are also quite a few input errors, CRC, and frame errors on the first T1 on both sides (s0/0 and s0/0/0:0).  The second T1 with most of the traffic is totally clean... no errors at all.


So, I'm trying to figure out if the errors are from a misconfigured clock setup (maybe I haven't set the appropriate clock priority?)  I've tried adding the network-clock-select command to my 2811, but it returns the error "*** Controller T1 0/0/0 is NOT deriving Clock from Line".  If I try to add the network-clock-participate or the network-clock-select command to the 2600, it does not recognize the command.  I'm not sure why.  The Cisco documentation says that the command was added to 12.2(4).  My 2800 is running 12.3(18), so I would think it would have the command... unless I don't have the correct feature set.  My image is c2600-ik9o3s3-mz.123-18.bin.


Does anyone have any ideas?


Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jeff Van Houten Thu, 12/12/2013 - 21:15
User Badges:
  • Silver, 250 points or more

Unless you have a physical crossover telco cable connecting both routers, you should have clock source line on all the controllers.

Sent from Cisco Technical Support iPad App

Jake Pratt Mon, 12/16/2013 - 08:27
User Badges:

Thanks for the response.  When I talked to turn up (telco), they told me I needed to provide my own clocking.  I am pretty sure on the DS3 I have, they provide clocking, but on these stand-alone T1's they specifically told me I need to provide it.  I can try setting both ends to line and see how it works, though.

Jake Pratt Mon, 12/16/2013 - 15:20
User Badges:

So, the problem may have just gone away.  I haven't changed the configs.  I still have clock source internal on one end, and clock source line on the other end.  I checked my interfaces today, and the first interface had like 60,000 or more errors in the last 3 days.  I cleared the counters, and kept checking the interfaces.  In the last 15 minuts, I have had zero errors of any kind.


So, it appears my clock settings may be correct after all.  While I'm glad my errors are gone, it drives me nuts not knowing what the problem was.  Thanks for your help.  I'll update this discussion after about a day or so, when I see how the interfaces are doing.

Jake Pratt Tue, 12/17/2013 - 15:23
User Badges:

Well, maybe the problem isn't gone completely.  It seems to come in spurts.  I let it run all night last night, and there was a spurt where I had about 200 errors.  Then I had zero errors for several hours.  Then today, I had about 2000 more.  And it's just on the first T1.  The second T1 is still pretty much zero errors.  That T1 has had 3 errors in 24 hours.

Jake Pratt Tue, 12/17/2013 - 15:35
User Badges:

I tried switching clock source to line on both ends, and I'm still getting lots of errors.

Actions

This Discussion

Related Content