Symbol MC9090 Scan Guns- 2602i AP's/5508

Unanswered Question
Dec 31st, 2013
User Badges:

We have used the Symbol Scan guns for quite some time on our wireless networks.  Recently we upgraded a location that had Cisco 1242 AP's, to the newer 2602i model.  The controller is a 5508 on version 7.3, and the access points are operating in FlexConnect mode. 


Since upgrading to the 2602i AP's. we have had many issues with the Symbol MC9090 scan guns.  They appear to be roaming very frequently between AP's servicing this area.  At first we thought it was coverage, and added more access points.  We are still seeing the same problems.  The signal strength fluctuates on the scan gun from excellent to poor very often, and I notice packets getting dropped during this process.


The application runnig on the scan gun will halt, and either normailze or cause the device to have to be completely reset.  These problems were not happenng before we upgraded to the new model of AP.  I have read the document Cisco published concerning best practices for Symbol/Motorola scanners and controller based networks, but that is fairly old and out of date.  We do have CCKM, Aironet IE, and Band Select enabled on this WLAN.  I assume I should probably disable these features but we have other scan guns using this same WLAN with no problems.  The biggest change was when we went from the 1242 to the 2602i.  During this change, we also moved also from a controller where the AP's were in local mode, to now the access points operating in Flex connecting to a central controller.  Latency between the AP's and the controller is not a problem.


Any help would be greatly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (6 ratings)
Loading.
Leo Laohoo Tue, 12/31/2013 - 16:27
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

The signal strength fluctuates on the scan gun from excellent to poor very often, and I notice packets getting dropped during this process.

Check the manufacturer's website for any recent addition to the drivers of the guns.  The decision to associate to APs is the responsibility of the client and not the AP. 


Can you specify what data rates are your radios operating on? 

Could you also verify that TPC and/or DCA are enabled and set to auto?  And refresh is set to, say, 12- or 24-hours?

awatson20 Tue, 12/31/2013 - 17:27
User Badges:

We are going to start with trying to update the Client drivers.


TPC and DCA is enabled and set to auto.  Interval is 10 minutes. I have turned up the transmit power manually on some of these access points in an effort to try and improve the issue.  I typically do not do this. but I noticed that RSSI was weak in some areas, and the transmit power on the access points were turned down on 5 and 6.


The Data rates for 802.11b/g/n are:
1 Mandatory
2 Mandatory
5.5 Mandatory
6 Supported
9 Supported
11 Mandatory
12 Supported
18 Supported
14 Supported
36 Supported
48 Supported
54 Supported

Leo Laohoo Tue, 12/31/2013 - 22:47
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

We are going to start with trying to update the Client drivers.

Don't do all.  Just a few.  About three or four and test.  If you see some improvements, then roll it out. 

Interval is 10 minutes. 

I'm not sure about the others but this is too low.  I normally set mine (if I recall) to 12 hours. 

I have turned up the transmit power manually on some of these access points in an effort to try and improve the issue

Don't.  Leave them all to auto.  Again, make sure the refresh value is long. 

Rasika Nayanajith Tue, 12/31/2013 - 23:31
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Wireless

Disable all data rates given below & make 12Mbps as mandatory in 2.4GHz band (Unless you have client operate in 802.11b only). You have default configuration for these & it is not optimum. By doing this you can get performance enhancement as well.


1 Mandatory

2 Mandatory

5.5 Mandatory

6 Supported

9 Supported

11 Mandatory


DCA interval 10 min is default setting. I have set it to 8 hours in my environment which acnhor it to 8:00AM.


HTH

Rasika


***** Pls rate all useful responses ****

Vasco Costa Thu, 06/05/2014 - 03:27
User Badges:

We've got a similar problem with old scan guns working with WEP on a 2602i APs+WLC 5760 environment.

 

We mitigate the problem by implementing this solution (disable all <12Mb's) and manually adjust the RRM values of some APs.

awatson20 Wed, 01/01/2014 - 07:42
User Badges:

Can DCA changes and Data rates be modified specifically for these access points and not globally on the WLC? This WLC services many other AP's. Would this be done as an RF profile then applied to an AP group?

Sent from Cisco Technical Support iPhone App

Scott Fella Wed, 01/01/2014 - 08:20
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Data rates can be configured with using RF Groups and AP Groups in combination.  I believe in v7.4, RF Groups were available.  DCA can only be set globally.  It is recommended that you have set the DCA interval to 24 hours and not leave it at 10 minutes which is default. 


http://www.cisco.com/en/US/docs/wireless/controller/7.4/configuration/guides/consolidated/b_cg74_CONSOLIDATED_chapter_010000101.html


As far as the issues you are seeing, your scanners roaming aggressively.... how is the RF environment.... was a site survey done?  The reason I say this is because I have heard customers complain about this and it was due to lack of coverage and devices looking to roam more frequently that what it should.  If you have the default data rates and your RF coverage is at the required specifications, < -72 rssi everywhere and > -20dbi for SNR, your client should stick since the lowest mandatory rate is 1mbps. 


So can you tell us if a site survey was done and what was the requirement of the site survey?


Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

awatson20 Wed, 01/01/2014 - 09:42
User Badges:

Yes, a site survey was performed.  Originally, we had 1242 AP's in this area.  We started having problems when we replaced the 1242 AP's with external antennas, with the 2602I using internal antennas.  In most environments where we have made this transition, a 1 for 1 replacement usually works ok.  At this particular location, we added some additional access points to address what we thought could be a coverage issue.


I have not adjusted the global TPC settings, but we did adjust the power level on these access points as it seemed RRM had the power adjusted way down.  The access points Tx Power Level assignment was auto set to 5 and 6 on most of these access points.  Should we leave this to auto?  I have seen in some environments, and depending on the client, adjusting the power level helped with coverage.


In looking at client session reports in Prime/NCS, we see that client RSSI and SNR for this area over a period of time is averaging -62 RSSI and SNR 31dbi. There are some areas that these clients are reporting higher RSSI over -75, and we may need to add coverage.  However it appeared to be working fine with the 1242 and less AP's.


From the Scan Gun perspective, when it roams or when the RSSI gets high, the application will freeze momentairly, but we do not lose connectivity.  I plan on spending some time tomorrow doing another thorough site survey to see what is going on.

George Stefanick Wed, 01/01/2014 - 09:46
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, October 2015

One thing I would do is a client debug and reproduce your problem.

Sent from Cisco Technical Support iPad App

Scott Fella Wed, 01/01/2014 - 10:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Well a 1 to 1 replacement with different antennas will change you RF footprint. When you see RRM set TX to 5-6, it's due to the AP's being high and in line of site to each other. This means that the RF at that height is fine, but at floor level it's not. I would set the MIN TX level to 11dbm or 14dbm under the TPC settings. You will need to disable the radio to make these changes. This usually fixes the issues in my customers environment. Adding more AP's and letting RRM handle changes will cause the TX power to drop even more. So when I see TX power at what you have, it tells me that you should have coverage, but not knowing the attenuation from racks and product, you just need to tweak your TPC. You can set the MAX TX power to 20dbm or 17dbm depending what your coverage requires. You can set these parameters and put a scanner in site survey mode, if they have that, and look at your signal and or available APs in the area. This way you can look at some trouble spots and determine if the power needs to be higher or not. Maybe due to attenuation, another AP might need to be installed. We usually do a post site survey to see if the coverage has changed and to determine areas that might have to be tweaked manually.

Sent from Cisco Technical Support iPhone App

awatson20 Wed, 01/01/2014 - 10:48
User Badges:

Thanks.  That is the same thing we thought.  Based on those levels, it appeared we did have enough coverage.  We have had to modify the Tx power in warehouses where the AP's were mounted high in the ceiling.  In this scenario, there is a lot of racking and dense product in this area.


In regards to your suggested changes below, are you referring to changing this per radio, as in adjusting the Tx power level assignment to 1 or 2? Or is this a global change under RRM TPC configuartion you are referring to?


I would set the MIN TX level to 11dbm or 14dbm under the TPC settings.


You can set the MAX TX power to 20dbm or 17dbm depending what your coverage requires.

Scott Fella Wed, 01/01/2014 - 11:26
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

I would set it globally on the 802.11 radios for TPC. I would see how that works first and then you might have to set it manually if you still see issues. You can set the MIN to 14 or higher is you want, this just prevents the AP from lowering power past the specified TX value you set.

Sent from Cisco Technical Support iPhone App

Rasika Nayanajith Tue, 12/31/2013 - 14:33
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Wireless

Is it possible to check these AP in local mode & see problem persist ? In that way you can isolate this issue is with FlexConnect or not


I would suggest you to move to a later code like 7.4.121.0 (7.4MR2 release) with FUS upgrade to 1.7.0.0 as that is the code I would recommend to anyone.


http://www.cisco.com/en/US/docs/wireless/controller/release/notes/crn74mr02.html

http://www.cisco.com/en/US/docs/wireless/controller/release/notes/fus_rn_1_7_0_0.html



HTH

Rasika


**** Pls rate all useful responses *****

Mats Nilson Mon, 02/17/2014 - 05:06
User Badges:

Hi Guys.


I was searching this forum for somone that is experiencing similar problems as we have currently.

We are using Autonomous 2602e with standard "rubber duck" antennas (AIR-ANT2524DB-R=) and Motorola MC17 and MK4900 wireless units. The clients (even stationary) are roaming excessively and have poor performance in wireless connectivity. RF is good(SNR and signal levels)


We have tried tuning the powerlevels to match the client. Other sites with (almost)identical configuration and environment (switches, vlans, firmware, etc) but with 1242AGN work excellent!

Client is roaming excessively without any apparent reason. When comparing 1242, the 2602 has spectrum intelligence and other RF enhancing function, but these are not activated. We have disabled 802.11n and speeds below 5.5Mbs(basic) the rest supported.



********* Config ***********

Current configuration : 5451 bytes

!

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime localtime

service password-encryption

!

hostname XXXXXXX

!

logging rate-limit console 9

!

aaa new-model

!

!

aaa group server radius rad_eap

server X.X.X.X

!

aaa group server radius rad_mac

server X.X.X.X

!

aaa group server radius rad_acct

server X.X.X.X

!

aaa group server radius rad_adm

server X.X.X.X

!

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods group rad_mac

aaa authentication login admin group rad_adm local

aaa authentication enable default group rad_adm enable

aaa accounting exec default stop-only group rad_acct

aaa accounting network acct_methods stop-only group rad_acct

!

!

!

!

!

aaa session-id common

clock timezone +0100 1 0

no ip routing

ip domain name net.axfood.se

ip name-server X.X.X.X

!

!

dot11 syslog

dot11 vlan-name equipment vlan 60

dot11 vlan-name selfscanning vlan 40

dot11 vlan-name voice vlan 20

dot11 vlan-name default vlan 1

!

dot11 ssid EQUIPMENT

   vlan 60

   authentication open

   authentication key-management wpa

   wpa-psk ascii 7 X.X.X.X

!

dot11 ssid SCANNING

   vlan 40

   authentication open

   authentication key-management wpa version 1

   wpa-psk ascii 7 X.X.X.X

!

dot11 wpa handshake timeout 2000

dot11 network-map

power inline negotiation prestandard source

crypto pki token default removal timeout 0

!

!

username @@@@@@ privilege 15 password 7 XXXXX

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 40 mode ciphers tkip

!

encryption vlan 60 mode ciphers tkip

!

ssid EQUIPMENT

!

ssid SCANNING

!

antenna gain 0     <--- I know this is wrong; should be 2 (AIR-ANT2524DW-R=)

stbc

speed  basic-5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

power local 11

power client local

packet retries 128 drop-packet

channel least-congested 2412 2437 2462

station-role root

rts retries 128

no dot11 extension aironet

no cdp enable

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio0.20

encapsulation dot1Q 20

no ip route-cache

bridge-group 20

bridge-group 20 subscriber-loop-control

bridge-group 20 spanning-disabled

bridge-group 20 block-unknown-source

no bridge-group 20 source-learning

no bridge-group 20 unicast-flooding

!

interface Dot11Radio0.40

encapsulation dot1Q 40

no ip route-cache

bridge-group 40

bridge-group 40 subscriber-loop-control

bridge-group 40 spanning-disabled

bridge-group 40 block-unknown-source

no bridge-group 40 source-learning

no bridge-group 40 unicast-flooding

!

interface Dot11Radio0.60

encapsulation dot1Q 60

no ip route-cache

bridge-group 60

bridge-group 60 subscriber-loop-control

bridge-group 60 spanning-disabled

bridge-group 60 block-unknown-source

no bridge-group 60 source-learning

no bridge-group 60 unicast-flooding

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0     <--- I know this is wrong; should be 4 (AIR-ANT2524DW-R=)

no dfs band block

channel dfs

station-role root

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

no bridge-group 1 source-learning

!

interface GigabitEthernet0.40

encapsulation dot1Q 40

no ip route-cache

bridge-group 40

bridge-group 40 spanning-disabled

no bridge-group 40 source-learning

!

interface GigabitEthernet0.60

encapsulation dot1Q 60

no ip route-cache

bridge-group 60

bridge-group 60 spanning-disabled

no bridge-group 60 source-learning

!

interface BVI1

ip address X.X.X.X 255.255.255.0

no ip route-cache

!

ip default-gateway X.X.X.X

ip http server

ip http authentication aaa

no ip http secure-server

ip http help-path

http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag


ip radius source-interface BVI1

logging X.X.X.X

access-list 111 permit tcp any any neq telnet

snmp-server community XXxxxXX RW

radius-server attribute 32 include-in-access-req format %h

radius-server dead-criteria time 10 tries 3

radius-server host X.X.X.X key 7 DDDDdddddDDDDD

radius-server host X.X.X.X key 7 bbbbBBBBBbbbbb

radius-server retransmit 2

radius-server timeout 4

radius-server deadtime 1

radius-server vsa send accounting

!

bridge 1 route ip

!

!

!

line con 0

access-class 111 in

password 7 ppppppppPPPPppppppp

logging synchronous

login authentication admin

history size 50

line vty 0 4

access-class 111 in

logging synchronous

login authentication admin

history size 50

transport input ssh

line vty 5 15

exec-timeout 3 0

password 7 ppppppppPPPPppppppp

login authentication admin

history size 50

transport input ssh

!

sntp server X.X.X.X

sntp broadcast client

end

 

*****************************************


Is there any "hidden" rate, access limiting or load-balancing features on the 2602 access points?

This is causing major disruptions on the stores where the 2602e access points have been deployed.

Checking the the client statistics for signal and SNR gives no reason why stationary clients should roam unless the access points fails to acknowledge reassociation requests from the client.


One important information is that many simultaneous association requests for some access points due to the fact that many motorola devices(50-200) are aggregated in racks.


Sincere Regards


Any ideas?

      


Dominic Stalder Thu, 03/13/2014 - 05:16
User Badges:

Hi there

 

Have you been able to solve your problem? A customer of us are experiencing exactly the same issues.

What authentication / encryption are you using?

 

Thanks in advance and regards Dominic

awatson20 Thu, 03/13/2014 - 05:30
User Badges:

We are doing EAP-TLS with WPA2/AES.  We modified the data rates which seemed to help.  Also, we upgraded to a newer Scan Gun Model (MC92N) which has 802.11n capabilities and that helped.  But ultimately, the fix was having the application modifed to be better suited for a wireless envrionement.  This incldued adjusting time-out settings in the app.

Steven Anderson Mon, 01/23/2017 - 08:55
User Badges:

The cause is the software on the scanners. Call Zebra to get the latest Fusion software release for your device.

MC92N0

Below is an excerpt from the release notes stating a roam stickiness issue. I resolved this issue for model MC92N0 by installing FUSION_X_2.03.0.0.012R_MPA3_WM65.CAB

Release Notes - Windows Mobile 6.5 - Fusion X_2.02.0.0.016R – SPR25781

"Roam stickiness caused by state machine bug causing roam scans to fail. Device fails to roam to AP with good signal strength and stays connected to AP with very low signal strength."


https://www.zebra.com/content/dam/zebra_new_ia/enus/software/utilities/f...


MC9190

The MC9190 has a bug fix for roaming too frequently. This software release fixes the issue: Fusion_3.00.2.0.025R_WM65.ARM.CAB

Release Notes - Windows Mobile 6.5 - Fusion 3.00.2.0.025R


"SPR 20363 – WLAN roams frequently in an environment where AP beacons are sent at 11 Mbps (i.e. the lowest basic rate on the AP is set to 11 Mbps)."


https://www.zebra.com/content/dam/zebra_new_ia/enus/software/utilities/f...


Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode