×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Help! Need Assistance On Proper Configuration Of Cisco 2821 W/Charter Broadband

Unanswered Question
Dec 31st, 2013
User Badges:

Hello all, HAPPY NEW YEARS!


I have Charter cable broadband internet service in my home. I'm using a Cisco 2821 as my router and noticed I sometimes have to refresh my browser to get weg pages to load. I also have issues pinging host outside my network, I get "Request Timed Out" on most host with the exception of a few. I don't have problems with pages like yahoo or craigslist for some reason. Im convinced the issue is with the router configuration as its the same configuration I used on my 3660 and had same problem. If I remove the 2821 and throw in the cheap WRT54G SOHO router I have no problems whatsoever. My router configuration is listed below for your review. I also attached a diagram of my network layout in a Word.Doc file. Any help would be appreciated!


Building configuration...


Current configuration : 3379 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Back2lifeRouter
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$NrCX$7GPtFHcXesTUcmZbdM4q51
!
no aaa new-model
!
!
crypto pki trustpoint TP-self-signed-2772828844
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2772828844
 revocation-check none
 rsakeypair TP-self-signed-2772828844
!
!
crypto pki certificate chain TP-self-signed-2772828844
 certificate self-signed 01
  30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 32373732 38323838 3434301E 170D3133 31323231 31393533 
  34335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37373238 
  32383834 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100A9EE 787DD02E 66CC9788 406A58A3 B4B68E25 A72D9160 753FC076 7B0B9FF6 
  BC41138E C82994FE 230B5639 13821522 783F034A 55C503AF 5C0D0DB7 45CB32BF 
  C57068BA F800A9CB 6B31C6CE 1003184B B03F9593 F6FB6425 2692F033 6CB218BA 
  E64E6EAD A951CAB3 C1763733 60AB4B43 50980DF9 B36377DF A0A310EF 0365FB96 
  60CF0203 010001A3 6F306D30 0F060355 1D130101 FF040530 030101FF 301A0603 
  551D1104 13301182 0F426163 6B326C69 6665526F 75746572 301F0603 551D2304 
  18301680 148C29ED 85990D08 7A9679DC CC2C154D 76D721FA 26301D06 03551D0E 
  04160414 8C29ED85 990D087A 9679DCCC 2C154D76 D721FA26 300D0609 2A864886 
  F70D0101 04050003 81810008 9B73D1A8 276734BC 2553D3EA 5D462513 FD00232D 
  E53DDE95 CF46D8BC 73A03ABB 2D65C94D E87DCC45 6EFAD563 4379C94C A42B504C 
  1DF9C7B7 E726764F 0316CF79 4D63B89B 1A4787CC 03D748EA ED730266 174260D4 
  2B05E572 CCA69DAA 26AE4D34 0FA0F223 A0FF44DC 53EEA153 2DC76EAB 28C6B8B6 
  2CD91A71 A73BD2CD EB8338
       quit
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2 192.168.1.3
ip dhcp excluded-address 192.168.1.105
ip dhcp excluded-address 192.168.1.106 192.168.1.107
ip dhcp excluded-address 192.168.1.108 192.168.1.116
ip dhcp excluded-address 192.168.1.115
!
ip dhcp pool DATA
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1 
   dns-server 4.2.2.2 4.2.2.3 8.8.8.8 
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
! 
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 shutdown
 clock rate 2000000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip http server
ip http secure-server
!
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip nat inside source static tcp 192.168.1.107 3389 interface GigabitEthernet0/0 3389
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

command completed.

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Collin Clark Tue, 12/31/2013 - 16:57
User Badges:
  • Purple, 4500 points or more

Mr. Outlaw-


Can you try setting the tcp mss to something smaller?


interface gi1/1

ip tcp adjust-mss 1350

Actions

This Discussion