×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco SPA504G - network ports on the back -vlans

Unanswered Question
Jan 6th, 2014
User Badges:

Hi,



I have some Cisco SPA504G phones which have Windows computers piggy backed off them using the PC port.



I want to seperate my VOICE and DATA into seperate VLANS.


I have a switch which has VLAN: 10 for VOICE and VLAN: 20 for DATA setup.


How do I go about setting the phone to use VLAN10 and the PC port on the Cisco phone to use the VLAN: 20 DATA?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Hermanus Janse ... Mon, 01/06/2014 - 04:47
User Badges:
  • Silver, 250 points or more

Hi,


if your switch config looks like below the Phone and PC will get the correct VLAN:


!

interface FastEthernet1/0/2

switchport access vlan 20

switchport mode access

switchport voice vlan 10

spanning-tree portfast

unrealone1 Mon, 01/06/2014 - 04:59
User Badges:

Thanks for this. Does the phones need to be plugged into tagged ports? (sorry might be the HP term)


"interface FastEthernet1/0/2" What interface is this referring to?


No guru with cli, by configuring the switch as above, I just plug the phone into any port on the cisco switch?

Hermanus Janse ... Mon, 01/06/2014 - 05:02
User Badges:
  • Silver, 250 points or more

on a cisco switch the ports is either fastethernet 1/0/1 or fastethernet 0/1 or gigbitethernet 0/1


so on CLI you need to enter conf t mode.

then go to the port number the phones is plugged into say for instance port 4 to port 8


then you can do

interface range fa0/4 - 8

switchport access vlan 20

switchport mode access

switchport voice vlan 10

spanning-tree portfast

exit

exit

wr



so yes you need to configure the ports on the cisco switch in which you plug the phones in.

Actions

This Discussion