×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Issue configuring 2 APs (1250 and 1232)

Unanswered Question
Jan 6th, 2014
User Badges:

Hi!


I am trying to setup an older 1232 Aironet as a repeater. I could not get this to work after countless hours of messing around with all the settings. This was going to be a non-ethernet repeater config. I finally decided to hardwire the 1232 to the switch. The whole purpose of this is to extend my wireless network. I now have the 1232 and 1250 going through the switch/router. I have not had any issues with the 1250--everything is setup just fine aside from the connectivity issues beyond a certain distance.


The main issues with the 1232 is that it does not support WPA2 (to my knowledge). The 1250 was setup with WPA2, but was demoted to WPA in order to work with the 1232. Putting the 1250 to WPA or WPAv1 prevented me from connecting to the SSID altogether.


I have also attempted to mess with the VLAN and the Network ID fields; thinking to put the same ID for the 1232 and 1250. No success on anything. The goal is to have the 1250 as the primary, and the 1232 simply to extend the capbility of the 1250. Can someone advise as to what specifically must be done? Both APs are on the same plane..essentially not a true line of sight since a wall separates them, but they are both now hardwired.


Thanks in advance!


Leo

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rasika Nayanajith Tue, 01/07/2014 - 00:42
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Wireless

Hi Leo,


First try to get your Repeater working with open authentication. Repeater AP need to connect to Root AP on the vlan configured as native vlan. Below post should be help you on this.


http://mrncciew.com/2013/01/20/autonomous-ap-repeater/


Once this is working, you can add WPA/TKIP as security (as WPA2 is not supported on your 1232) mechanism later on as shown in the below.


dot11 ssid

   authentication open

   authentication key-management wpa

   wpa-psk ascii

!

interface Dot11Radio0

encryption mode ciphers tkip

!

interface Dot11Radio1

encryption mode ciphers tkip


HTH

Rasika


**** Pls rate all useful responses ****

Leo Alexander Mon, 01/20/2014 - 20:29
User Badges:

Hi,


Thank you for your response! I am still experiencing issues, mainly from what I am seeing, due to the AP 1232. I think it would be best to get another 1250, if not later due to the encryption and many other features.


Once I do acquire another 1250 or later, should I just mirror the settings in terms of setting the SSID, etc. What would be the best method to setup the additional 1250 as 'repeater' / but maintain it being hard-wired (since it is currently feasible to do so). My goal is the same, to extend the capability and integrity of the wireless (failsafe is other AP goes down).


Thanks again for your help!


Leo

Rasika Nayanajith Mon, 01/20/2014 - 20:56
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Wireless

Hi Leo,


Yes, it is good idea if you can find something like this. Then you can configure WPA2/AES & you can get 802.11n data rates as well (ie higher throughput for clients since 1250 supports that)


What do you mean by this ? Do you want this additional 1250 to be connected to the network via wired ethernet cable ?

What would be the best method to setup the additional 1250 as 'repeater' / but maintain it being hard-wired (since it is currently feasible to do so).


Pls clarify this


HTH

Rasika


*** Pls rate all useful responses ****

Leo Alexander Mon, 01/20/2014 - 22:08
User Badges:

Yes, I agree with the benefits of having the 1250. I would prefer to have the 1250 connected via cable to the switch. Do you agree that this would be the best method, or should it be setup as a repeater stand alone AP without the cable to the switch? I am going for best throughput as well as range.

Rasika Nayanajith Mon, 01/20/2014 - 23:47
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Wireless

Hi Leo,


Yes, if you could connect AP to a wired switch that is the best you could get (typically repeater is used where you cannot extend wired connection for AP connectivity & backhall via wireless where bandwidth get drastically drop for client connections)


So what you should do is configure your SSID on both 125s 2 in same manner with WPA2/AES as auth/encryption. This will provide higher througput where you can get 802.11n speeds. Also it will give smooth roaming as long as you keep the config consistant & using PSK with WPA2.


Here is a simplest configuration example if you require a single SSID. You can simply configure your switch port as Access vlan with DHCP enabled on that vlan.(clients & ap will get same range IP)


hostname

!

dot11 ssid

   authentication open

   authentication key-management wpa version 2

   guest-mode

   wpa-psk ascii

!

interface Dot11Radio0

encryption mode ciphers aes-ccm

ssid

no shutdown

!

interface Dot11Radio1

encryption mode ciphers aes-ccm

ssid

no shutdown

!

interface BVI1

ip address dhcp



If you want to configure multiple SSID then you have to create different bridge groups with sub interfaces on radio & gig interface. In this case your switchport should be configured as trunk & set native vlan as AP-Mgmt vlan (vlan 10 in below example)


hostname AAP1

!

dot11 ssid WLAN-1

   vlan 7

   authentication open

   authentication key-management wpa version 2

   wpa-psk ascii WLAN-1-KEY

   mbssid guest-mode

!

dot11 ssid WLAN-2

   vlan 8

   authentication open

   authentication key-management wpa version 2

   wpa-psk ascii WLAN-2-KEY

  mbssid guest-mode

!

interface Dot11Radio0

encryption vlan 7 mode ciphers aes-ccm

encryption vlan 8 mode ciphers aes-ccm

ssid WLAN-1

ssid WLAN-2

mbssid

station-role root

!

interface Dot11Radio1

encryption vlan 7 mode ciphers aes-ccm

encryption vlan 8 mode ciphers aes-ccm

ssid WLAN-1

ssid WLAN-2

mbssid

station-role root

!

interface Dot11Radio0.7

encapsulation dot1Q 7

bridge-group 7

!

interface Dot11Radio0.8

encapsulation dot1Q 8

bridge-group 8

!

interface Dot11Radio0.10

encapsulation dot1Q 10 native

bridge-group 1

!

!

interface Dot11Radio1.7

encapsulation dot1Q 7

bridge-group 7

!

interface Dot11Radio1.8

encapsulation dot1Q 8

bridge-group 8

!

interface Dot11Radio1.10

encapsulation dot1Q 10 native

bridge-group 1

!

interface GigabitEthernet0.7

encapsulation dot1Q 7

bridge-group 7

!

interface GigabitEthernet0.8

encapsulation dot1Q 8

bridge-group 8

!

interface GigabitEthernet0.10

encapsulation dot1Q 10 native

bridge-group 1

!

interface BVI1

ip address 192.168.10.254 255.255.255.0

!

ip default-gateway 192.168.10.1




**** AP Connected Swtichport *****


int g x/x

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10

switchport trunk allow vlan 7,8,10



HTH

Rasika


***** Pls rate all useful resposnes ****

Actions

This Discussion

Related Content