×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

two group of 2960-s stacked switches connection problem

Answered Question
Jan 7th, 2014
User Badges:

I have two group of 2960 stacked switches connected by trunked (UTP) interface


stack-1                       stack-2

SW-1 -------UTP-------- SW-A

SW-2                           SW-B

SW-3                           SW-C

SW-4                           SW-D



I cannot ping stacks by their management IP?


Here is the config of stack-1


stack-1#sh switch
Switch/Stack Mac Address : c025.5cf1.0b80
                                           H/W   Current
Switch#  Role   Mac Address     Priority Version  State
----------------------------------------------------------
*1       Master c025.5cf1.0b80     14     1       Ready              
2       Member 64e9.5055.bd00     1      1       Ready              
3       Member 64e9.501d.f980     1      1       Ready              
4       Member 64e9.5062.1580     1      1       Ready              


stack-1#sh switch stack-ports
  Switch #    Port 1       Port 2
  --------    ------       ------
    1           Ok           Ok  
    2           Ok           Ok  
    3           Ok           Ok  
    4           Ok           Ok  



stack-1#sh run
!

switch 1 provision ws-c2960s-48lps-l
switch 2 provision ws-c2960s-48ts-l
switch 3 provision ws-c2960s-48ts-l
switch 4 provision ws-c2960s-48ts-l
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
interface GigabitEthernet1/0/48
description uplink_other_stack
switchport trunk allowed vlan 1,200,379,380,396-399
switchport mode trunk
!
!
interface Vlan1
no ip address
!
interface Vlan200
description management
ip address 10.8.15.4 255.255.0.0
!

Correct Answer by Leo Laohoo about 3 years 7 months ago

Ok, try these sequence of commands from switch stack 1 ...


conf t

cluster enable

do sh cluster candidate


!!!!  Note the MAC address of stack-2


cluster member mac pass

end

rc 1


!!!! If everything is correct, you should be able to remote into stack-2.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Leo Laohoo Tue, 01/07/2014 - 13:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Can you post the output to commands of both stacks:


1.  sh interface trunk;

2.  sh int vlan 200;

recep.sefer Tue, 01/07/2014 - 22:39
User Badges:

stack-1#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/48    on               802.1q         trunking      1
Gi1/0/49    on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/0/48    1,200,379-380,396-399
Gi1/0/49    1,200,379-380,396-399

Port        Vlans allowed and active in management domain
Gi1/0/48    1,200
Gi1/0/49    1,200

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/48    1,200
Gi1/0/49    1,200

sack-1#sh int vlan 200
Vlan200 is up, line protocol is up
  Hardware is EtherSVI, address is c025.5cf1.0bc1 (bia c025.5cf1.0bc1)
  Description: management
  Internet address is 10.8.15.4/16
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1000 bits/sec, 3 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     112256 packets input, 7333704 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     961 packets output, 95330 bytes, 0 underruns
     0 output errors, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out

recep.sefer Tue, 01/07/2014 - 23:12
User Badges:

Here is sh cdp neigbors


stack-1#sh cdp neighbors det
-------------------------
Device ID: BACKBONE
Entry address(es):
  IP address: 10.15.20.1
Platform: cisco WS-C4506-E,  Capabilities: Router Switch IGMP
Interface: GigabitEthernet1/0/49,  Port ID (outgoing port): GigabitEthernet4/1
Holdtime : 146 sec

Version :
Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500e-UNIVERSAL-M), Version 15.1(2)SG, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Wed 05-Dec-12 05:58 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Native VLAN: 1
Duplex: full
Management address(es):
  IP address: 10.15.20.1

-------------------------
Device ID: stack-2
Entry address(es):
Platform: cisco WS-C2960S-48TS-L,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/48,  Port ID (outgoing port): GigabitEthernet1/0/48
Holdtime : 144 sec

Version :
Cisco IOS Software, C2960S Software (C2960S-UNIVERSALK9-M), Version 12.2(55)SE7, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Mon 28-Jan-13 10:28 by prod_rel_team

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=00000000FFFFFFFF010221FF00000000000064E950825200FF0000
VTP Management Domain: ''
Native VLAN: 1
Duplex: full
Management address(es):

Leo Laohoo Tue, 01/07/2014 - 23:21
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

That's why you can't ping the 2nd stack's managmenet IP address.  You can't see it in "sh cdp n". 


Provide the following commands from the 2nd stack: 


1.  sh interface vlan 200;

2.  sh interface trunk


Maybe interface VLAN 200 is in "shutdown".

Leo Laohoo Tue, 01/07/2014 - 22:43
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Are ports G1/0/48 and G1/0/49 going to the same switch? 

recep.sefer Tue, 01/07/2014 - 23:52
User Badges:

Yes they are on same switch (stack-1)


here is teh topology

I can reach stack-1 by VLAN200 IP adress

But I cannot reach stack-2


                                       stack-1                       stack-2

Backbone------fiber-------SW-1 -------UTP-------- SW-A

                                       SW-2                           SW-B

                                       SW-3                           SW-C

                                       SW-4                           SW-D

Leo Laohoo Wed, 01/08/2014 - 00:07
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

On the stack 2, post the output to the following commands:


1.  sh interface trunk; and

2.  sh interface vlan 200

recep.sefer Wed, 01/08/2014 - 00:49
User Badges:

I cannot reach (telnet) stack-2

It is so far to me

I am sure stack-2 config is same as stack-1


is it possible to solve it without going to stack-2

Leo Laohoo Wed, 01/08/2014 - 01:09
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Is VLAN 1 on both stack enabled or disabled?

recep.sefer Wed, 01/08/2014 - 02:00
User Badges:

Yes

Vlan 1 is enabled

here is config


interface Vlan1

no ip address

!

interface Vlan200

description management

ip address ...



stack-1#sh vlan


VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Gi1/0/4, Gi1/0/5, Gi1/0/6 ....

Correct Answer
Leo Laohoo Wed, 01/08/2014 - 02:03
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Ok, try these sequence of commands from switch stack 1 ...


conf t

cluster enable

do sh cluster candidate


!!!!  Note the MAC address of stack-2


cluster member mac pass

end

rc 1


!!!! If everything is correct, you should be able to remote into stack-2.

recep.sefer Wed, 01/08/2014 - 03:30
User Badges:

Thank you very much

I  access switch with you help

I correct th config

and everthing works

Leo Laohoo Wed, 01/08/2014 - 13:37
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Thank you very much for taking the time to rate our posts. 

Actions

This Discussion