Inter vlan routing not working on RV180

Unanswered Question
Jan 20th, 2014
User Badges:

I've created two vlans and enabled inter-vlan routing on both. I can access the WAN from each vlan, but I can't access any device across the vlans. Is there something else I need to do?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tom Watts Mon, 01/20/2014 - 15:48
User Badges:
  • Green, 3000 points or more

Hi David, please ensure the members of the VLAN.

As an example port 1 may be vlan 1 untag while port number 2 should be vlan 2 untag.

In addition, ensure the connected devices do not have a firewall blocking connection. By default Windows as an example blocks ping (ICMP) so you may want to disable firewall capabilities for testing.



-Tom
Please mark answered for helpful posts

tech000032 Tue, 01/21/2014 - 14:05
User Badges:

Tom, Thanks for the reply.


Regarding members of the VLAN, I'm using one port as a trunk for both VLANs. I've set up the port so that it sees tagged packets from both VLANs.


Capture.PNG


This seems to be working since I can access the WAN through the RV180 from either VLAN. I can also ping each VLAN from the RV180's ping utility.


Regarding the firewall blocking, I'm trying multiple hosts with multiple protocols, for example, Windows and Linux PCs, web admin pages, etc. I get nothing when trying to communicate across VLANs.


One thing, I have the RV180 set to "gateway" mode. Does this have to be "router" mode for inter-vlan routing to work?


Thanks.

mpyhala Tue, 01/21/2014 - 14:46
User Badges:
  • Gold, 750 points or more

David,


Have you tested with a port Untagged for each VLAN? Example: Port 2 VLAN 8 Untagged, Port 3 VLAN 19 Untagged. This may not be practical for real world use, but try it as a test.


Are the devices in each VLAN getting DHCP addresses from the RV180?


What are the VLAN subnets?


Is the VLAN IP of the RV180 the Default Gateway for the devices in the VLAN?


Latest firmware?


If the RV180 is gateway to the internet then it should be in gateway mode. If you put it in router mode your LAN devices will not be able to reach the internet.


- Marty

viningele Tue, 01/21/2014 - 18:17
User Badges:

Did you also check VLAN enable on the top of the vlan member page?  How are you connecting clients to the various vlans, are you just using the four ports, four clients, a multi-vlan ap or a managed vlan capble switch? Why isn't vlan 1 inter-vlan enabled?  When pinging from diagnotic utility your using vlan 1  and if it's set to inter-vlan the router won't route to the other vlans from it.

tech000032 Wed, 01/22/2014 - 03:47
User Badges:

viningele,


VLAN enable is checked.


I'm using one port as a trunk from a managed vlan capable switch.


vlan 1 inter vlan is not enabled because I'm not using vlan 1. I'm only interested in vlan 8 and vlan 19. I can ping hosts on vlan 8 and vlan 19 from the RV180 diagnostic ping utility.

viningele Wed, 01/22/2014 - 09:04
User Badges:

I assume your managed switch is acting as the DHCP server then.  You could make the RV the dhcp server and eliminate the servers on the switch or you might try changing the default router setting in each vlan dhcp pool on the switch to the ip of the vlan interface of on the RV since that's what you want to do your routing.  I'm not sure if that will screw up you dhcp server Pol though which is why it might be easiest just to let the RV handle that too. 


I had a simiar but opposite issue a couple of weeks ago where I wanted my L3 switch to handle interv-vlan routing but wanted the vlan 1 dhcp server on the RV320 and the fix recommended was to move the dhcp server to the switch so the default router for that vlan was the ip of the switch vlan interface, SVI.  Your SVI is on the RV but in the switch you're provably telling to use the ip of your dhcp server.


Disclaimer: I could be completely wrong but based on my limited knowledge I think that's the root of your issue.

tech000032 Wed, 01/22/2014 - 03:40
User Badges:

Marty,


I'm using a single port as a trunk. I haven't tried using separate ports with untagged traffic. I'll try using separate ports with untagged packets as a test.


Regarding DHCP: I am not using the RV180 to provide DHCP for either VLAN. I have another device doing that.


VLAN subnets are: VLAN 8: 192.168.8.0/24, VLAN 19: 192.168.19.0/24


Yes, the VLAN IP of the RV180 is the default gateway for the devices. They do route to the WAN properly.


Yes, I have the latest firmware.


Thanks.

Actions

This Discussion

Related Content