×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

3750X-48P-S switch IOS upgrade from 12.X to 15.X

Unanswered Question
Jan 21st, 2014
User Badges:

Hello Everyone,


I am trying to upgrade the license for 3750X-48P-S switch to latest 15.X release (15.2.1E1). but end up with the IOS uncompatable error. Presently the IOS image and version on the switch is C3750E-UNIVERSALK9NPE-M & 12.2(55)SE5


I downloaded multiple images from Cisco.com under switches section 3750X-48P-S (http://software.cisco.com/download/release.html?mdfid=282979366&flowid=2632&softwareid=280805680&release=15.2.1E1&relind=AVAILABLE&rellifecycle=ED&reltype=latest)


1. c3750e-universalk9npe-tar.152-1.E1.tar

2. c3750e-universalk9-tar.152-1.E1.tar


I use the command archive download-sw /safe tftp://x.x.x.x/iosname.tar flash: and it sucessfully uploaded the image but gave error while extracting and for other IOS at the time i enter the command and press enter it gave ios does not match error.


This switch has Permenent IPBase license and IPServices evaluation license. I have attached show version and show license all output. First time i am upgrading the IOS which has name npe in the name (C3750E-UNIVERSALK9NPE-M).


Kindly advise what will be the right IOS to upgrade the present 12.2(55)SE5 to the latest 15.x version.


Input in this regard will be highly appriciated.


Thanks in Advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Amit Singh Tue, 01/21/2014 - 12:43
User Badges:
  • Cisco Employee,

Hi Fazal,


I think the issue could be the "IP Base" license installed on the system already. When switch tries to boot the new Uiniversal image, it looks for the specific license installed on the bootflash. Typically as per the release notes you have to work with Cisco Licensing to get an upgrade license for this.


http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/15.0_1_se/release/notes/OL25302.html#wp754685


I would suggest to use the IPbase image and see if that goes through. If it works fine then work with the licensing team to get the upgrade to universal image with the specific licenses.


Cheers,

-amit singh

Leo Laohoo Tue, 01/21/2014 - 13:29
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Fazal,


First off, try avoiding posting screen shots.  Some information can get obscured.


I use the command archive download-sw /safe tftp://x.x.x.x/iosname.tar flash: and it sucessfully uploaded the image but gave error while extracting and for other IOS at the time i enter the command and press enter it gave ios does not match error.

Post the entire process when you do this.  I want to see this.   Can you also post the output to the command "sh version".  Please do not edit anything out.  If you need to edit things out, take away IP addresses and/or passwords.

I am trying to upgrade the license for 3750X-48P-S switch to latest 15.X release (15.2.1E1).

Personally, I would stay away from IOS versions 15.2(1)E and 15.2(1)E1 as this train is very buggy.  You could go with 12.2(55)SE8 which is deemed to be very stable, particularly for 3750G/E/X.

Fazal E Rasool Khan Tue, 01/21/2014 - 21:47
User Badges:

Thanks for the reply Leo & Amit.


Apologized for the edited screenshot but this is what i get from customer on request and could not capture the IOS upload error unfortunately. Right now i dont have access to the switch as its at customer site.


My main concern is to just upgrade the image. As i mentioned in my first post it has  C3750E-UNIVERSALK9NPE-M

12.2(55)SE5 and will it be fine if i download the image c3750e-ipbasek9-tar.122-55.SE8.tar and upload it.


Or i have to use c3750e-ipbasek9npe-tar.122-55.SE8.tar which is IP BASE NO MACSEC WITH WEB BASED DEV MGR.


i know it costs to upgrade the license from IP base to IP Services and i cisco GPL its 8000$.


Please advise which IOS image i should use to upgrade to the latest stable version of 12.x(or122-55.SE8)


Fazal



Leo Laohoo Wed, 01/22/2014 - 00:55
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Please advise which IOS image i should use to upgrade to the latest stable version of 12.x(or122-55.SE8)

Personally, I would stay away from IOS versions 15.2(1)E and 15.2(1)E1 as this train is very buggy.  You could go with 12.2(55)SE8 which is deemed to be very stable, particularly for 3750G/E/X.

Fazal E Rasool Khan Wed, 01/22/2014 - 02:33
User Badges:

Thanks for the reply Leo. Please clear one confusion.


Right now switch has C3750E-UNIVERSALK9NPE-M. Will it be fine if i use c3750e-ipbasek9-tar.122-55.SE8.tar (

UNIVERSAL WITH WEB BASE DEV MGR) image or its mandatory to use c3750e-ipbasek9npe-tar.122-55.SE8.tar(UNIVERSAL NO MACSEC WITH WEB BASED DEV MGR) image.


Eventhough when i upgraded 15.x image it should atleast upgrade fine as it was for the same switch. 15.x has bugs are the other issue which come after image is upgraded.


Thanks again.

Actions

This Discussion

Related Content