×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CME and 2 sip inbound numbers not always working.

Unanswered Question
Jan 24th, 2014
User Badges:

I have a working configuration that has two different inbound numbers and one numebr works perfectly both inbound and outbound.not at all  But the other numer sometimes works inbound but ALWAYS works outbount.


I understand that is is not possable to get both numbers to be outbount but what I need is for both numbers to ALWAYS work inbound.


The number ending in 1577 always seems to receive inbound calls.


The number ending in 9001 sometime receives inboind calls and sometimes not.  Then for no reason it will start receiving calls again only to later quit working.


My config:


sip-ua

credentials number 5552901577 username GV15552901577 password 7 cisco123 realm GVGW

credentials number 5562439001 username GV15562439001 password 7 cisco123 realm GVGW

authentication username GV15562439001 password 7 cisco123 realm GVGW

mwi-server ipv4:10.110.0.2 expires 3600 port 5060 transport udp unsolicited

registrar dns:gvgw7.simonics.com:5070 expires 300 refresh-ratio 50 tcp

sip-server dns:gvgw7.simonics.com:5070


The 9001 ismy new business and the 1577 is my cell phone forwarded to google voice.


Any ideas on how to have them BOTH work reliabilly?


---Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gregory Brunn Fri, 01/24/2014 - 16:37
User Badges:
  • Bronze, 100 points or more

I have had simular problems with H.323 when I do not properly bind my source interfaces. Have not see exactly what you are experiences but have you properly bound your SIP traffic


See links below

http://www.cisco.com/en/US/docs/ios/12_2/12_2x/12_2xb/feature/guide/ftbind.html


SIP CME configuration

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a00808f9666.shtml


If you read through these and everything still seems fin,e start running some debugs see if you can not find where the call is failing and what the error code on the call is.


http://docwiki.cisco.com/wiki/Cisco_IOS_Voice_Troubleshooting_and_Monitoring_--_Cisco_SIP_Gateway_Troubleshooting


Hope this helps!


If you want post the rest of your configuration and the results of the debugs.

Michael Durham Sat, 01/25/2014 - 12:46
User Badges:

I read your links above and with what little knowledge I have, I think I have things set correctly.


I upoaded my CME router configuration and two debug ccsip all results. One called No Ring.txt where I call the number 5552439001 from my cell phone and the IP phone does not ring.  The other file called Ring1.txt wher I call 5552439001 from my cell phone it this tme the phone does ring. 


To get the phone to ring I did a NO SIP-UP command then reapplied the SIP config from the CME config file as attached.  Calles to 5552901577 seem to always work so I did not do a debug on that number.


One thing I noticed right off the top is the To


No Ring

To:

Ring

To:


Any suggestions?

Gregory Brunn Sat, 01/25/2014 - 13:48
User Badges:
  • Bronze, 100 points or more

Can you provide for me a show sip-ua status?

Per my comments above you want to check out this docmentation you are missing your bind statements in your configuration

http://www.cisco.com/en/US/docs/ios/12_2/12_2x/12_2xb/feature/guide/ftbind.html




voice service voip 

 sip

  bind all source-interface 

You are using interface GigabitEthernet0/1.110 for your CME configuraiton so you will want to use that here.

Give me the results of the show sip-ua status before and after you apply the command. Also give the results of the debugs after you have completed you binding.

I think you are running into a natting issue.  I will do a little more research on my end on the SIP 400 error message as well.


Michael Durham Sat, 01/25/2014 - 14:02
User Badges:

Currently both numebera are ringing.  Before changes.


SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED


SIP User Agent for TLS over TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
SIP early-media for 180 responses with SDP: ENABLED
SIP max-forwards : 70
SIP DNS SRV version: 2 (rfc 2782)
NAT Settings for the SIP-UA
Role in SDP: NONE
Check media source packets: DISABLED
Maximum duration for a telephone-event in NOTIFYs: 2000 ms
SIP support for ISDN SUSPEND/RESUME: ENABLED
Redirection (3xx) message handling: ENABLED
Reason Header will override Response/Request Codes: DISABLED
Out-of-dialog Refer: DISABLED
Presence support is DISABLED
protocol mode is ipv4


SDP application configuration:
Version line (v=) required
Owner line (o=) required
Timespec line (t=) required
Media supported: audio video image
Network types supported: IN
Address types supported: IP4 IP6
Transport types supported: RTP/AVP udptl


After cahnges:


SIP User Agent Status

SIP User Agent for UDP : ENABLED

SIP User Agent for TCP : ENABLED


SIP User Agent for TLS over TCP : ENABLED

SIP User Agent bind status(signaling): ENABLED  10.110.0.1

SIP User Agent bind status(media): ENABLED  10.110.0.1

SIP early-media for 180 responses with SDP: ENABLED

SIP max-forwards : 70

SIP DNS SRV version: 2 (rfc 2782)

NAT Settings for the SIP-UA

Role in SDP: NONE

Check media source packets: DISABLED

Maximum duration for a telephone-event in NOTIFYs: 2000 ms

SIP support for ISDN SUSPEND/RESUME: ENABLED

Redirection (3xx) message handling: ENABLED

Reason Header will override Response/Request Codes: DISABLED

Out-of-dialog Refer: DISABLED

Presence support is DISABLED

protocol mode is ipv4


SDP application configuration:

Version line (v=) required

Owner line (o=) required

Timespec line (t=) required

Media supported: audio video image

Network types supported: IN

Address types supported: IP4 IP6

Transport types supported: RTP/AVP udptl

Michael Durham Sat, 01/25/2014 - 16:04
User Badges:

Its not ringing now and here is the sh sip-ua status command


CME_Router#show sip-ua status

SIP User Agent Status

SIP User Agent for UDP : ENABLED

SIP User Agent for TCP : ENABLED


SIP User Agent for TLS over TCP : ENABLED

SIP User Agent bind status(signaling): ENABLED  10.110.0.1

SIP User Agent bind status(media): ENABLED  10.110.0.1

SIP early-media for 180 responses with SDP: ENABLED

SIP max-forwards : 70

SIP DNS SRV version: 2 (rfc 2782)

NAT Settings for the SIP-UA

Role in SDP: NONE

Check media source packets: DISABLED

Maximum duration for a telephone-event in NOTIFYs: 2000 ms

SIP support for ISDN SUSPEND/RESUME: ENABLED

Redirection (3xx) message handling: ENABLED

Reason Header will override Response/Request Codes: DISABLED

Out-of-dialog Refer: DISABLED

Presence support is DISABLED

protocol mode is ipv4


SDP application configuration:

Version line (v=) required

Owner line (o=) required

Timespec line (t=) required

Media supported: audio video image

Network types supported: IN

Address types supported: IP4 IP6

Transport types supported: RTP/AVP udptl

Gregory Brunn Sat, 01/25/2014 - 16:48
User Badges:
  • Bronze, 100 points or more

Sounds like it is working now?  However reading more it sounds like it has worked before in the past just not all the time.  I am wondering why your Simon Telephonic would be sending you 1000 and not the number you are asking for in your registration.


I would see if it starts failing again and look at the debugs also look at debug dial-peer to see the call as it comes in what dial-peer your matching.


If I am correct your topology is PSTN-->Google voice --> Simon Telephonic google voice gateway --> Switch--> CME Switch --> SCCP Phone.


This is the topology for both #'s correct?


I really have not set up this type of SIP connection before but I would keep looking at the debugs when calls are failing.  If you keep seeing the 1000 number in the SIP invite instead of what you are expecting reach out to simonic to find out why they are sending you the extension in the invite. 


Looks like simon telephonic is not allowing anyone else to sign up for there Google Voice gateway service otherwise I might be tempted to recreated you sceanario myself.

Gregory Brunn Sat, 01/25/2014 - 17:34
User Badges:
  • Bronze, 100 points or more

Sorry I also misread your previous post that it was now ringing.  If you are not ringing remove the bind. I don't want to mislead you with that.


Other than running more debugs and the debug dial-peer command I would try talking to the Simon Telephonic guys about why you are sending you the 1000 extension some of the time instead of the full E.164. 

So you might find something by looking at the following show commands while inbound ringing is working and compare them to when it is running along with runnig

show sip service

show sip-ua register status

show sip-ua statistics

show sip-ua status


show sip-ua time

I will let anyone else in the community chime in if they have any experience with this.

Michael Durham Sun, 01/26/2014 - 11:35
User Badges:

You are correct on the topology for both numbers.  For some reason one number always works and the other one does not.  From what you said, it looks like my second number starts out registering the second number at 5552439001 and then drops that reg and starts using 1000, the translated number.  Weird.


I DO have two extra numbers that were previously registered with Simon.  I have all the infor for one of the and the other one we can get a new passcode for.  If I can PM you, I could give you the needed info.  But, in the long run, I really want to not loose thest numebers .  Just not using them right now.


Also, it looks like Google Voice is making some changes in a few months that may prevent us from using services like Simon.  At that point I will be porting my numbers to a SIP provider.  Looking for a good but chap one.  I could do that now if you feel it would be in my best interset.

Gregory Brunn Tue, 01/28/2014 - 18:34
User Badges:
  • Bronze, 100 points or more

Michael,


Had some time today to review and the binding of the SIP traffic has to deal with outgoing SIP related traffic.  Issuing the bind bind command in global SIP configuration mode set the source address for outgoing traffic.


Can you capture the out put of show sip-ua register status when inbound calling is working and is not working.  This command will display the status of E.164 numbers that a SIP gateway has registered with your simon registar server.


If there is a delta I am wondering if you have to tweak your register timer.  Once again this is just a thought.  The SIP register status command is only for outbound registration.  Let me know if you are able to run the test.

Actions

This Discussion