×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

3750 stack won't sync with NTP server

Unanswered Question
Jan 28th, 2014
User Badges:

Any help greatly appreciated with this one - I can't for the life of me figure out what's going wrong here.


I'm working on a 3750 stack in Singapore (UTC +8) and I'm trying to get it to sync its clock with 3.sg.pool.ntp.org.


This is the weird part - "sh ntp associations" shows that it is syncing:


-----------------------------------------------------------------------------------------------------------------------

  address         ref clock       st   when   poll reach  delay  offset   disp

*~199.195.193.200 203.117.180.36   2     52     64   377 80.936 -13895.  1.771

* sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured

-----------------------------------------------------------------------------------------------------------------------


And "sh ntp associations de" shows that it's happy:


-----------------------------------------------------------------------------------------------------------------------

199.195.193.200 configured, our_master, sane, valid, stratum 2

ref ID 203.117.180.36, time D691F63E.C4B691CD (17:26:22.768 UTC Tue Jan 28 2014)

our mode client, peer mode server, our poll intvl 64, peer poll intvl 64

root delay 196.39 msec, root disp 592.71, reach 377, sync dist 944.69

delay 80.93 msec, offset -13895.2686 msec, dispersion 2.65

precision 2**20, version 4

org time D691FA8F.5FF29003 (17:44:47.374 UTC Tue Jan 28 2014)

rec time D691FA9D.5041E9C7 (17:45:01.313 UTC Tue Jan 28 2014)

xmt time D691FA9D.3B3524C8 (17:45:01.231 UTC Tue Jan 28 2014)

filtdelay =    82.20   80.93   82.17   81.49  155.78   81.08   84.67   82.09

filtoffset = -13897. -13895. -13899. -13900. -13901. -13872. -13876. -13876.

filterror =     0.00    0.99    1.98    2.94    3.94    4.92    5.87    6.81

minpoll = 6, maxpoll = 10

--------------------------------------------------------------------------------------------------------------------------


But the clock is stubbornly remaining unsynchronised ("sh ntp st"):


--------------------------------------------------------------------------------------------------------------------------

Clock is unsynchronized, stratum 16, reference is 199.195.193.20

nominal freq is 119.2092 Hz, actual freq is 119.2092 Hz, precision is 2**17

reference time is 00000000.00000000 (08:00:00.000 UTC Mon Jan 1 1900)

clock offset is -13895.2686 msec, root delay is 0.00 msec

root dispersion is 14.62 msec, peer dispersion is 3.26 msec

loopfilter state is 'CTRL' (Normal Controlled Loop), drift is 0.000000000 s/s

system poll interval is 64, never updated.

--------------------------------------------------------------------------------------------------------------------------


NTP-relevant config is as follows (no ACLs, outbound UDP 123 allowed on perimeter firewall):


---------------------------------------------------------------------------------------------------------------------------

clock timezone UTC 8 0

ntp server 3.sg.pool.ntp.org

---------------------------------------------------------------------------------------------------------------------------


I have configured a pair of stacks in Hong Kong for NTP (though that was a couple of months ago and I recall that those were a pain at the time as well) and those are working fine.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chandrila Tue, 01/28/2014 - 04:54
User Badges:

Much to my annoyance, the switch stack is now synchronised.  No  configuration changes were made in the interim; it just looks like it  needed a long time (well over an hour in this case) to start syncing  properly.

Actions

This Discussion

Related Content