Cisco Prime LMS Device Names

Unanswered Question
Jan 30th, 2014
User Badges:

In Prime LMS 4.2, has anyone seen this issue/bug before?


I've added in all devices indicating their Device Names and Hostnames. However in the Monitor section and only High Severity Faults part, the Device Name is actually showing IP addresses.


In the Syslog report that sent via email, Device Name fields are showing IP addresses as well. Other sections or portlets are totally fine.


Thanks.

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
AFROJ AHMAD Thu, 01/30/2014 - 20:29
User Badges:
  • Cisco Employee,

Hi Bin,


Check the below link:

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_device_fault_manager/3.2/user/guide/useDevMg.html#wp1367517


Workaround to get the HOSTNAME in DFM is :


1> Added the Device Name and IP on the DNS Server or /etc/HOSTS file


2> Modified NMSROOT/objects/smarts/conf/discovery/discovery.conf, and changed the DisplayNameFormat from "AUTOASSIGNED" to "MIBIISYSNAME". 


That caused DFM to display the sysName as the display name.


Also set the NameFormat to TM_USEAUTONAME, then restarted daemon Manager (net stop crmdmgtd && net start crmdmgtd )


3> Delete and re-add a device in DFM


============


Open name-resolver.conf file and make same changes that we have made in discovery.conf.  ie, the following entry should be there in this file also.


  #NameFormat = "TM_USESEEDNAME"


  NameFormat = "TM_USEAUTONAME"


Thanks-

Afroz

[Do rate the useful post]

Actions

This Discussion