TMS agent database replication fails after changing IPs

Unanswered Question
Feb 11th, 2014
User Badges:

I have a change the VCS-C (Version x7.0.2) and TMS (version 13.1.2) IPs and now I can't log in with the Jabber Video clients.

I was doing troublehouting and I discovered the following error:


Verifies that the VCS IP address is in the Local TMS Agent list of replicating agents.

If the VCS IP address isn't in the Local TMS Agent list of replicating agents, replication will fail.

TMS agent data replication is enabled for this TMS Agent, but the network address of this VCS was not found in the list of replicating agents read from the local TMS agent. If you have recently enabled data replication for this system, please wait and refresh after the background event on the TMS Server setting up the replication has finished. If not, try to reenable the replication by turning if off and then back on again for this VCS in the System Navigator page under the TMS Agent tab. You should perform a "Create TMS Agent backup file" on each VCS peer BEFORE disabling and re-enabling data replication.



Error details from TMS Agent:

System IP (the new IP) or host name (vcs.xxx.com) not found in list of replicating agents.



I have stoped the TMS agent and start again but it has the same problem. I think that the TMS is trying to replicate with the old IP but I didn't found where I can change it.

I have read that I will need to purge the TMS agents but I don't now what it could change in the VCS.


Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Martin Koch Sun, 02/16/2014 - 15:53
User Badges:
  • Red, 2250 points or more

Its two parts of the story.


It could be worth to look in to upgradeing to X8.1 and TMS14.x and use TMSPE.(or at least TMS 13.2.2 and X7.2.2)


I do not know your deployment.

(like it can get more complicated if you have cluster or replication to multiple VCSs, findme

data can get lost if you have to purge the db on the vcs and s on.)


So maybe its better if you contact Cisco TAC or ask your Cisco partner to help you.





Please remember to rate helpful responses and identify helpful or correct answers.

Javier Espejo Sun, 02/16/2014 - 23:04
User Badges:

Hi Martin,


I achieve to fix the problem. The problem was due to the fact that the vcs name and IP mismatch in TMS. At least, one of them must be the older or TMS will be unable to reconnect. If somebody has this problem I suggest to use TMS's diagnostic tests and keep some of these parameters.


Now I am working in a upgrade for the server. Could you recommend a guide for upgrading TMS and VCS? Do I need to contact with cisco licencing if I upgrade?


Regards

Actions

This Discussion