×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

LDAP sync, Directory URI and SIP dialing

Unanswered Question
Feb 13th, 2014
User Badges:

note: CUCM version 9.1.2


I have an issue when dialing people from a Telepresence endpoint.

For phones, we have setup a specific phone service pointing to an external web server for Phone Directory.

Telepresence endpoints cannot use that service and point automatically to the default corporate directory.


Since we upgraded CUCM to version 9.1.2, the "Directory URI" parameter is now setup on end-users and their associated DN, as it is synced with LDAP.

So when we want to dial a user using the directory from a Telepresence endpoint it dials the SIP address: [email protected]

The problem is that the "directory-URI" parameter pulled from LDAP is sip:[email protected]


When dialing sip:[email protected] from the endpoint, sip: is apparently stripped and [email protected] is dialed and it never reach the end-user.

When dialing from a phone a Telepresence endpoint the URI displays as [email protected]and when dialing that back (or diling it manualy) from the Telepresence endpoint, it then reaches the end-user.

If I add onto the end user DN, under the "directory-URI" parameter [email protected] in addition to sip:[email protected] then when dialing the end-user [email protected] URI, the call completes.


But I don't want to to update our thousands of DNs, even with any of the bulk admin tools.


How can I get that working and make sure that the CUCM understand that [email protected] is the same as sip:[email protected] ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gfolens Mon, 03/10/2014 - 04:42
User Badges:

I've about the same problem. The only difference is that I've a SIP trunk to a VCS Control which is in the same SIP domain.

I've a SIP Route Pattern to that domain that points to the SIP trunk.

I would expect like a Route Pattern the CUCM gives priority to local registered devices before routing the call to the VCS. But this is not the case.

When I add the directory URI manually to the line then it works fine.

The trouble is that on the C-series registered devices on the CUCM the phonebook does not contain the DN's of the registered phones anymore but the SIP URI automatically loaded from the User profile...

rgds, Geert.

gfolens Mon, 03/10/2014 - 06:54
User Badges:

I think I found th esolution to this problem.

On the CUCM Enterprise parameters adjust the following:

1. Adjust "Directory URI Alias Partition" to an existing partition, e.g. "PT_Internal"
2. Adjust "URI Lookup Policy" to "Case Insensitive"
 

This is partially documented in the CUCM v9.1 System guide under SIP URI dialing.

rgds, Geert.

 

Matthieu LIENART Mon, 03/10/2014 - 19:30
User Badges:

I had already seen that part of the doc and applied the points 1 & 2 you propose.

It doesn't solve the issue.

It doesn't make the CUCM understand that [email protected] is the same as sip:[email protected]...

Today the only solution I can see is to manually add [email protected] under the "directory-URI" parameter but this is not a viable solution. It's not possible for us to maintain that up to date manually.

Actions

This Discussion

Related Content