×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

E1 line configuration on iOS

Unanswered Question
Feb 17th, 2014
User Badges:

Hi All,


I have a cisco router c2600 version 12.4T. I'm trying to configure the E1 on that router and connectto an eFax server. but it seems that there is some thing wrong in the configuration. Are there anything wrong in the config ??






Current configuration : 2759 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MAA-FAX

!

boot-start-marker

boot system flash

boot system flash c2600-ipvoice-mz.124-15.T14.bin

boot-end-marker

!

card type e1 1 1

enable secret 5 $1$Eu5N$LNIs2iojGJB.VUSeYS45T1

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

ip domain name main.knpcdom.net

multilink bundle-name authenticated

isdn switch-type primary-net5

voice-card 1

!

!

!

!

voice service voip

allow-connections h323 to h323

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

h323

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729br8

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive

log config

  hidekeys

!

!

controller E1 1/0

pri-group timeslots 1-31

!

controller E1 1/1

pri-group timeslots 1-31

!

!

!

!

!

interface FastEthernet0/0

ip address x.x.x.x(voice GW ip) 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

!

interface Serial1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial1/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 x.x.x.x(Voice GW ip -last digit is 1)

!

no ip http server

!

no logging trap

!

!

control-plane

!

!

!

voice-port 1/0:15

!

voice-port 1/1:15

!

!

!

!

!

dial-peer voice 100 voip

preference 2

destination-pattern [1234567890]...

voice-class codec 1

session target ipv4:x.x.x.x (the eFax server ip)

dtmf-relay h245-alphanumeric

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

no vad

!

dial-peer voice 200 pots

destination-pattern 2.......

port 1/0:15

!

dial-peer voice 101 voip

preference 1

destination-pattern [1234567890]...

voice-class codec 1

session target ipv4:x.x.x.x (the eFax backup server ip)

dtmf-relay h245-alphanumeric

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

no vad

!

dial-peer voice 10 voip

translation-profile incoming rightfax

voice-class codec 1

incoming called-number 2.......

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 2 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 102 voip

destination-pattern 8...

session target ipv4:x.x.x.x (CUCM ip)

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 103 voip

preference 1

destination-pattern 8...

session target ipv4:x.x.x.x (CUCM backup ip)

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 1 voip

voice-class codec 1

incoming called-number .

dtmf-relay h245-alphanumeric

no vad

!

!

!

line con 0

password ******

login

line aux 0

line vty 0 4

password ******

login

transport input all

!

!

end




Thank alot

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Thu, 02/20/2014 - 07:13
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I am surprised to see encapsulation hdlc on the serial interfaces. Are you sure that the server is processing hdlc?


HTH


Rick

Dragan Ilic Fri, 02/21/2014 - 01:21
User Badges:
  • Silver, 250 points or more

Can you post output of "debug isdn q921" and "debug isdn q931" during attempt to make a call?



HTH,
Dragan

Actions

This Discussion