CellRoute 3G GSM Box to Cisco 2921 Analog Trunk Configuration

Unanswered Question
Feb 17th, 2014
User Badges:

Hi all,


I'm  trying to configure  a 2921 Cisco voice gateway to place mobile calls  trough an analog CellRoute 3G GSM Box.


ios is c2900-universalk9-mz.SPA.152-4.M4.bin. FXO card is VIC2-2FXO.


Till now I get only a fast-busy tone on every outgoing calls. I'm sure  the gsm-box is working fine, since a call placed through it with an  analog phone directly connected is successful in both directions.

From the cisco debug info (debug vpm all) it seems to me that my fxo is unable to going off-hook and break the dial-tone.


####################


VOIPPEBAR#

Feb 17 17:08:22.009: htsp_timer_stop3 htsp_setup_req

Feb 17 17:08:22.009:  Orig called num: ###my mobile number #######

Feb 17 17:08:22.009: htsp_process_event: [0/0/0, FXOLS_ONHOOK, E_HTSP_SETUP_REQ]fxols_onhook_setup

Feb 17 17:08:22.009: [0/0/0] set signal state = 0xC timestamp = 0

Feb 17 17:08:22.009: dsp_set_sig_state: [0/0/0] packet_len=12 channel_id=128 packet_id=39 state=0xC timestamp=0x0

Feb 17 17:08:22.009: TGRM: reg_invoke_tgrm_call_update(0, 0, 0, 65535, 1, TGRM_CALL_BUSY, TGRM_CALL_VOICE, TGRM_DIRECTION_OUT)

Feb 17 17:08:22.009: htsp_timer - 1300 msec

Feb 17 17:08:22.265: htsp_process_event: [0/0/0, FXOLS_WAIT_DIAL_TONE, E_DSP_SIG_1100]fxols_power_denial_detected

VOIPPEBAR#

Feb 17 17:08:22.265: htsp_timer2 - 1000 msec

Feb 17 17:08:22.265: htsp_timer_stop

Feb 17 17:08:23.265: htsp_process_event: [0/0/0, FXOLS_WAIT_DIAL_TONE, E_HTSP_EVENT_TIMER2]fxols_power_den_disc

Feb 17 17:08:23.265: htsp_timer_stop

Feb 17 17:08:23.265: htsp_timer_stop2

Feb 17 17:08:23.265: [0/0/0] set signal state = 0x4 timestamp = 0

Feb 17 17:08:23.265: dsp_set_sig_state: [0/0/0] packet_len=12 channel_id=128 packet_id=39 state=0x4 timestamp=0x0

Feb 17 17:08:23.265: mars_flex_dsprm_current_codec_comp:DSP:0 FLEX Complexity Codec htsp_release_req: cause 34, no_onhook 0

Feb 17 17:08:23.265: htsp_process_event: [0/0/0, FXOLS_ONHOOK, E_HTSP_RELEASE_REQ]fxols_onhook_release

Feb 17 17:08:23.265: TGRM: reg_invoke_tgrm_call_update(0, 0, 0, 65535, 1, TGRM_CALL_IDLE, TGRM_CALL_VOICE, TGRM_DIRECTION_OUT)

Feb 17 17:08:23.265: flex_dsprm_close_cleanup

VOIPPEBAR#


####################


This is how I configured my fxo port:

####################

voice-port 0/0/0                           
  cptone ES                           # tried also with US tone with no luck
  connection plar opx 200            
  impedance 600c                  # impedance value taken from
CellRoute 3G GSM Box manual
  description :: GSM BOX ::         
  caller-id enable                    

####################

This is the complete configuration:

####################

Foreign Exchange Office 0/0/0 Slot is 0, Sub-unit is 0, Port is 0
  Type of VoicePort is FXO
  Operation State is DORMANT
  Administrative State is UP
  No Interface Down Failure
  Description is :: GSM BOX ::
  Noise Regeneration is enabled
  Non Linear Processing is enabled
  Non Linear Mute is disabled
  Non Linear Threshold is -21 dB
  Music On Hold Threshold is Set to -38 dBm
  In Gain is Set to 0 dB
  Out Attenuation is Set to 3 dB
  Echo Cancellation is enabled
  Echo Cancellation NLP mute is disabled
  Echo Cancellation NLP threshold is -21 dB
  Echo Cancel Coverage is set to 128 ms
  Echo Cancel worst case ERL is set to 6 dB
  Playout-delay Mode is set to adaptive
  Playout-delay Nominal is set to 60 ms
  Playout-delay Maximum is set to 1000 ms
  Playout-delay Minimum mode is set to default, value 40 ms
  Playout-delay Fax is set to 300 ms
  Connection Mode is plar opx
  Connection Number is 200
  Initial Time Out is set to 15 s
  Interdigit Time Out is set to 10 s
  Call Disconnect Time Out is set to 60 s
  Power Denial Disconnect Time Out is set to 1000 ms
  Ringing Time Out is set to 180 s
  Wait Release Time Out is set to 30 s
  Companding Type is u-law
  Region Tone is set for ES

  Analog Info Follows:
  Currently processing none
  Maintenance Mode Set to None (not in mtc mode)
  Number of signaling protocol errors are 0
  Impedance is set to 600c Ohm
  Station name None, Station number None

Caller ID Info Follows:
  Standard ETSI
  Caller ID is received after 1 ring(s)
  Translation profile (Incoming):
  Translation profile (Outgoing):
  lpcor (Incoming):
  lpcor (Outgoing):
          
  Voice card specific Info Follows:
  Signal Type is loopStart
  Battery-Reversal is enabled
  Number Of Rings is set to 1
  Supervisory Disconnect is signal
  Answer Supervision is inactive
  Hook Status is On Hook
  Ring Detect Status is inactive
  Ring Ground Status is inactive
  Tip Ground Status is inactive
  Dial Out Type is dtmf
  Digit Duration Timing is set to 100 ms
  InterDigit Duration Timing is set to 100 ms
  Pulse Rate Timing is set to 10 pulses/second
  InterDigit Pulse Duration Timing is set to 750 ms
  Percent Break of Pulse is 65 percent
  GuardOut timer is 2000 ms
  Minimum ring duration timer is 125 ms
  Hookflash-in Timing is set to 600 ms
  Hookflash-out Timing is set to 400 ms
  Supervisory Disconnect Timing (loopStart only) is set to 350 ms
  OPX Ring Wait Timing is set to 6000 ms
  Secondary dialtone is disabled

####################


How can I fix this?


Thank you,


Daniele

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion