×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

router (config-vpdn-req-in)#protocol pppoe (not find ) cisco 887va

Unanswered Question
Feb 23rd, 2014
User Badges:

i try to config adsl

i used this config



Configure ip routing, ip subnet-zero, and ip classless in order to provide flexibility in routing configuration options.

(config)#ip routing

(config)#ip subnet-zero

(config)#ip classless



Configure the global Point-to-Point Protocol over Ethernet (PPPoE) parameters.

(config)#vpdn enable

(config)#no vpdn logging

(config)#vpdn-group pppoe

(config-vpdn)#request-dialin

(config-vpdn-req-in)#protocol pppoe

(config-vpdn-req-in)#exit

(config-vpdn)#exit



Configure an IP address and subnet mask on the Cisco DSL Router Ethernet interface.

(config)#int ethernet 0

(config-if)#ip tcp adjust-mss 1452

(config-if)#ip address 41.32.58.169 255.255.255.248

(config-if)#ip nat inside

(config-if)#no shutdown

(config-if)#exit



Configure the ATM interface of your Cisco DSL Router with an ATM permanent virtual circuit (PVC), encapsulation type, and dialer pool.

(config)#int atm 0

(config-if)#pvc 0/35

(config-if-atm-vc)#pppoe-client dial-pool-number 1

(config-if-atm-vc)#no shutdown

(config-if)#exit

*******************

(config)#int dialer 1

(config-if)#mtu 1492

(config)#int dialer 1

(config-if)#mtu 1492

(config-if)#ip address 196.202.4.105 255.255.255.248

(config-if)#encapsulation ppp



********************

(config-if)#dialer pool 1

(config-if)#ppp pap sent-username [email protected] password ******

(config-if)#exit




Configure a default route using Dialer1 as the outbound interface.

(config)#ip route 0.0.0.0 0.0.0.0 dialer 1


i don't find pppoe protocol red line

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Sun, 02/23/2014 - 10:53
User Badges:
  • Cisco Employee,

Hi Ahmed,


New IOSes do not use that kind of configuration. That is why you don't see the red line. Simply skip the entire VPDN section and you should be fine. The necessary PPPoE configuration is done on the PVC 0/35 - the PPPoE client is activated there, and that is all that is needed.


Best regards,

Peter

CSCO11649089 Mon, 02/24/2014 - 00:26
User Badges:

thanks


now i don't need NAT .. the pc will take real ip 

create vlan with real ip

so the config will be



Configure ip routing, ip subnet-zero, and ip classless in order to provide flexibility in routing configuration options.

(config)#ip routing

(config)#ip subnet-zero

(config)#ip classless



i don't need that right !!!!!!!!!!!!!!!!

******************************

Configure an IP address and subnet mask on the Cisco DSL Router Ethernet interface.

(config)#int ethernet 0

(config-if)#ip tcp adjust-mss 1452

(config-if)#ip address 41.32.58.169 255.255.255.248

(config-if)#ip nat inside

(config-if)#no shutdown

(config-if)#exit

****************************



Configure the ATM interface of your Cisco DSL Router with an ATM permanent virtual circuit (PVC), encapsulation type, and dialer pool.

(config)#int atm 0

(config-if)#pvc 0/35

(config-if-atm-vc)#pppoe-client dial-pool-number 1

(config-if-atm-vc)#no shutdown

(config-if)#exit

*******************

(config)#int dialer 1

(config-if)#mtu 1492

(config)#int dialer 1

(config-if)#mtu 1492

(config-if)#ip address 196.202.4.105 255.255.255.248

(config-if)#encapsulation ppp



********************

(config-if)#dialer pool 1

(config-if)#ppp pap sent-username [email protected] password ******

(config-if)#exit




Configure a default route using Dialer1 as the outbound interface.

(config)#ip route 0.0.0.0 0.0.0.0 dialer 1


interface Vlan10

ip address 196.202.4.105 255.255.255.248



*************************************************


right this config or have any mistake

CSCO11649089 Mon, 03/03/2014 - 01:04
User Badges:

nowi have another message


when i create vlan

196.202.4.105 overlaps with dialer1


i need to make this ip  196.202.4.105 gateway to pc without nat static ip


how can i solve it

CSCO11649089 Mon, 03/03/2014 - 01:30
User Badges:

new update


(config)#int dialer 1

(config-if)#mtu 1492

(config)#int dialer 1

(config-if)#mtu 1492

(config-if)#ip address 196.202.4.105 255.255.255.248

(config-if)#encapsulation ppp


interface Vlan10

ip address 196.202.4.105 255.255.255.248



and it's run


but when i ping in yahooo

196.202.4.105 unreachable

and in racert stop in 196.202.4.105



Actions

This Discussion