×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SRST incoming call fail on FXO Port

Answered Question
Feb 23rd, 2014
User Badges:

Hi all


im using cisco 2901 has a MGCP Gateway whit FXO ports on a remote branch office.


When the Gateway is connected to the CUCM all works fine but when the Gateway disconnects from the CUCM it goes into SRST mode:

In SRST Mode the outgoing calls works fine.

The problem is when there is a incoming call  on SRST mode :  the external incoming call ring one time and after that the call is connected, but with silent, the extension won't ring and the FXO ports stays on until the cable is unpulg.


Using debug voip ccapi i see the incoming calls are getting into the (dial-peer voice 999010 pots) ignoring the (connection plar 216) on each port.


If i delete the (dial-peers voice 999010 pots) when on SRST Mode then all the incoming calls works fine, but when the connection to the CUCM is establish the dial-peers gets back on.


what am i missing here ?


Thanks in advance.


Here is my configuration:



!

trunk group TELNOR_GROUP

hunt-scheme longest-idle

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729br8

codec preference 3 g729r8

!

!

voice hunt-group 1 parallel

list 216,215,214,213

timeout 20

pilot 280

!

!

!

!

voice translation-rule 1

rule 1 /^8/ //

!

!

voice translation-profile OutgoingProfile_1

translate called 1

!

!

voice-card 0

dsp services dspfarm

!

!

application

global

  service alternate default

!

!

!

!

!

!

ip tftp source-interface Vlan100

ip ssh version 1

!

!

!

!

!

!

!

interface Loopback0

ip address 10.2.10.2 255.255.255.252

!

interface FastEthernet0/1/0

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/1

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/2

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/3

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/4

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/5

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/6

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/7

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/8

switchport mode trunk

no ip address

!

interface Vlan1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1412

!

interface Vlan100

ip address 10.2.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1412

!

ip forward-protocol nd

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip dns server

ip nat inside source route-map SDM_RMAP_1 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 10.2.10.1 255.255.255.255 Integrated-Service-Engine0/0

!

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 192.168.2.0 0.0.0.255

access-list 20 remark CCP_ACL Category=1

access-list 20 permit 192.168.2.0 0.0.0.255

access-list 20 permit 10.2.2.0 0.0.0.255

access-list 20 permit 192.168.0.0 0.0.0.255

access-list 20 permit 10.242.2.0 0.0.0.255

access-list 20 permit 10.1.1.0 0.0.0.255

access-list 100 remark CCP_ACL Category=2

access-list 100 deny   ip 10.2.10.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 100 deny   ip 10.2.10.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 100 deny   ip 10.2.10.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 100 deny   ip 10.2.10.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 100 deny   ip 10.2.2.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 100 deny   ip 10.2.2.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 100 deny   ip 10.2.2.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 100 deny   ip 10.2.2.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 100 deny   ip 192.168.2.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 100 deny   ip 192.168.2.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 100 deny   ip 192.168.2.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 100 deny   ip 192.168.2.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 100 permit ip 192.168.2.0 0.0.0.255 any

access-list 2000 remark CCP_ACL Category=4

access-list 2000 permit ip 192.168.2.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 2000 permit ip 192.168.2.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 2000 permit ip 192.168.2.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 2000 permit ip 192.168.2.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 2000 permit ip 10.2.2.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 2000 permit ip 10.2.2.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 2000 permit ip 10.2.2.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 2000 permit ip 10.2.2.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 2000 permit ip 10.2.10.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 2000 permit ip 10.2.10.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 2000 permit ip 10.2.10.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 2000 permit ip 10.2.10.0 0.0.0.255 192.168.100.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

!

!

route-map SDM_RMAP_1 permit 1

match ip address 100

!

!

!

control-plane

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

!

voice-port 0/0/3

ring frequency 20

!

voice-port 0/1/0

trunk-group TELNOR_GROUP

supervisory disconnect dualtone mid-call

no battery-reversal

cptone MX

timeouts call-disconnect 1

timeouts wait-release 3

timing hookflash-out 50

connection plar 216

description TELNOR_0

caller-id enable

!

voice-port 0/1/1

trunk-group TELNOR_GROUP

supervisory disconnect dualtone mid-call

no battery-reversal

cptone MX

timeouts call-disconnect 1

timeouts wait-release 3

timing hookflash-out 50

connection plar 216

description TELNOR_1

caller-id enable

!

voice-port 0/1/2

cptone MX

timing hookflash-out 50

caller-id enable

!

voice-port 0/1/3

cptone MX

timing hookflash-out 50

caller-id enable

!

voice-port 0/4/0

auto-cut-through

signal immediate

input gain auto-control

description Music On Hold Port

!

ccm-manager shut-backhaul-interfaces

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.1.1.2

ccm-manager config

!

mgcp

mgcp call-agent 10.1.1.2 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp bind control source-interface Vlan100

mgcp bind media source-interface Vlan100

!

mgcp profile default

!

sccp local Vlan100

sccp

!

dial-peer voice 999010 pots

service mgcpapp

port 0/1/0

!

dial-peer voice 999011 pots

service mgcpapp

port 0/1/1

!

dial-peer voice 999000 pots

service mgcpapp

port 0/0/0

!

dial-peer voice 999001 pots

service mgcpapp

port 0/0/1

!

dial-peer voice 999002 pots

service mgcpapp

port 0/0/2

!

dial-peer voice 999003 pots

service mgcpapp

port 0/0/3

!

dial-peer voice 999012 pots

service mgcpapp

port 0/1/2

!

dial-peer voice 999013 pots

service mgcpapp

port 0/1/3

!

dial-peer voice 1 pots

trunkgroup TELNOR_GROUP

description International

translation-profile outgoing OutgoingProfile_1

destination-pattern 800T

forward-digits all

!

dial-peer voice 2 pots

trunkgroup TELNOR_GROUP

description National_Cell

translation-profile outgoing OutgoingProfile_1

destination-pattern 8045..........

forward-digits all

!

dial-peer voice 3 pots

trunkgroup TELNOR_GROUP

description National

translation-profile outgoing OutgoingProfile_1

destination-pattern 801..........

forward-digits all

!

dial-peer voice 4 pots

trunkgroup TELNOR_GROUP

description Local_Cell

translation-profile outgoing OutgoingProfile_1

destination-pattern 8044686.......

forward-digits all

!

dial-peer voice 5 pots

trunkgroup TELNOR_GROUP

description Local

translation-profile outgoing OutgoingProfile_1

destination-pattern 8.......

forward-digits all

!

!

!

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 10.2.2.1 port 2000

max-ephones 12

max-dn 8 dual-line

system message primary SRST

date-format dd-mm-yy

!

!

Correct Answer by islam.kamal about 3 years 5 months ago

Hi Mario


1- I didnot notice ccm-manager fallback-mgcp on your configuation , pleae check. This is manadatory .

2-no need for inbound dial-peer.


Thanks

Please rate all useful information

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
islam.kamal Sun, 02/23/2014 - 11:02
User Badges:
  • Red, 2250 points or more

Hi Mario


Can you find the below?.


1-configure terminal

ccm-manager fallback-mgcp

application

global

  service alternate default

  end

2-Test

If this not help , please use plar-opx instead of plar


Thanks

Please rate all useful information

Mario Musquiz Sun, 02/23/2014 - 11:22
User Badges:

Hi, i do have the (service alternate default)

I try whit the (connection plar opx) and the (connection plar opx immediate) and i still get the same issue.


Do i need to create a dial-peer for incoming calls in SRST mode ? if so, how can i foward a call to a extension in a dial-peer ?


Regards.

Correct Answer
islam.kamal Sun, 02/23/2014 - 11:39
User Badges:
  • Red, 2250 points or more

Hi Mario


1- I didnot notice ccm-manager fallback-mgcp on your configuation , pleae check. This is manadatory .

2-no need for inbound dial-peer.


Thanks

Please rate all useful information

islam.kamal Sun, 02/23/2014 - 11:48
User Badges:
  • Red, 2250 points or more

Hi


Can you share the following

debug mgcp pack

debug vpm sig

debug voip ccapi inout


Thanks


Please rate all useful information

Mario Musquiz Sun, 02/23/2014 - 12:31
User Badges:

hi here is a debug of a call in SRST Mode





.Feb 23 20:27:41.028: htsp_process_event: [0/1/1, FXOLS_ONHOOK, E_DSP_SIG_0000]fxols_onhook_ringing

.Feb 23 20:27:41.028: htsp_timer - 125 msec

.Feb 23 20:27:41.156: htsp_process_event: [0/1/1, FXOLS_WAIT_RING_MIN, E_HTSP_EVENT_TIMER]fxols_wait_ring_min_timer

.Feb 23 20:27:41.156: htsp_timer - 10000 msec

.Feb 23 20:27:41.156: htsp_timer3 - 5600 msec

.Feb 23 20:27:41.156: [0/1/1] htsp_start_caller_id_rx:BELLCORE

.Feb 23 20:27:41.156: htsp_start_caller_id_rx create dsp_stream_manager

.Feb 23 20:27:41.156: [0/1/1] htsp_dsm_create_success  returns 1

.Feb 23 20:27:41.464: htsp_process_event: [0/1/1, FXOLS_RINGING, E_DSP_SIG_0100]

.Feb 23 20:27:41.464: fxols_ringing_not

.Feb 23 20:27:41.464: htsp_timer_stop

.Feb 23 20:27:41.464: htsp_timer - 10000 msec

.Feb 23 20:27:43.116: [0/1/1] htsp_dsm_feature_notify_cb  returns 2 id=DSM_FEATURE_SM_CALLERID_RX

.Feb 23 20:27:43.116: htsp_process_event: [0/1/1, FXOLS_RINGING, E_HTSP_CALLERID_RX_DONE]

.Feb 23 20:27:43.116: htsp_timer_stop

.Feb 23 20:27:43.116: htsp_timer_stop3

.Feb 23 20:27:43.116: [0/1/1] htsp_stop_caller_id_rx. message length 25htsp_setup_ind

.Feb 23 20:27:43.116: [0/1/1] get_fxo_caller_id:Caller ID received. Message type=128 length=25 checksum=AD

.Feb 23 20:27:43.116: [0/1/1] Caller ID String 80 16 01 08 30 32 32 33 31 32 32 37 02 0A 36 36 34 33 36 38 37 34 32 37 AD

.Feb 23 20:27:43.116: [0/1/1] get_fxo_caller_id calling num=*** calling name= calling time=02/23 12:27 

.Feb 23 20:27:43.120: fxols_callerid_done: call being answered

.Feb 23 20:27:43.120: //-1/C854B5C58039/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=***

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=0

   dest=216

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=0

   cisco-rdnplan=0

   cisco-rdnpi=0

   cisco-rdnsi=0

   cisco-redirectreason=0   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0



.Feb 23 20:27:43.120: //-1/C854B5C58039/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x89BB62B8, Call Info(

   Calling Number=***,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=216(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=999011, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=TRUE,

   Source Trkgrp Route Label=TELNOR_GROUP, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1

.Feb 23 20:27:43.120: //-1/C854B5C58039/CCAPI/ccCheckClipClir:

   In: Calling Number=***(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

.Feb 23 20:27:43.120: //-1/C854B5C58039/CCAPI/ccCheckClipClir:

   Out: Calling Number=***(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

.Feb 23 20:27:43.124: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


.Feb 23 20:27:43.124: :cc_get_feature_vsa malloc success

.Feb 23 20:27:43.124: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


.Feb 23 20:27:43.124:  cc_get_feature_vsa count is 1

.Feb 23 20:27:43.124: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


.Feb 23 20:27:43.124: :FEATURE_VSA attributes are: feature_name:0,feature_time:2351182240,feature_id:16

.Feb 23 20:27:43.124: //20/C854B5C58039/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=***(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=216(TON=Unknown, NPI=Unknown))

.Feb 23 20:27:43.124: [0/1/1] htsp_dsm_close_done

.Feb 23 20:27:43.124: htsp_process_event: [0/1/1, FXOLS_WAIT_SETUP_ACK, E_HTSP_SETUP_ACK]

.Feb 23 20:27:43.124: fxols_wait_setup_ack:

.Feb 23 20:27:43.124: [0/1/1] set signal state = 0xC timestamp = 0fxols_check_auto_call

.Feb 23 20:27:43.124: //20/C854B5C58039/CCAPI/cc_process_call_setup_ind:

   Event=0x89B666A0

.Feb 23 20:27:43.124: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 216

.Feb 23 20:27:43.124: //20/C854B5C58039/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 20 with tag 999011 to app "MGCPAPP"

.Feb 23 20:27:43.124: //20/C854B5C58039/CCAPI/ccCallSetContext:

   Context=0x8AE819A8

.Feb 23 20:27:43.124: //20/C854B5C58039/CCAPI/ccCallSetupAck:

   Call Id=20

.Feb 23 20:27:43.124: //20/C854B5C58039/CCAPI/cc_api_set_transfer_info:

   Transfer Number=, Transfer Reason=0x0

.Feb 23 20:27:43.124: //20/C854B5C58039/CCAPI/ccCallConnect:

   Progress Indication=NULL(0), Data Bitmask=0x0

.Feb 23 20:27:43.128: //20/C854B5C58039/CCAPI/ccCallConnect:

   Call Entry(Connected=TRUE, Responsed=TRUE)

.Feb 23 20:27:43.128: MGCP Packet sent to 10.1.1.2:2427--->

NTFY 841693232 aaln/S0/SU1/[email protected]-MXI MGCP 0.1

N: [email protected]:2427

X: 0

O: L/hd

<---



.Feb 23 20:27:43.128: htsp_process_event: [0/1/1, FXOLS_PROCEEDING, E_HTSP_SETUP_ACK]

.Feb 23 20:27:43.128: htsp_process_event: [0/1/1, FXOLS_PROCEEDING, E_HTSP_CONNECT]fxols_offhook_connect

.Feb 23 20:27:43.128: htsp_timer_stop

.Feb 23 20:27:43.396: htsp_process_event: [0/1/1, FXOLS_CONNECT, E_DSP_SIG_0110]fxols_rvs_battery

.Feb 23 20:27:43.396: htsp_timer_stop2

.Feb 23 20:27:43.632: MGCP Packet sent to 10.1.1.2:2427--->

NTFY 841693232 aaln/S0/SU1/[email protected]-MXI MGCP 0.1

N: [email protected]:2427

X: 0

O: L/hd

<---



.Feb 23 20:27:44.652: MGCP Packet sent to 10.1.1.2:2427--->

NTFY 841693232 aaln/S0/SU1/[email protected]-MXI MGCP 0.1

N: [email protected]:2427

X: 0

O: L/hd

<---



.Feb 23 20:27:46.672: MGCP Packet sent to 10.1.1.2:2427--->

NTFY 841693232 aaln/S0/SU1/[email protected]-MXI MGCP 0.1

N: [email protected]:2427

X: 0

O: L/hd

<---



.Feb 23 20:27:50.693: MGCP Packet sent to 10.1.1.2:2427--->

NTFY 841693232 aaln/S0/SU1/[email protected]-MXI MGCP 0.1

N: [email protected]:2427

X: 0

O: L/hd

<---



.Feb 23 20:27:54.713: MGCP Packet sent to 10.1.1.2:2427--->

NTFY 841693232 aaln/S0/SU1/[email protected]-MXI MGCP 0.1

N: [email protected]:2427

X: 0

O: L/hd

<---



.Feb 23 20:27:58.733: MGCP Packet sent to 10.1.1.2:2427--->

NTFY 841693232 aaln/S0/SU1/[email protected]-MXI MGCP 0.1

N: [email protected]:2427

X: 0

O: L/hd

<---

  

.Feb 23 20:28:02.753: MGCP Packet sent to 10.1.1.2:2427--->

NTFY 841693232 aaln/S0/SU1/[email protected]-MXI MGCP 0.1

N: [email protected]:2427

X: 0

O: L/hd

<---

Ayodeji Okanlawon Sun, 02/23/2014 - 11:48
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Mario..


You need ccm-manager fallback-mgcp, this is different from call-manager-fallback


RemoteSite# configure terminal


RemoteSite(config)# ccm-manager fallback-mgcp


RemoteSite(config)# application


RemoteSite(config - app)# global


RemoteSite(config - app -global)# service alternate default


RemoteSite(config - app -global)# end



Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Mario Musquiz Sun, 02/23/2014 - 12:34
User Badges:

Hi i try it but still the same issue.


Here is a full configuration


!

! Last configuration change at 12:22:19 Pacific Sun Feb 23 2014 by

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ***

!

boot-start-marker

boot-end-marker

!

!

no logging buffered

!

no aaa new-model

!

clock timezone Pacific -8 0

clock summer-time Pacific date Apr 6 2003 2:00 Oct 26 2003 2:00

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

crypto pki token default removal timeout 0

!

!

dot11 syslog

ip source-route

ip cef

!

!

!

ip dhcp excluded-address 192.168.2.1 192.168.2.9

ip dhcp excluded-address 192.168.2.251 192.168.2.254

ip dhcp excluded-address 10.2.2.1 10.2.2.9

ip dhcp excluded-address 10.2.2.251 10.2.2.254

!

ip dhcp pool data

import all

network 192.168.2.0 255.255.255.0

dns-server 192.168.2.1

default-router 192.168.2.1

!

ip dhcp pool voice

import all

network 10.2.2.0 255.255.255.0

option 150 ip 10.1.1.2

default-router 10.2.2.1

!

!

ip name-server 8.8.8.8

ip name-server 8.8.4.4

ip ddns update method ccp_ddns1

HTTP

  add ***

  remove ***

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

trunk group TELNOR_GROUP

hunt-scheme longest-idle

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729br8

codec preference 3 g729r8

!

!

voice hunt-group 1 parallel

list 216,215,214,213

timeout 20

pilot 280

!

!

!

!

voice translation-rule 1

rule 1 /^8/ //

!

!

voice translation-profile OutgoingProfile_1

translate called 1

!

!

voice-card 0

dsp services dspfarm

!

!

application

global

  service alternate default

!

!

!

!

license udi pid C1861E-UC-4FXO-K9

username ***

username ***

!

!

ip tftp source-interface Vlan100

ip ssh version 1

!

!

crypto isakmp policy 1

encr 3des

authentication pre-share

group 2

crypto isakmp key *** address ***

!

!

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

!

crypto map SDM_CMAP_1 1 ipsec-isakmp

description Tunnel to***

set peer ***

set transform-set ESP-3DES-SHA

match address 2000

!

!

!

!

!

!

interface Loopback0

ip address 10.2.10.2 255.255.255.252

!

interface FastEthernet0/0

description WAN$ETH-WAN$

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface Integrated-Service-Engine0/0

description CUE

ip unnumbered Loopback0

ip nat inside

ip virtual-reassembly in

service-module ip address 10.2.10.1 255.255.255.252

service-module ip default-gateway 10.2.10.2

!

interface FastEthernet0/1/0

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/1

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/2

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/3

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/4

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/5

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/6

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/7

switchport voice vlan 100

no ip address

spanning-tree portfast

!

interface FastEthernet0/1/8

switchport mode trunk

no ip address

!

interface Vlan1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1412

!

interface Vlan100

ip address 10.2.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1412

!

interface Dialer0

ip ddns update ***

ip ddns update ccp_ddns1

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname ***

ppp chap password 0 ***

ppp pap sent-username *** password 0 ***

crypto map SDM_CMAP_1

!

ip forward-protocol nd

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip dns server

ip nat inside source route-map SDM_RMAP_1 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 10.2.10.1 255.255.255.255 Integrated-Service-Engine0/0

!

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 192.168.2.0 0.0.0.255

access-list 20 remark CCP_ACL Category=1

access-list 20 permit 192.168.2.0 0.0.0.255

access-list 20 permit 10.2.2.0 0.0.0.255

access-list 20 permit 192.168.0.0 0.0.0.255

access-list 20 permit 10.242.2.0 0.0.0.255

access-list 20 permit 10.1.1.0 0.0.0.255

access-list 100 remark CCP_ACL Category=2

access-list 100 deny   ip 10.2.10.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 100 deny   ip 10.2.10.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 100 deny   ip 10.2.10.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 100 deny   ip 10.2.10.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 100 deny   ip 10.2.2.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 100 deny   ip 10.2.2.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 100 deny   ip 10.2.2.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 100 deny   ip 10.2.2.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 100 deny   ip 192.168.2.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 100 deny   ip 192.168.2.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 100 deny   ip 192.168.2.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 100 deny   ip 192.168.2.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 100 permit ip 192.168.2.0 0.0.0.255 any

access-list 2000 remark CCP_ACL Category=4

access-list 2000 permit ip 192.168.2.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 2000 permit ip 192.168.2.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 2000 permit ip 192.168.2.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 2000 permit ip 192.168.2.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 2000 permit ip 10.2.2.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 2000 permit ip 10.2.2.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 2000 permit ip 10.2.2.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 2000 permit ip 10.2.2.0 0.0.0.255 192.168.100.0 0.0.0.255

access-list 2000 permit ip 10.2.10.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 2000 permit ip 10.2.10.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 2000 permit ip 10.2.10.0 0.0.0.255 10.242.2.0 0.0.0.255

access-list 2000 permit ip 10.2.10.0 0.0.0.255 192.168.100.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

!

!

route-map SDM_RMAP_1 permit 1

match ip address 100

!

!

!

control-plane

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

!

voice-port 0/0/3

ring frequency 20

!

voice-port 0/1/0

trunk-group TELNOR_GROUP

supervisory disconnect dualtone mid-call

no battery-reversal

cptone MX

timeouts call-disconnect 1

timeouts wait-release 3

timing hookflash-out 50

connection plar 216

description TELNOR_0

caller-id enable

!

voice-port 0/1/1

trunk-group TELNOR_GROUP

supervisory disconnect dualtone mid-call

no battery-reversal

cptone MX

timeouts call-disconnect 1

timeouts wait-release 3

timing hookflash-out 50

connection plar 216

description TELNOR_1

caller-id enable

!

voice-port 0/1/2

cptone MX

timing hookflash-out 50

caller-id enable

!

voice-port 0/1/3

cptone MX

timing hookflash-out 50

caller-id enable

!

voice-port 0/4/0

auto-cut-through

signal immediate

input gain auto-control

description Music On Hold Port

!

ccm-manager fallback-mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.1.1.2

ccm-manager config

!

mgcp

mgcp call-agent 10.1.1.2 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp bind control source-interface Vlan100

mgcp bind media source-interface Vlan100

!

mgcp profile default

!

sccp local Vlan100

sccp

!

dial-peer voice 999010 pots

service mgcpapp

port 0/1/0

!

dial-peer voice 999011 pots

service mgcpapp

port 0/1/1

!

dial-peer voice 999000 pots

service mgcpapp

port 0/0/0

!

dial-peer voice 999001 pots

service mgcpapp

port 0/0/1

!

dial-peer voice 999002 pots

service mgcpapp

port 0/0/2

!

dial-peer voice 999003 pots

service mgcpapp

port 0/0/3

!

dial-peer voice 999012 pots

service mgcpapp

port 0/1/2

!

dial-peer voice 999013 pots

service mgcpapp

port 0/1/3

!

dial-peer voice 1 pots

trunkgroup TELNOR_GROUP

description International

translation-profile outgoing OutgoingProfile_1

destination-pattern 800T

forward-digits all

!

dial-peer voice 2 pots

trunkgroup TELNOR_GROUP

description National_Cell

translation-profile outgoing OutgoingProfile_1

destination-pattern 8045..........

forward-digits all

!

dial-peer voice 3 pots

trunkgroup TELNOR_GROUP

description National

translation-profile outgoing OutgoingProfile_1

destination-pattern 801..........

forward-digits all

!

dial-peer voice 4 pots

trunkgroup TELNOR_GROUP

description Local_Cell

translation-profile outgoing OutgoingProfile_1

destination-pattern 8044686.......

forward-digits all

!

dial-peer voice 5 pots

trunkgroup TELNOR_GROUP

description Local

translation-profile outgoing OutgoingProfile_1

destination-pattern 8.......

forward-digits all

!

!

!

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 10.2.2.1 port 2000

max-ephones 12

max-dn 8 dual-line

system message primary SRST

default-destination 216

date-format dd-mm-yy

!

!

line con 0

session-timeout 5

no modem enable

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

session-timeout 5

login local

transport input all

line vty 5

session-timeout 5

login

transport input all

!

ntp update-calendar

ntp server 192.168.0.254 prefer source Vlan1

end

islam.kamal Sun, 02/23/2014 - 13:00
User Badges:
  • Red, 2250 points or more

HI Mario


The above configuration is differnent from the 1st configuation which you posted firstly .


*ccm-manger mgcp    is missing above .


If you need to allow fallback , just type no mgcp on the config mode.


Can you check again your configuration and share the latest?.


show ccm-manager                               after fallback



Thanks

Please rate all your useful information

Mario Musquiz Sun, 02/23/2014 - 15:07
User Badges:

Hi sorry i was playing whit the configuration when i did the "show running"


now is working


First i had

ccm-manager shut-backhaul-interfaces

ccm-manager mgcp


Then change it to

ccm-manager fallback-mgcp

ccm-manager mgcp



Thanks.

Actions

This Discussion