×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Connecting "fast ethernet" to "ethernet" is not working!

Answered Question
Mar 5th, 2014
User Badges:

Hey there,


I connected "FE 0/1" (cisco 1841) to "Ethernet 1/0" ( NM-4E module in 2651 router). Both interfaces' status are up but their line protocol is down.


I sat both their speed to 10Mbps and their duplux to full but no luck.


Is this because i am using a straight-throught cable? According to my understanding all cisco routers uses "Auto-Mdix" feature which eleminates the need for cross-over cables.


Thanks,


Abdul,

Correct Answer by cadet alain about 3 years 5 months ago

Hi,

Auto mdix needs autonegotiation and not all devices or modules  support this feature.


Regards


Alain



Don't forget to rate helpful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Jon Marshall Wed, 03/05/2014 - 04:22
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Abdul


According to my understanding all cisco routers uses "Auto-Mdix" feature which eleminates the need for cross-over cables.

Most switches support that feature but not necessarily routers. If you were using a switch module in the router then it would probably support it but i'm not sure the onboard ports do.


Jon

Correct Answer
cadet alain Wed, 03/05/2014 - 04:23
User Badges:
  • Purple, 4500 points or more

Hi,

Auto mdix needs autonegotiation and not all devices or modules  support this feature.


Regards


Alain



Don't forget to rate helpful posts.

Umesh Shetty Wed, 03/05/2014 - 09:52
User Badges:

HI Alain,


Another good peice of information, I was not really aware of this. I was under the impression that auto mdix works and is independent of speed/duplex settings. There definitely must be a reason behind auto mdix needing auto nego ON. If you could put some light on that too please


Regards

Umesh

Abdullah Net Wed, 03/05/2014 - 21:12
User Badges:

Alain,


You are right. As it turns out, the "NM-4E" module is very very old and it lacks autonegotiation feature thus no auto-mdix.


I used cross-over cables and everything works fine now.


Abdul,

Dragan Ilic Wed, 03/05/2014 - 04:31
User Badges:
  • Silver, 250 points or more

Do you see something in log?


As I understand you have L2 issue - have you tried with static "half-duplex" on both sides?



HTH,
Dragan

Richard Burts Wed, 03/05/2014 - 05:36
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Alain reminds us that auto mdix needs autonegotiation and Abdul tells us that he is hard coding the speed and duplex. I think that the simple thing is to try a crossover cable and see if the connection works with that.


HTH


Rick

Actions

This Discussion