×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

OutBound Dialer Not working on ICM 7.5

Unanswered Question
Mar 9th, 2014
User Badges:

 

Hi Folks,

  Communication between Dialer and Campaign is not established, We found out that some of the files are missing on the Registry on the respective components.

 

Dialer

(i) PortThrottleCountentry on SOFTWARE\Cisco Systems, Inc.\Instance\Dialer

PG2 

(i) AutoCfgerrorfilemaxBytes on  SOFTWARE\Cisco Systems, Inc.\Instance\PG2A\PG\Current Version\PIMS\pim1\MRData\Dynamic
(ii) AutoCfgerrorFileName  on  SOFTWARE\Cisco Systems, Inc.\Instance\PG2A\PG\Current Version\PIMS\pim1\MRData\Dynamic

 

attached the screen shot of process of Dailer and PG PIM components from Progger.

 

As a part of investigation ,we have reinstalled the Dailer and PG PIM (Media Routing) , however still the commincation is not established between Dialer and Campaign.

Regards,

Ananda Kumar N

 

 

 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gergely Szabo Mon, 03/10/2014 - 00:35
User Badges:
  • Green, 3000 points or more
  • Community Spotlight Award,

    Member's Choice, December 2015

Hi,

can you please double check your configuration for both the Logger and the Dialer process (take a look at the Outbound Option Guide for your ICM version, for 7.5 it's probably page 76).

You might also turn up tracing (read the troubleshooting section in the OO guide), dump the logs for the dialer "baDialer" and the Logger A "CampaignManager" and post them to here.

G.

Ananda Kumar Mon, 03/10/2014 - 01:00
User Badges:

Hi Gergely,

 

Please have look at  dump log of "baDialer"

 
12:58:35 dialer-baDialer Trace: (DD) **** Media Routing PIM is not Connected **** 
12:58:35 dialer-baDialer Trace: (DD) **** Media Routing PIM is not Connected **** 
12:58:36 dialer-baDialer Trace: (DD) **** Media Routing PIM is not Connected **** 
12:58:36 dialer-baDialer Trace: (DD) **** Media Routing PIM is not Connected **** 
 
 
Logger A
"12:00:00 la-CampaignManager Trace: Data message [DialerHalfHour] sent to the router 
12:00:03 la-CampaignManager Trace: Data message [CampaignQueryRuleHalfHour] sent to the router 
12:00:03 la-CampaignManager Trace: Data message [CampaignQueryRuleHalfHour] sent to the router 
12:30:00 la-CampaignManager Trace: Data message [DialerHalfHour] sent to the router 
12:30:03 la-CampaignManager Trace: Data message [CampaignQueryRuleHalfHour] sent to the router 
12:30:03 la-CampaignManager Trace: Data message [CampaignQueryRuleHalfHour] sent to the router 
12:53:08 la-CampaignManager Trace: Executing SQL Command [UPDATE DL_5000_5000 SET CallStatusZone1 = 'P' WHERE CallStatusZone1 = 'U'] 
12:53:08 la-CampaignManager Trace: Executing SQL Command [UPDATE DL_5000_5000 SET CallStatusZone2 = 'P' WHERE CallStatusZone2 = 'U'] 
12:53:08 la-CampaignManager Trace: Executing SQL Command [UPDATE DL_5002_5002 SET CallStatusZone1 = 'P' WHERE CallStatusZone1 = 'U'] 
12:53:08 la-CampaignManager Trace: Executing SQL Command [UPDATE DL_5002_5002 SET CallStatusZone2 = 'P' WHERE CallStatusZone2 = 'U'] "

.

My suspection is that  Dialer is not connecting to MR PG .As mentioned in the previous post i am not able to locate these files on the respective components. 

-Anand N

 

Gergely Szabo Mon, 03/10/2014 - 01:28
User Badges:
  • Green, 3000 points or more
  • Community Spotlight Award,

    Member's Choice, December 2015

Hi,

did you turn up tracing? Set the TraceMask to at least FFFF, please, for both the CampaignManager and the Dialer.

Thanks.

Yes, the Dialer status bar says MR-X which indicates there's a problem connecting to the MR PIM. There's a number of reasons why this is happening, I suspect a configuration error.

G.

Actions

This Discussion