CUCM 8.0(2) upgrade subscriber to 9.1(2) fails - eth0: ipcalc: bad netmask: 255.255.255.000

Unanswered Question
Mar 31st, 2014
User Badges:

Hi,

Hope someone can shed some light and help us with an issue.

We're upgrading CUCM cluster from 8.0.2.40000-1 to 9.1.2.10000-28

Systems were on MCS hardware - migrated 8.0(2) successfully to VM infrastructure.

Appeared to successfully upgrade Publisher.

During upgrade to Sub (after Pub upgrade was completed and server restarted) - it fails with an error message 

"Refresh Upgrade Failed - Error detected in post-install phase. Trying to restore the system to the active version. Please wait..."

It then restarted.

I was watching the console output and noted that when it went to enable Eth0 it produced the following output:

<cite><q>&quot;Brining up interface eth0: ipcalc: bad netwmask: 255.255.255.000</q></cite>

<cite><q>ipcalc: bad netwmask: 255.255.255.000</q></cite>

<cite><q>ipcalc: bad netwmask: 255.255.255.000</q></cite>

<cite><q>Cannot get current device settings: Operation not supported.</q></cite>

<cite><q>&nbsp; not setting autoneg</q></cite>

<cite><q>Error: an inet prefix is expected rather than &quot;10.33.159.100/&quot;.</q></cite>

<cite><q>Error adding address 10.33.159.100 for eth0.</q></cite>

<cite><q>bind: Cannot assign requested address</q></cite>

<cite><q>RTNETLINK answers: No such device &nbsp;[ &nbsp;OK &nbsp;]&quot;</q></cite>

It then continued to boot up and went back into the original version. I ran a check of the inactive version and there's nothing there "No Inactive side available".

I tried to change the IP to change the subnet mask from 255.255.255.000 to 255.255.255.0 but after it changed and restarted, the output of "show network eth0" still shows subnet mask with the 3 x 0 (255.255.255.000).

I thought maybe it had just kept the same mask due to same IP being configured so I changed the address to something different (10.33.159.105 255.255.255.0).

After restart it also shows netmask of 255.255.255.000

I didn't encounter this issue on the Publisher - but our subnet mask on the Publisher is 255.255.255.128


I'm going to try again now that I've "changed" the IP and will update with outcome if favourable (won't bother if the result is the same).

 

Sub output that may help in your thoughts:

<samp><tt>VMware Installation:<br />&nbsp; &nbsp; &nbsp; &nbsp; 2 vCPU: &nbsp;Intel(R) Xeon(R) CPU E5-2680 0 @ 2.70GHz<br />&nbsp; &nbsp; &nbsp; &nbsp; Disk 1: 80GB<br />&nbsp; &nbsp; &nbsp; &nbsp; 4096 Mbytes RAM</tt></samp>

<samp><tt>admin:show version active<br />Active Master Version: 8.0.2.40000-1<br />Active Version Installed Software Options:<br />cmterm-7937-1-4-4-SCCP.cop<br />cmterm-7936-sccp.3-3-21.cop<br />cm-locale-combined_network-8.0.1.1000-2.cop<br />cmterm-7945_7965-sccp.9-3-1SR2-1.cop<br />ciscocm.refresh_upgrade_v1.3.cop<br />dp-ffr.3-1-9.AU.cop<br />localeinstaller<br />cmterm-7941_7961-sccp.9-3-1SR2-1.cop</tt></samp>

 

<samp><tt>admin:show version inactive</tt></samp>

<samp><tt>Executed command unsuccessfully<br />No Inactive side availabl</tt></samp>

Pub output of the same:

admin:show version active<br />Active Master Version: 9.1.2.10000-28<br />Active Version Installed Software Options:<br />cmterm-7941_7961-sccp.9-3-1SR2-1.cop<br />cmterm-7936-sccp.3-3-21.cop<br />cm-locale-combined_network-8.0.1.1000-2.cop<br />dp-ffr.3-1-9.AU.cop<br />ciscocm.refresh_upgrade_v1.3.cop<br />cmterm-7937-1-4-4-SCCP.cop<br />cmterm-7945_7965-sccp.9-3-1SR2-1.cop


admin:show version inactive<br />Inactive Master Version: 8.0.2.40000-1<br />Inactive Version Installed Software Options:<br />cmterm-7941_7961-sccp.9-3-1SR2-1.cop<br />cmterm-7936-sccp.3-3-21.cop<br />cm-locale-combined_network-8.0.1.1000-2.cop<br />dp-ffr.3-1-9.AU.cop<br />ciscocm.refresh_upgrade_v1.3.cop<br />cmterm-7937-1-4-4-SCCP.cop<br />cmterm-7945_7965-sccp.9-3-1SR2-1.cop
 

 

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brett Hanson Mon, 03/31/2014 - 23:29
User Badges:

Well, good news.

After changing the IP to 10.33.159.105 255.255.255.0, restarting the sub, changing the IP back to 10.33.159.100, restarting the sub again - the upgrade worked.

Bizarre.

PS. show network eth0 still shows a mask ending in .000 but I didn't encounter the same problems and everything is looking peachy.

admin:show network eth0<br />Ethernet 0<br />DHCP &nbsp; &nbsp; &nbsp; &nbsp; : disabled &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; Status &nbsp; &nbsp; : up<br />IP Address &nbsp; : 10.33.159.100 &nbsp; &nbsp; &nbsp;IP Mask &nbsp; &nbsp;: 255.255.255.000

Version looks good:

Command Line Interface is starting up, please wait ...

&nbsp; &nbsp;Welcome to the Platform Command Line Interface

VMware Installation:<br />&nbsp; &nbsp; &nbsp; &nbsp; 2 vCPU: Intel(R) Xeon(R) CPU E5-2680 0 @ 2.70GHz<br />&nbsp; &nbsp; &nbsp; &nbsp; Disk 1: 80GB, Partitions aligned<br />&nbsp; &nbsp; &nbsp; &nbsp; 4096 Mbytes RAM

admin:show version active<br />Active Master Version: 9.1.2.10000-28<br />Active Version Installed Software Options:<br />cmterm-7937-1-4-4-SCCP.cop<br />cmterm-7936-sccp.3-3-21.cop<br />cm-locale-combined_network-8.0.1.1000-2.cop<br />cmterm-7945_7965-sccp.9-3-1SR2-1.cop<br />ciscocm.refresh_upgrade_v1.3.cop<br />dp-ffr.3-1-9.AU.cop<br />cmterm-7941_7961-sccp.9-3-1SR2-1.cop

 

 

 

mohamed helmy Tue, 04/01/2014 - 01:19
User Badges:

 

Hello,

Good news that you solved the problem, however "000" is not a problem, it just shows each part in three digits :)

Regards,

Mohamed Helmy

Brett Hanson Tue, 04/01/2014 - 01:21
User Badges:

Thanks Mohamed.


Yeah - that's what I'd figured and couldn't understand why I got that ipcalc error.

Seems bizarre that changing the IP and changing it back resolved.

I had tried restarting the server and various bits and pieces that didn't make any difference.

 

Brett Hanson Wed, 04/02/2014 - 01:38
User Badges:

Of interest, I ran into this same issue while upgrading our UCCX cluster from 8.0(2) SU4 to 9.0(2) SU1.

Changed the IP, changed it back, upgrade to sub worked.

 

Actions

This Discussion