SPA232D & CID

Unanswered Question
Apr 5th, 2014
User Badges:

I'm using the SPA232D as an FXO port with asterisk. I can place and receive calls between asterisk and the FXO port of the SPA232D, but when receiving calls I don't receive callerID.

 

I'm in USA. Specifically, I have Comcast as voice provider. I'm not sure what settings to adjust or how to troubleshoot. If I plug an analog phone straight into the comcast equipment (bypassing the SPA232D), it receives callerID. With the SPA232D in place, when asterisk receives the inbound call the CallerID is empty.

 

I have the following settings in the SPA232D:

Voice -> Regional page, Miscellaneous section:

  • CallerID Method: Bellcore (N Amer, China)
  • CallerID FSK Standard: bell 202.  I also tried v.23, but this did not change behavior.

PSTN page, PSTN-To-VoIP Gateway Setup section:

  • PSTN CID For VoIP CID: yes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mattchase Sat, 04/05/2014 - 08:44
User Badges:

Trouble Resolved.

 

on the Voice -> PSTN page, PSTN Timer Values (sec):

  • Set PSTN Answer Delay to 5.

 

I had the PSTN answer delay set to 0 so the call would immediately pass through to VoIP. CallerID is not presented at the beginning of the call, but comes through shortly thereafter.

So to pass CID along through to asterisk, I had to not send the call to VoIP until the SPA232 first received callerID from the carrier. That meant putting a delay into answering the call.

Actions

This Discussion

Related Content