×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Remote Callers can't hear ringback on E1

Unanswered Question
Apr 8th, 2014
User Badges:

I'm running CMExpress on Cisco 2911 with one E1 card and callers can't hear ringback when the call is actually ringing in the local site. They just hear one ringback on the establish of call and after that, nothing until the end-user off-hook the phone.

Can someone have an idea about this issue?

Tahnks in advanced for your help.

This is the configuration:

controller E1 0/0/0
 framing NO-CRC4
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani
 cas-custom 0
  country telmex
  release-guard-time 2
  disconnect-tone
  category 2
  answer-signal group-b 1
  caller-digits 4
  dnis-digits min 4 max 4
  answer-guard-time 500
  groupa-callerid-end
  dtmf timer inter-digit 250
!
  voice-card 0
 dspfarm
 dsp services dspfarm
!
voice-port 0/0/0:0
 cptone MX
!

dial-peer voice 7 pots
 description ### INCOMING CALLS E1-PSTN ###
 translation-profile incoming To-AA
 incoming called-number .
 direct-inward-dial

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
acampbell Tue, 04/08/2014 - 16:24
User Badges:
  • Green, 3000 points or more

Hi Tavo,

Can you try adding a line to your VOIP dial peer:-

Something like:-

!
!
dial-peer voice 2000 voip
desc *** VOIP DP TO CUCM SUB ***
destination-pattern 2...
session target ipv4:172.16.255.22
codec g711ulaw
progress_ind setup enable 3
!
!

Hope this helps
Regards
Alex

Gustavo Adolfo ... Tue, 04/08/2014 - 16:35
User Badges:

Hi Alex, your comment make me update my case, i'm actually runnning CME with SCCP and SIP phones registered on it and when i called to any of this extensions, anyone made ringback tone.

Thanks for your help.

acampbell Tue, 04/08/2014 - 17:03
User Badges:
  • Green, 3000 points or more

Tavo,

 

What version of CME are you running and what is the router IOS version ?

You may be hitting bug CSCdw73507 if it is old ios 12.2 etc

Does the issue happen with both the sip & sccp phones ?

Alex

Gustavo Adolfo ... Wed, 04/09/2014 - 13:48
User Badges:

This my CME and IOS version:

=====================
Version 9.1
Max phoneload sccp version 17
Max dspfarm sccp version 18
Cisco Unified Communications Manager Express

======================

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(4)M4, RELEASE SOFTWARE (fc2)

=======================

The issue is similar to the bug CSCdw73507When a call come from PSTN, the Caller just hear one ringback, but my IP Phone rings normal.

This is my Incoming Dial-Peer

dial-peer voice 7 pots
 description ### INCOMING CALLS E1-PSTN ###
 translation-profile incoming To-AA
 incoming called-number .
 direct-inward-dial

 

 

Thanks in advance for your help.

 

Regards,

 

 

acampbell Fri, 04/11/2014 - 01:33
User Badges:
  • Green, 3000 points or more

Tavo,

Can you try adding this to your global config

!
voice call send-alert
voice rtp send-recv
!

Hope this helps.
Regards
Alex

Gustavo Adolfo ... Fri, 04/11/2014 - 08:16
User Badges:

Alex,

I already added these commands, but this issue continues, Do you think my E1 Provider has some work to do about it?

Thanks in advanced for your help.

Regards,

Tavo.

Gustavo Adolfo ... Fri, 04/11/2014 - 09:03
User Badges:

Caller who calls a DID don't hear ringback, but when a AA is playing and Caller Dial an Extension in that moment he can hear ringback.

Call -> DID -> CME -> AA (Unity) -> Dial Extension -> Ringback (YES)

Call -> DID -> CME -> Ringback (NO)

Aaziz AMHAOUCH Tue, 04/15/2014 - 05:17
User Badges:

 Hi Gustavo,

 

I have the same problem with the same Gateway (Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(4)M4) registered with CUCM 9.1

Did you resolve this issu ?

Thanks in advance

BR,

Aaziz

 

Gustavo Adolfo ... Tue, 04/15/2014 - 06:32
User Badges:

Hi Aaziz, i still have the issue.

 

Let me know if you have any kind of suggestion.

 

Thanks a lot

 

Regards,

Tavo

Ayodeji Okanlawon Tue, 04/15/2014 - 07:21
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Can you send us the ff: logs

debug isdn q931

debug ephone state

Aaziz AMHAOUCH Wed, 04/16/2014 - 13:27
User Badges:

Hi,

The problem is resolved using this two commands just in POTS Dial-peer :

 progress_ind setup enable 3
 progress_ind alert enable 8

Could you try those commands

BR,

Aaziz

Gustavo Adolfo ... Wed, 04/16/2014 - 13:50
User Badges:

Aaziz,

IOS mark as Invalid input when i tried to use these commnds on POTS Dial-peer, but in VOIP (NO MY CASE) I can use them.

 

Thanks for your help.

 

Regards.

Gustavo Adolfo ... Wed, 04/16/2014 - 13:52
User Badges:

Ayodeji,

IOS mark as invalid input *debug isdn q931*. I'm using Controller E1.

Thanks for your help.

BR

Tavo

Actions

This Discussion