×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

FastEthernet0: Fatal transmit error. Restarting...

Answered Question
Apr 14th, 2014
User Badges:

I am having this kind of issue on my Cisco876.

Has anybody experienced this before ? WAN is aDSL line and it has been lately

checked by provider like five times. The main problem is that internet itself falls dows from 5 to 10 times a day. 

Local cabling was tested with certified devices.

Here`s ADSL:

Capacity Used:   44%                             99%
Noise Margin:    14.0 dB                          7.5 dB
Output Power:    11.0 dBm                        12.5 dBm
Attenuation:     15.5 dB                          9.0 dB

 

Here`s log:

C876#sh log | i Fatal

000040: Apr 10 18:46:01: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...
000048: Apr 11 10:49:21: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...
000058: Apr 11 11:30:37: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...
000072: Apr 11 14:42:25: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...
000087: Apr 11 16:36:54: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...
000097: Apr 14 08:15:41: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...
000116: Apr 14 08:27:28: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...
000149: Apr 14 10:59:09: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...
000159: Apr 14 11:00:46: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...
000169: Apr 14 11:02:14: %C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...

 

What sould I try, please ? Can somebody help with this ?

Thanks in advance.

 

 

Correct Answer by Kimmo Suominen about 3 years 2 weeks ago

I'm having this issue with one of my 877 routers and was told by TAC that it is caused by a hardware bug, not fixable in software.

The CSCth20872 bug describes a fix that works around the hardware bug by using a watchdog to reset the interface (apparently the whole switch; the message says "FastEthernet0" regardless of port used). As such, this could be considered an "informational" log message.

Without the fix applied the interface(s) just hang, requiring a device reload to restore functionality.

Based on my experience, the interface hang + reset also results in lost packets, easily noticeable in video conferencing and even VoIP. However, at least in my environment this issue only surfaces on a router that has comparatively more packets going through it (servicing a public NTP server and a SIP PBX).

The suggested fix is replacing the router with a model from a different series (e.g. 887 or 897).

Correct Answer by joseper2 about 3 years 4 months ago

There is a bug as well.

 

%C870_FE-3-TXERR: error messages and reset of Fa interface on 877 router
Symptoms: The following error message is seen accompanied by a reset of the Fast Ethernet:

%C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...

Conditions: The symptom is observed on a Cisco 877 router that is running Cisco IOS Release 12.4(24)T3.

Workaround: There is no workaround.
 
 
 
Check your IOS or feel free to involved Cisco TAC, hope that helps.
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Leo Laohoo Mon, 04/14/2014 - 15:10
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Noise Margin:    14.0 dB                          7.5 dB

Your service provider is not doing a good job.  This means that the upstream line needs to be investigated.  

martinkroslak Mon, 04/14/2014 - 19:39
User Badges:

I will tell them to lower dsl profile on upstream. Thank you Leo for help. Have a nice day.

Correct Answer
joseper2 Mon, 04/14/2014 - 16:24
User Badges:

There is a bug as well.

 

%C870_FE-3-TXERR: error messages and reset of Fa interface on 877 router
Symptoms: The following error message is seen accompanied by a reset of the Fast Ethernet:

%C870_FE-3-TXERR: FastEthernet0: Fatal transmit error. Restarting...

Conditions: The symptom is observed on a Cisco 877 router that is running Cisco IOS Release 12.4(24)T3.

Workaround: There is no workaround.
 
 
 
Check your IOS or feel free to involved Cisco TAC, hope that helps.
martinkroslak Mon, 04/14/2014 - 19:40
User Badges:

I guess this is it. Thank you very much ! :) I ll try to change the IOS

Correct Answer
Kimmo Suominen Tue, 07/29/2014 - 08:15
User Badges:

I'm having this issue with one of my 877 routers and was told by TAC that it is caused by a hardware bug, not fixable in software.

The CSCth20872 bug describes a fix that works around the hardware bug by using a watchdog to reset the interface (apparently the whole switch; the message says "FastEthernet0" regardless of port used). As such, this could be considered an "informational" log message.

Without the fix applied the interface(s) just hang, requiring a device reload to restore functionality.

Based on my experience, the interface hang + reset also results in lost packets, easily noticeable in video conferencing and even VoIP. However, at least in my environment this issue only surfaces on a router that has comparatively more packets going through it (servicing a public NTP server and a SIP PBX).

The suggested fix is replacing the router with a model from a different series (e.g. 887 or 897).

Actions

This Discussion