×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Howto set timezone on UCS C220 M3 by CLI

Answered Question
Apr 18th, 2014
User Badges:

Hello, I have configured NTP in the GUI but due to a wrong timezone time isn't OK

I cannot edit the timezone in the GUI so I looked for CLI commands.

http://www.cisco.com/c/en/us/td/docs/unified_computing/ucs/sw/cli/config/guide/1-3-1/b_CLI_Config_Guide_1_3_1/CLI_Config_Guide_1_3_1_chapter33.html#task_A14B792FD20A458E8990E93368F5B222

According to this article it should be possible to use scope system but this command isn't available in my CLI:

BKS-C220-FCH1743V1FY#
  commit   Batch commit changes
  connect  Connect to other console
  discard  Discard all changes
  exit     Exit from command interpreter
  scope    Changes the current mode
  set      Set property values
  show     Show system information
  top      Go to the top mode

BKS-C220-FCH1743V1FY#
BKS-C220-FCH1743V1FY# scope
  bios          System BIOS: Basic Input/Output System
  certificate   Security Certificates for SSH & SSL
  chassis       Server Inventory Items
  cimc          Cisco Integrated Management Controller
  fault         Configure alerts on platform events/fault
  http          Hyper Text Transfer Protocol
  ipmi          Intelligent Platform Management Interface
  kvm           Keyboard Video Mouse console to host
  ldap          Lightweight Directory Access Protocol
  sel           System Event Log
  sensor        Sensors
  snmp          Simple Network Management Protocol
  sol           Serial Over Lan (character mode console to Host)
  ssh           Secure Shell Configuration
  user          Local users of this CIMC
  user-session  Active user sessions on this CIMC
  vmedia        Virtual Media (mount local media onto Host)
  xmlapi        XML API Configuration

BKS-C220-FCH1743V1FY# scope
% Incomplete command
BKS-C220-FCH1743V1FY#

 

How should I change the timezone???

Correct Answer by Keny Perez about 3 years 4 months ago

Hello,

 

Unfortunately you were checking a pretty old guide for UCSM 1.3 (we have gone through UCSM 1.4/2.0/2.1 and currently on 2.2 already) and this server you are trying to configure seems to be in standalone mode...

 

For a standalone C series server, the only 2 ways to manage their time is either in BIOS or through NTP configuration (starting on CIMC 1.5) but not their timezone.  See the screenshots attached.

If you integrate the server with UCSM then you can set up the time zone.

 

-Rate ALL helpful answers

-Kenny

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Keny Perez Fri, 04/18/2014 - 08:08
User Badges:
  • Blue, 1500 points or more

Hello,

 

Unfortunately you were checking a pretty old guide for UCSM 1.3 (we have gone through UCSM 1.4/2.0/2.1 and currently on 2.2 already) and this server you are trying to configure seems to be in standalone mode...

 

For a standalone C series server, the only 2 ways to manage their time is either in BIOS or through NTP configuration (starting on CIMC 1.5) but not their timezone.  See the screenshots attached.

If you integrate the server with UCSM then you can set up the time zone.

 

-Rate ALL helpful answers

-Kenny

 

pdezeeuw-01 Tue, 04/22/2014 - 02:55
User Badges:

Hello, thank you for the answer.

I'ts a standalone UCS indeed, this is our first UCS.

I changed time and ntp server in CIMC as you describe but for changing the timezone I need to setup a Cisco USCS Manager?!?

 

Regards

Peter

Keny Perez Tue, 04/22/2014 - 07:34
User Badges:
  • Blue, 1500 points or more

Peter,

 

It is not that you need to set up UCSM, it is more that time zone is only included in UCSM, so if you want to use it for a C series, it can only be done if you have the server integrated; otherwise you only have the option to do it as explained before.

Please rate ALL helpful answers and if answered your question, somehow, please mark it as such so future users see you found the solution to your query.

 

Let me know if you have any other doubt.

-Kenny

pdezeeuw-01 Wed, 04/23/2014 - 07:11
User Badges:

OK, I've set the correct time in System Setup

Once the system is booted the time goes back 2 hours again...

NTP is disabled!

 

Any ideas left?

 

Peter

Keny Perez Wed, 04/23/2014 - 07:21
User Badges:
  • Blue, 1500 points or more

Peter,

 

All I could think of is that the CMOS battery is not providing power to keep that setting.  Do you know if any other setting that you configure in BIOS is lost after a reboot?  that would confirm my theory...

 

Rate ALL helpful answers

-Kenny

Actions

This Discussion