VMS-1-CONN_SSL_NOAUTH error in Nexus 1000v

Unanswered Question
Apr 21st, 2014
User Badges:

Any one knows how to fix the error "%VMS-1-CONN_SSL_NOAUTH: SSL AUTHENTICATION failure." in Nexus 1000v. Starting seeing this error after upgrading the VSM version to 4.2(1)SV2(2.1a).

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph LeBlanc Mon, 04/21/2014 - 09:05
User Badges:
  • Cisco Employee,

Hi,

In SV2(2.1) we started doing VSM to vCenter server certificate validation.

You can find more info about this change in the SV2(2.1) Release Notes.

"If the certificate authentication fails, a warning is generated but the connection is not impaired. This is an optional feature."

HTH,

Joe

emc100155 Mon, 04/21/2014 - 22:08
User Badges:

Thanks Joe.

Is there any way to turn of this warning as we are not using any certificate in the vCenter?

Regards

RK

 

Joseph LeBlanc Tue, 04/22/2014 - 05:13
User Badges:
  • Cisco Employee,

Hi RK,

There is no way to suppress the messages at this time. If that changes, I will update the thread.

Thanks,

Joe

stanleyb Mon, 06/01/2015 - 16:08
User Badges:

RK,

Yes there is by using "logging level security 0". Here you go:

2015 Jun  1 22:06:41 N1Kv01 %VMS-1-CONN_SSL_NOAUTH: SSL AUTHENTICATION failure.
2015 Jun  1 22:09:41 N1Kv01 %VMS-1-CONN_SSL_NOAUTH1: SSL AUTHENTICATION failure.
2015 Jun  1 22:12:41 N1Kv01 %VMS-1-CONN_SSL_NOAUTH: SSL AUTHENTICATION failure.

N1Kv01#con
Enter configuration commands, one per line.  End with CNTL/Z
N1Kv01(config)# logging level security ?
  <0-7>  0-emerg;1-alert;2-crit;3-err;4-warn;5-notif;6-inform;7-debug

N1Kv01(config)# logging level security 0
N1Kv01(config)#
N1Kv01(config)#  sh clo
Mon Jun  1 22:20:19 UTC 2015
N1Kv01(config)# copy run startup-config
[########################################] 100%
2015 Jun  1 22:20:52 N1Kv01 %SYSMGR-STANDBY-5-CFGWRITE_STARTED: Configuration copy started (PID 4819).

N1Kv01(config)#  sh clo
Mon Jun  1 22:25:29 UTC 2015


-Stanley B

Joseph LeBlanc Wed, 06/03/2015 - 05:31
User Badges:
  • Cisco Employee,

Hi RK and Stanley,

 

This has been fixed in SV3(1.1). The defect ID is CSCuo39379.

 

The fix does two things:

1. Change the output of the message to be more detailed

2014 Jun 21 23:46:32 labVSM vms[3345]: %VMS-1-CONN_SSL_NOAUTH1: SSL AUTHENTICATION failure. [This message can be safely ignored if vCenter Certificate is not in use.]

2. Provide the option to enable/disable these messages

Cisco Nexus 1000V for VMware vSphere System Management Configuration Guide

 

Have a good day,

Joe

Actions

This Discussion