×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Vlan Trunk Between Dell PowerConnect 5324 and Cisco Cisco 2811 (Intervlan-routing)

Unanswered Question
Apr 25th, 2014
User Badges:

Hi Everybody:

 

Im conecting a phisical trunk, between  switch Dell PowerConnect 5324 and Cisco 2811 Router, please see the attachment topology, I can't not ping between the PC A and PC B, I will show the configs:

The config in the router CISCO:

!
interface FastEthernet0/0 
 description Cisco to Trunk DELL
 no ip address
 duplex auto
 speed auto
!
!
interface FastEthernet0/0.2
 description VLAN 2
 encapsulation dot1Q 2 native
 ip address 200.71.155.193 255.255.255.248
!
interface FastEthernet0/0.3
 description VLAN 3
 encapsulation dot1Q 3
 ip address 201.249.204.153 255.255.255.248
!

 

Config DELL POWERCONNECT:

Configuring VLAN Trunk in Ethernet G23 :

interface ethernet g23
switchport mode trunk
switchport trunk allowed vlan add 2,3
exit

 

ADDING VLAN 2 AND 3:

enable
configure
vlan database
vlan 2
vlan 3
exit

 

Configuring Ports  E2 , E3 in VLANS 2, 3 respectivily:

interface ethernet e2
switchport mode access
switchport access vlan 2
exit

interface ethernet e3
switchport mode access
switchport access vlan 3
exit


copy running-config startup-config

 

Could you tell me what is missing on my config? Thanks in advance.

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Fri, 04/25/2014 - 06:31
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I'm not familiar with that make of switch but have you made vlan 2 the native ie. untagged vlan on the switch ?

If not then it may be easier on the 2811 to simply change -

int fa0/0.2

encapsulation dot1q 2 native

to

int fa0/0.2

encapsulation dot1q 2

ie. remove the native keyword and retry.

Jon

sistemastel Fri, 04/25/2014 - 06:53
User Badges:

Thanks you, I am going to do that, it is true, because I dont configure native VLAN on DELL switch, may be this is the problems cause.  

Actions

This Discussion