×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

NO Internet access on LAN - Cisco 1941 Router

Unanswered Question
May 1st, 2014
User Badges:

I have a router in my company premises and i am getting problems to access internet on LAN. My router configuration is as follows:

router#show run
Building configuration...

Current configuration : 1249 bytes
!
! Last configuration change at 08:05:40 UTC Thu May 1 2014
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 cMKf9AseOngX7qzV669VAP6mTP7Zx2CAoLvvkpbCO1E
!
no aaa new-model
memory-size iomem 25
!
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1941/K9 sn FGL1801222R
!
!
username admin privilege 15 secret 4 c5LFTnp3A5C3Ds2sCA3PU0Csl6Q1V1MpHyKNktEi5tI
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 192.168.100.8 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
!
ip route 10.10.10.0 255.255.255.0 GigabitEthernet0/0
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
!
end

 

Please help ..... and suggest to change the configuration and please send the detailed steps to do. 

 

Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
hdussa Thu, 05/01/2014 - 01:41
User Badges:

Hi,

why do route ip route 10.10.10.0 255.255.255.0 to GigabitEthernet0/0 ?

usually a default route points to the internet.

ip route 0.0.0.0 0.0.0.0 <ip next hop>

 

Horst

D.Ghanekar Thu, 05/01/2014 - 06:43
User Badges:

hi,, 

thanks for reply...

I am a beginner in router configurations..... so please help me with the <ip next hope>..

 

I am trying to connect this router for testing in my office network.... My Office network is in 192.168.100.10-200 range and i given 192.168.100.8 to routers wan interface an i am trying the 192.168.100.7 as ip next hop...

Will this work ...

 

I can share you remote for the console of router...

hdussa Thu, 05/01/2014 - 06:57
User Badges:

next hop = ip address of the internet router.

D.Ghanekar Fri, 05/02/2014 - 06:09
User Badges:

hi, 

i change the configurations as follows...

nterface GigabitEthernet0/0
 ip address 192.168.100.8 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.10.10.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
!
ip nat inside source list 10 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 192.168.100.1
ip route 10.10.10.0 255.255.255.0 GigabitEthernet0/0
!
access-list 10 permit 192.168.100.0 0.0.0.255

 

with this i can ping the 4.2.2.2 and 8.8.8.8 and google.com IP 74.125.200.113 but on LAN interface i am unable to access the internet. 

Please help.

Jon Marshall Fri, 05/02/2014 - 06:17
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

The configuration is confusing.

You have a default route pointing to a 192.168.100.x IP and you say you can ping internet IPs from the router.

But then you have "ip nat inside" on the 192.168.100.x interface.

So -

1) what are your LAN IPs

2) what is the subnet used to connect to the internet ?

Jon

D.Ghanekar Fri, 05/02/2014 - 23:35
User Badges:

Hi Jon..

Actually this device id of our customers and he has a lease line ... but he reported that they found this hardware faulty and thus we are testing it by configuring in our office premises. 

In our office we have network in range 192.168.100.0/24 and thus we give the ip 192.168.100.8 to routers wan port. On routers LAN port we give the ip 10.10.10.1/24. 

This is the scenario..... 

 

Thanks

 

Actions

This Discussion