×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco 7821 handset DTMF tones dont work i.e IVR "press1 for x"

Answered Question
May 6th, 2014
User Badges:

 

Hello All,

 

I have a few Cisco 7821 handsets that will not allow DTMF tones to pass to things like on-line banking. i.e "press 1 for x, press 2 for y", when i press "1" i hear the tone but the other end does nothing.

It works with most other phone types as we have the option to disable rfc2833 but this function is not available in the menu for 7821's

Hope you can help and thanks in advance.

 

Martin.

Correct Answer by apanesar about 3 years 3 months ago

Hello Martin, This could be a bug as I have experienced something simillar with other phones. A good way to test is entering your PIN against your unity connectio voicemail server. If it does not work then open a TAC case.

Thank you.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Manish Gogna Tue, 05/06/2014 - 07:19
User Badges:
  • Cisco Employee,

Hi Martin,

We need to isolate if the DTMF digits are being sent to the gateway or not. For h323 use 'debug h245 asn1' , for SIP use 'debug voip rtp session named-event' to check if the dtmf digits are being sent to the gateway or not. If you see them on the gateway then the gateway dtmf config ( dial-peer ) or the settings on the party where IVR application is hosted needs to be checked. Else, the troubleshooting will need to focus on IP phone and callmanager ( using capture from phone and traces from cucm ).

HTH

Manish

martindickinson Tue, 05/06/2014 - 07:33
User Badges:

Hi Manish,

Many thanks for your quick response. We will give the debug a go and hopefully get some good info as to where the problem is. (We are using SIP so that is great)

Many thanks again :)

Martin.

martindickinson Tue, 05/06/2014 - 08:25
User Badges:

I have run the debug on the Gateway and placed a call from my desk phone  (Cisco 7960), once with the option RFC2833 Enabled and Once with RFC2833 Disabled, each time I pressed the number 1 key once and hung up.  See attached for the debugs

The DTMF Tones work with the RFC2833 option disabled.

I have attached the output from each.

The 7960 works fine because i can tick disable RFC2833 but there does not seem to be a box to tick for the Cisco 7821's.

Many thanks, Martin

 

Manish Gogna Tue, 05/06/2014 - 11:04
User Badges:
  • Cisco Employee,

If it is an issue with the called party not being able to handle RFC2833 then you can change the dtmf method on SIP trunk to something other than RFC2833 and check if it helps.

Manish

 

martindickinson Wed, 05/07/2014 - 06:44
User Badges:

Hi Manish,

 

At the moment we have disabled RFC2833 on the phones under "Protocol Specific information" - we ticked the box that says "RFC2833 Disabled"

On the 7960 this works great and we can dial a company i.e Barclay's bank and use DTMF. Unfortunately the 7821 does not have this tick box.

Many thanks,

Martin.

Correct Answer
apanesar Wed, 05/14/2014 - 08:11
User Badges:

Hello Martin, This could be a bug as I have experienced something simillar with other phones. A good way to test is entering your PIN against your unity connectio voicemail server. If it does not work then open a TAC case.

Thank you.

martindickinson Mon, 06/02/2014 - 08:04
User Badges:

Hello All --- FIXED..

The fix was to un-tick MTP on the SIP trunk as this was ticked. This fixed the problem on the 7821 handset. We then un-ticked the 'RFC2833 Disabled' on the 7960 handsets. Now all handsets are working fine.

Many thanks for everyones help on this.

Kind Regards,

Martin.

Rakesh K Wed, 05/07/2014 - 04:18
User Badges:

Hi Martin,

Could  please let me know how  you disabled the RFC2833 option.

Thanks in Advance 

V.Naveen Kumar Thu, 05/15/2014 - 17:39
User Badges:

In 7821 phone page,  enable mtp required option in it.

try doing test call

martindickinson Mon, 06/02/2014 - 08:03
User Badges:

Hello All,

The fix was to un-tick MTP on the SIP trunk as this was ticked. This fixed the problem on the 7821 handset. We then un-ticked the 'RFC2833 Disabled' on the 7960 handsets. Now all handsets are working fine.

Many thanks for everyones help on this.

Kind Regards,

Martin.

Actions

This Discussion