×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

External Phone Number Mask - number sent, number displayed on phone CUCM 9.1.2.11900-12

Unanswered Question
May 16th, 2014
User Badges:

I have a problem with additional 0's being prefixed to all the numbers my users dial.

I'm in the United Kingdom.  We have Presentation Number 5 and are allowed to send any of our non-geographic numbers or DDI's.  I have configured this by setting the External Phone Number Mask on user lines.  Several days ago our customers began to complain that they were receiving calls from us with an extra 0 at the front.  People were not answering the phone as they didn't recognise the number or mistakenly thought it was coming from overseas.  I looked at a debug and we were sending out the full number as per usual

 May 16 11:43:19.655 GMT: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x007E
        Sending Complete
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech 
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839E
                Exclusive, Channel 30
        Calling Party Number i = 0x2181, '0207092XXXX'
                Plan:ISDN, Type:National
        Called Party Number i = 0x80, '0207426XXXX'
                Plan:Unknown, Type:Unknown

When this call arrives at the other end it shows as 00207092XXXX.

Our telco BT insist they have changed nothing and that the fault is at our end.  As a temporary fix I've removed the leading 0 from the number in the External Phone Number Mask for the user so that it reads as 207092XXXX.  Then, when this extra 0 appears at the front, the number at least appears normal to the person receiving the calls.  The annoyance with this is that the phone display then shows the users number in this format as well.  Understandably my users just want things to be the same as they were before.

BT have insisted that we can only send 10 digits if we want it to work.  It has always previously worked sending the whole 11 by using the External Phone Number Mask.  If I cannot get the telco to look at this further, is there a way of having the number display normally on the handsets (with the leading 0) but then send the number out without it?  This is the initial reply from them.

“The ISDN30 service tests OK with no failures in the exchange and NO historic alarms. Presentation number facility is completely controlled by customers cpe programming:

CPE SETTINGS

1)            CUSTOMER needs to send FULL National Number MINUS the leading zero (10 digits)

2)            CLI CALLING PLAN must be set to either ISDN or UNKNOWN

3)            CLI CALLING TYPE must be set to NATIONAL number ONLY

4)            At the receiving end the Called Party must have Screening Indicator set to NOT Screen”

Thanks for any assistance.  I do not specialise in VOIP so there may be some simple setting that I have overlooked (firewall & routing is more my area).  This was working previously for many weeks.  My users have also noted that incoming call CLI is now displaying with the leading 0 missing!  No changes have been made on our system to the gateway or the route patterns and it is calls to all landline/mobile numbers (BT, Vodafone, O2, EE etc).

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Hermanus Janse ... Fri, 05/16/2014 - 06:39
User Badges:
  • Silver, 250 points or more

is your gateway H323 or MGCP?

 

If H323 can we see translation patterns and do you have any translation profiles on the voice-ports maybe?

 

 

Alexandra Willsher Fri, 05/16/2014 - 06:51
User Badges:

I assume there are a number of different ones.  Test calls so far have been to a variety of clients, to my home landline, 5 different mobile providers.  It's every single person we call so this points to the extra 0 going out from my end.

dana.tong Sun, 05/18/2014 - 23:01
User Badges:

Assuming that these are two sites on the SAME CUCM cluster with MGCP gateways and off-net calling.

 

What are the Incoming Calling Party Settings on the receiving site's MGCP gateway? Are you prefixing a 0 on incoming calling party numbers? If you are saying that the calling party number in the debug above is correct, then what are you seeing on the debug on the receiving gateway?

Brian Meade Fri, 05/16/2014 - 08:23
User Badges:
  • Silver, 250 points or more

Assuming they want you to send the number as National, there's not much you can do here in regards to what external users see.

 

If incoming calls to the Cisco system are seeing the leading 0, you can definitely strip that out using calling party transformations.

 

You could try sending the calling number as Unknown/Unknown instead of ISDN/National.  That might make it so the carrier doesn't prefix anything on the number.  Depending on your configuration, you can do that setting on the route pattern, the route list, or via outbound calling party transformations applied to the PRI in CUCM.

Alexandra Willsher Fri, 05/16/2014 - 08:30
User Badges:

Unfortunately, if I change to unknown/unknown the Presentation Number 5 no longer works and all calls are sent as the billing number of the circuit.

The incoming calls are not getting the leading zero.  I can see on the debug that all calls are turning up without it.  We definitely want the leading zero so people can just return calls.

Nathan Compton Fri, 05/16/2014 - 22:08
User Badges:
  • Silver, 250 points or more
If you REALLY want to show the 11 digit phone number at the top of the phone and send 10 digits to the carrier, you can program the 11 digit number as the epnm and program the calling party transform mask as XXXXXXXXXX (10 Xs) at the route pattern or route list level. This will strip the leading zero off of the calling number. From my experience, some carriers want the leading zero, and some don't. As to why it is different now, I think you are getting the typical "nothing has changed" answer from the carrier.
Alexandra Willsher Mon, 05/19/2014 - 04:17
User Badges:

adcompto - You are certainly right about the carrier!  Alas people want to be able to see their individual DDI and send it so using the routelist to send an epnm won't work as they will all differ.  This would be good for the group of people that I want to put behind a non-geo so I'll bear that in mind.

dana - I do not have any access to the receiving end gateways.  It's any potential call made by my site to any other number in the country, so it's definitely a problem being caused at my end by my provider.

Brian - incoming calls are arriving without the leading 0! I can see them turn up without one on my gateway debug.  I guess I can put a rule on that adds a zero before it comes in to my users - then they can just hit a button to return any calls they miss.

This is so frustrating, to have everything working and then the carrier refuse pointblank that anything has changed on their side.  I can show that no one has accessed or altered my system but all I'm getting back is a disinterested "you need to change the programming of your CPE".  Thanks for everyone's ideas/help so far.

Alexandra Willsher Thu, 05/22/2014 - 04:56
User Badges:

Hi

I had a chance to do this today and it is indeed stripping out that lead 0 at source - so thank you.  What is odd however is that with this in place, the debug no longer shows any details of the calling number at all (see below) is this expected?

 

May 22 11:51:43.818: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0068
        Sending Complete
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech 
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839F
                Exclusive, Channel 31
        Called Party Number i = 0x80, '07793XXXXXX'
                Plan:Unknown, Type:Unknown

Alexandra Willsher Thu, 05/22/2014 - 05:06
User Badges:

For the sake of anyone else having a smilar issue and finding this thread - more fiddling about found an option that restored the Calling Party Number details - I set Use Calling Party's EPNM to ON instead of default.  Now I get

PTBO-WUBS-BB-3925-01#deb isdn
May 22 11:57:24.284: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x006B
        Sending Complete
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech 
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839F
                Exclusive, Channel 31
        Calling Party Number i = 0x2181, '173387XXXX'
                Plan:ISDN, Type:National
        Called Party Number i = 0x80, '07793XXXXXX'
                Plan:Unknown, Type:Unknown

At least now I can fix our presentation at source, even if we do not know why the extra 0 is being added.  Our Service Provider gave us a code to route the traffic over a different network to BT and we still get the extra 0.  It seems that my CUCM is doing something the networks don't like.  So many options to choose from!

 

Actions

This Discussion

Related Content