×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Firmware upgrade failure on CIVS 6020 and 6030

Unanswered Question
May 16th, 2014
User Badges:

Hi,

We've been trying to upgrade the camera firmware:

- from 1.2.1-73 to 1.4.1-97, for CIVS 6020 cameras

- from 1.1.4-48 to 1.4.1-97, for CIVS 6030 cameras.

Each time we get the following error (please see screenshot). We are using the Cisco firmware file "CIVS-IPC-6xxx-V1.4.1-97.bin". The file is clean (checked with MD5).

Any idea?

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jonathan Young Fri, 05/16/2014 - 07:28
User Badges:

Wass,

Are you able to update the camera manually through the camera's management web page? If not, do you receive the same error message or a different one?

Wassim Aouadi Fri, 05/16/2014 - 09:04
User Badges:

Jonathan,

I tried that too. It showed "there was a problem with the request". The camera local log was not helpful.

Jonathan Young Fri, 05/16/2014 - 09:23
User Badges:

It may be a long shot, but in the past when we've had firmware issues on the camera, we had to reset the camera name to it's default and then the upgrade would work. The only difference is it would usually complain about a "bad magic number". I don't know if this would work for you in this case, or if you are experiencing a different issue. I believe the default name for yours would be IPC-CIVS-6020 and IPC-CIVS-6030, but you may want to confirm this on an unconfigured camera if you have one. Or maybe its CIVS-IPC-6020/CIVS-IPC-6030. I remember it was some variation of the camera model.

Jonathan Young Fri, 05/16/2014 - 09:19
User Badges:

On a side note, it's been a while since we've upgraded any 6020s. We do have some deployed in the field. But I looked back at our maintenance logs and we upgraded a number of 6020s from 1.2.1-73 to 1.4.1-97. The lowest supported firmware was 1.2.1-73 and the upgrade worked great. All our issues occurred when we were upgrading from a firmware level that was below the lowest supported firmware. We had one 6020 that was on the 1.1.4-48 for which we had to set it back to the original camera name, but I believe we got a "bad magic number" for this. I failed to document the error, so my memory may not be too good. This was all done on VSM 7.2.1.

So, I would expect your 6020s to work since they are on a supported firmware. I don't have any 6030s but I would expect them to be similar to the 6020s since they are in the same family and use the same firmware package.

Also, try different browsers. I seem to have the best success using IE10.

Actions

This Discussion