Setup VPN on 1921

Unanswered Question
May 19th, 2014
User Badges:

I have tried a few things, but connecting to my 1921 at home from a public location via VPN with a Windows 8 laptop does not work. I am traveling in a few days so this has become a priority for me to resolve. Below is the current config. Thank you in advance for your help.

 

Current configuration : 6205 bytes
!
! Last configuration change at 15:37:01 PCTime Sat Mar 1 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco1921
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxx
enable password xxxxxxxxxxxxxxxxxxxxxxxxxxx
!
aaa new-model
!
!
aaa authentication ppp default local
aaa authorization network default if-authenticated
!
!
!
!
!
aaa session-id common
clock timezone PCTime -8 0
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
!
no ipv6 cef
ip source-route
ip cef
!
!
!
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.99 192.168.1.254
!
ip dhcp pool iptpool
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 8.8.8.8 8.8.4.4
!
!
ip domain name xxxxxxxxxxxxxxx.com
ip name-server 8.8.8.8
ip name-server 8.8.4.4
multilink bundle-name authenticated
!
vpdn enable
vpdn tunnel authorization password xxxxxxxxxxxxxxx
!
vpdn-group 1
 ! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 1
 local name my-vpn
 l2tp tunnel timeout no-session 15
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-431180123
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-431180123
 revocation-check none
 rsakeypair TP-self-signed-431180123
!
!
crypto pki certificate chain TP-self-signed-431180123
 certificate self-signed 01
  xxxxxxxxxxxxxxxxxxxxxxxxxx
  xxxxxxxxxxxxxxxxxxxxxxxxxx
  xxxxxxxxxxxxxxxxxxxxxxxxxx
        quit
license udi pid CISCO1921/K9 sn xxxxxxxxxxxxxxxxx
!
!
username xxxxxxxxxxxxxxxx privilege 15 secret 4 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description LAN
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 no mop enabled
!
interface GigabitEthernet0/1
 description WAN
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 no mop enabled
!
interface Virtual-Template1
 ip unnumbered GigabitEthernet0/0
 peer default ip address pool VPN-IN
 no keepalive
 ppp authentication ms-chap
!
ip local pool VPN-IN 192.168.1.90
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication aaa
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list FOR_NAT interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 192.168.100.1
!
ip access-list standard FOR_NAT
 permit 192.168.1.0 0.0.0.255
ip access-list standard USC
 permit 0.0.0.0
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
snmp-server community public RO
!
!
!
control-plane
!
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for  one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN
CREDENTIALS

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want
to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 access-class 23 in
 privilege level 15
 password xxxxxxxxxxxxxxxxxxxxxx
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 password xxxxxxxxxxxxxxxxxxxxxx
 transport input telnet ssh
!
scheduler allocate 20000 1000
end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion