×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Dear fellows, Kindly I am facing issue when ruing a 3G SIM card in a Cisco "C819HG-4G-G-K9" the profile is flapping between “

Unanswered Question
May 20th, 2014
User Badges:

Dear fellows,
 

Kindly I am facing issue when ruing a 3G SIM card from Etisalat UAE in a Cisco "C819HG-4G-G-K9" the profile is flapping between “ACTIVE” and “INACTIVE” also I am getting below error messages:
 

 

Running Config:

=============
 

chat-script hspaq "" "AT!SCACT=1,1" TIMEOUT 60
 

 

interface Cellular0

 ip address 192.168.100.216 255.255.240.0

 ip access-group SITE-TO-SITE in

 ip virtual-reassembly in

 encapsulation slip

 dialer in-band

 dialer string hspaq

 dialer-group 1

 async mode interactive


 

line 3

 exec-timeout 0 0

 script dialer hspaq >>>> But when I issue the script dialer direct-ip command here the profile stay active but interface ip address                                             will be spoofing and not ping able.

login

 modem InOut

 no exec

 transport input all

 transport output all

 rxspeed 100000000

 txspeed 50000000

mss-test-ra#


 

Error Message:

===================
 

*May 20 11:31:18.067: CHAT3: Attempting async line dialer script

*May 20 11:31:18.067: CHAT3: Dialing using Modem script: hspaq & System script: none

*May 20 11:31:18.071: CHAT3: process started

*May 20 11:31:18.071: CHAT3: Asserting DTR

*May 20 11:31:18.071: CHAT3: Chat script hspaq started

*May 20 11:31:18.071: CHAT3: Sending string: AT!SCACT=1,1

*May 20 11:31:18.071: CHAT3: Chat script hspaq finished, status = Success

*May 20 11:31:20.071: %LINK-3-UPDOWN: Interface Cellular0, changed state to up

*May 20 11:31:21.071: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to up

*May 20 11:33:22.071: %LINK-5-CHANGED: Interface Cellular0, changed state to reset

*May 20 11:33:23.071: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to down

*May 20 11:33:27.071: %LINK-3-UPDOWN: Interface Cellular0, changed state to down

*May 20 11:33:38.071: CHAT3: Attempting async line dialer script

*May 20 11:33:38.071: CHAT3: Dialing using Modem script: hspaq & System script: none

*May 20 11:33:38.075: CHAT3: process started

*May 20 11:33:38.075: CHAT3: Asserting DTR

*May 20 11:33:38.075: CHAT3: Chat script hspaq started

*May 20 11:33:38.075: CHAT3: Sending string: AT!SCACT=1,1

*May 20 11:33:38.075: CHAT3: Chat script hspaq finished, status = Success

*May 20 11:33:40.075: %LINK-3-UPDOWN: Interface Cellular0, changed state to up

*May 20 11:33:41.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to up

*May 20 11:35:42.075: %LINK-5-CHANGED: Interface Cellular0, changed state to reset

*May 20 11:35:43.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to down

*May 20 11:35:47.075: %LINK-3-UPDOWN: Interface Cellular0, changed state to down



 

mss-test-ra#sh cellular 0 profile



 

Profile 1 = INACTIVE* **

--------

PDP Type = IPv4

Access Point Name (APN) = mss.net

Authentication = CHAP

Username: cisco

Password: cisco



 

  * - Default profile

 ** - LTE attach profile



 



 

Configured default profile for active SIM 0 is profile 1.

 

I will appreciate if any one can share a working configuration.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gihanucsc Tue, 05/20/2014 - 05:25
User Badges:

Are you using chap username password for this connection?  

Then try creating a dialer interface with ppp authentication instead having slip on the cellular interface. 

Try something like below: 

interface Cellular0

 no ip address
 encapsulation slip
 dialer in-band
 dialer pool-member 1
 async mode interactive


interface Dialer1
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer string INTERNET
 dialer persistent
!

ip route 0.0.0.0 0.0.0.0 Dialer1

line 3
 script dialer INTERNET

 

Your chat script is working fine and check what you get on the debug output: 

debug chat

debug ppp authentication

debug dialer

 

1mody1mody Tue, 05/20/2014 - 05:52
User Badges:

Dear gihanucsc,

thank you for your reply.

I have applied the above configuration, but still the profile is not coming up.

Kindly have a look to the below debug output.

Running Config:

=============

mss-test-ra#sh run | in ip route
ip route 0.0.0.0 0.0.0.0 Dialer1
mss-test-ra#
mss-test-ra#sh run int cell 0
Building configuration...

Current configuration : 199 bytes
!
interface Cellular0
no ip address
ip access-group SITE-TO-SITE in
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive
end

mss-test-ra#
mss-test-ra#sh run int dialer 1
Building configuration...

Current configuration : 292 bytes
!
interface Dialer1
ip address negotiated
ip access-group SITE-TO-SITE in
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string hspaq
dialer persistent
dialer-group 1
no ppp lcp fast-start
ppp chap password 0 cisco
ppp ipcp dns request
end

mss-test-ra#
mss-test-ra#sh run | s line 3
line 3
exec-timeout 0 0
script dialer hspaq
login
modem InOut
no exec
transport input all
transport output all
rxspeed 100000000
txspeed 50000000
mss-test-ra#


 

Debug Message:

==============

*May 20 12:40:20.363: CHAT3: process started
*May 20 12:40:20.363: CHAT3: Asserting DTR
*May 20 12:40:20.363: CHAT3: Chat script hspaq started
*May 20 12:40:20.363: CHAT3: Sending string: AT!SCACT=1,1
*May 20 12:40:20.363: CHAT3: Chat script hspaq finished, status = Success
*May 20 12:40:22.363: %LINK-3-UPDOWN: Interface Cellular0, changed state to up
*May 20 12:40:22.363: Ce0 DDR: Dialer statechange to up
*May 20 12:40:22.363: %DIALER-6-BIND: Interface Ce0 bound to profile Di1
*May 20 12:40:22.363: Ce0 DDR: Dialer call has been placed
*May 20 12:40:22.367: Ce0 DDR: dialer protocol up
*May 20 12:40:22.367: Di1 DDR: Persistent Dialer Profile nailed up successfully
*May 20 12:40:23.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to up
mss-test-ra#
mss-test-ra#sh ip int br | in Cel|D
Cellular0 unassigned YES manual up up
Dialer1 unassigned YES manual up up
mss-test-ra#
mss-test-ra#sh cell 0 profile

Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = mss.net
Authentication = CHAP
Username: mss-test-ra
Password: cisco

* - Default profile
** - LTE attach profile


Configured default profile for active SIM 0 is profile 1.

 


 

gihanucsc Tue, 05/20/2014 - 22:43
User Badges:

Try the the below: 

 

interface Cellular0
no ip address
ip access-group SITE-TO-SITE in
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 1
no dialer-group 1
async mode interactive
end

mss-test-ra#
mss-test-ra#sh run int dialer 1
Building configuration...

Current configuration : 292 bytes
!
interface Dialer1
ip address negotiated
ip access-group SITE-TO-SITE in
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string hspaq
dialer persistent
no dialer-group 1
no ppp lcp fast-start
no ppp chap password 0 cisco
ppp ipcp dns request
end

trycraeting the cellular profile with the chap info

cellular 0  gsm profile create 1 ipv4 chap '' ''

 

then have debug ppp authentication

gointshutseewhat to  cellular 0 and shutdown/ no to retry the dial.. errors you're getting

Actions

This Discussion