SRW2008MP firmware 1.0.4 problems

Unanswered Question
May 28th, 2014
User Badges:

Hello. At my workplace we had to install a Cisco SRW2008MP 8-port Gigabit Switch bought back in 2010 as backup, used 4 months in the summer of 2012, and never used for the rest of the time. It has been updated to the latest firmware available (Hardware Version 00.03.00 / Boot Version 1.0.1 / Firmware Version 1.0.4).

Now, after some days (and some complaints), we discovered that the switch reboots randomly, recording Emergency errors in the Flash logs.

1   2147479047  29-May-2014 00:32:08  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
2   2147479507  29-May-2014 00:27:11  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
3   2147479967  25-May-2014 00:13:43  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
4   2147480427  24-May-2014 21:47:20  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
5   2147480887  24-May-2014 21:36:15  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
6   2147481347  24-May-2014 21:28:25  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
7   2147481807  24-May-2014 21:12:09  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
8   2147482267  24-May-2014 17:55:42  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
9   2147482727  24-May-2014 17:15:50  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
10  2147483187  24-May-2014 17:05:54  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****     
11  2147483647  24-May-2014 16:59:28  Emergency  %OS-F-MEMORY: OSMEMG_rn_free: Memory address is NULL ***** FATAL ERROR *****  Reporting Task: GOAH. Software Version: 1. 0. 4 (date  06-Sep-2007 time  09:11:  40) ***** END OF FATAL ERROR *****

 

In the summer of 2012 it had been used as a standalone switch, providing just PoE and non-continuous connectivity between some devices, without any noticeable problem (can't be sure). Now its PoE functionality is not needed and has been disabled; but it's now connected to another switch, a Cisco SG-300MP.

No particular configuration is in place: static ip, time servers, PoE disabled, jumbo frames enabled. The error seems to be really random; it has been experienced under high and low load.

I can honestly say that this firmware is a real pain for another reason too: the webgui doesn't work with browsers like Chrome, Safari or Konqueror, as it can't go past the login screen, giving this error:

Error: http://192.168.1.245/js/initFunctions.js: Parse error at http://192.168.1.245/js/initFunctions.js line 33
Error: node : ReferenceError: Can't find variable: importXML

 

It loads only in Internet Explorer, but even there we couldn't change the switch password (we've got that via telnet, in the end).

Can we hope in a firmware update? Thank you in advance!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion

Related Content