×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Weird, speed not identical same AP, help

Unanswered Question
Jun 8th, 2014
User Badges:

Leaseline = 4mb speed and ADSL=40mb speed

When I connect using my mobile via AP, i will get the ADSL speed 40mb in speedtest.net, but when I connect my laptop same AP, i will get leaseline speed of 4mb. Both configured with no proxy, Both gets the same Public IP from ADSL. All LAN http speed also is 4mb with ADSL public ip when testing in speedtest.net My configuration below.

!
interface GigabitEthernet0/0.5
 description SERVERSNETWORK
 encapsulation dot1Q 5
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.11
 ip nbar protocol-discovery
 ip nat inside
 ip virtual-reassembly in
 ip policy route-map REROUTE-HTTP
!
interface GigabitEthernet0/0.70
 description NATIVE
 encapsulation dot1Q 70 native
 ip address 192.168.70.1 255.255.255.0
 ip helper-address 192.168.5.11
 ip nbar protocol-discovery
 ip nat inside
 ip virtual-reassembly in
 ip policy route-map REROUTE-HTTP
!
interface GigabitEthernet0/1
 description MAIN
 ip address 213.42.34.abc 255.255.255.abc
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 description ADSL
 no ip address
 ip flow egress
 ip virtual-reassembly in
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 10
 no cdp enable
!
interface FastEthernet0/1/1
 description BACKUP
 ip address 213.42.68.abc 255.255.255.abc
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 no ip address
!
interface GigabitEthernet0/0/1
 no ip address
!
interface GigabitEthernet0/0/2
 no ip address
!
interface GigabitEthernet0/0/3
 description MAIN
 switchport access vlan 50
 no ip address
!
interface Vlan1
 no ip address
!
interface Vlan50
 ip address 83.111.165.abc 255.255.255.abc
 ip flow ingress
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in max-fragments 64 max-reassemblies 512
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 10
 ppp authentication pap callin
 ppp pap sent-username abcde password 7 abcde
 ppp ipcp dns request accept
 ppp ipcp address accept
 no cdp enable
!
!
router bgp 65200
 bgp log-neighbor-changes
 network 83.111.165.abc mask 255.255.255.abc
 network 94.56.22.abc mask 255.255.255.abc
 neighbor 213.42.34.abc remote-as 5300
 neighbor 213.42.34.abc update-source GigabitEthernet0/1
 neighbor 213.42.34.abc route-map MAINLL in
 neighbor 213.42.68.abc remote-as 5300
 neighbor 213.42.68.abc update-source FastEthernet0/1/1
 neighbor 213.42.68.abc route-map BACKUPLL in
 maximum-paths 2
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip dns server
ip nat inside source route-map ADSL interface Dialer1 overload
ip nat inside source route-map BACKUP interface FastEthernet0/1/1 overload
ip nat inside source route-map MAIN interface GigabitEthernet0/1 overload
!

ip access-list extended COMMON-TRAFFIC
 deny   tcp any any eq www
 deny   tcp any any eq 443
 permit ip any any
ip access-list extended HTTP-TRAFFIC
 permit tcp any any eq www
 permit tcp any any eq 443
 deny   ip any any
!
!
route-map ADSL permit 10
 match ip address HTTP-TRAFFIC
 match interface Dialer1
!
route-map MAIN permit 10
 match ip address COMMON-TRAFFIC
 match interface GigabitEthernet0/1
!
route-map BACKUP permit 10
 match ip address COMMON-TRAFFIC
 match interface FastEthernet0/1/1
!
route-map MAINLL permit 10
 set local-preference 110
!
route-map BACKUPLL permit 10
 set local-preference 90
!

route-map REROUTE-HTTP permit 10
 match ip address HTTP-TRAFFIC
 set interface Dialer1
!
!
!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Sun, 06/08/2014 - 18:33
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Can you specify the wireless NIC for your laptop and what is your mobile? 

 

Maybe your laptop will only support low-speed 802.11b data rates but your mobile can do 802.11a/n protocol.

cinmar1957 Sun, 06/08/2014 - 21:09
User Badges:

Thank you for the reply.

Both have same AP connected and same bandwidth. Also desktops that is connected locally pick-up lower speed at 4mb.

Leo Laohoo Mon, 06/09/2014 - 00:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

What is the model of the NIC card?  Is the driver of the NIC card updated?

Leo Laohoo Mon, 06/09/2014 - 02:31
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

NIC card is updated. Is this a vlan issue?

What's the model of your NIC card?  

 

Some NIC cards can behave differently.  This gets worst when the cards are not configured properly.  

 

What is the model of your NIC card and the version of the driver you are using.

cinmar1957 Mon, 06/09/2014 - 03:30
User Badges:

Realtek PCIe GBE Family

Version:7.72.410.2013

I updated it isays "I have the latest"

Actions

This Discussion

Related Content