Can not login with Jabber into VCS-E

Unanswered Question
Jun 12th, 2014
User Badges:

Hi,

I set up Expressway-E and Expressway-C (X8.1.1), Travearsal Zone is up with TLS, all certificates are fine.

The Connection to CUCM and IM&P (9.1) is also ok.

LDAP integration works also fine, has no error.

Every server is reachable, all ports are open.

 

Jabber 9.7.1 can not connect to Expressway-E.

The logfiles show this:

 

2014-06-12 13:01:03,306 DEBUG [0x00001584] [sets\adapters\imp\components\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: cert, OnCertVerificationEvent, start:0 need-timeout:1
2014-06-12 13:01:03,322 ERROR [0x00001584] [sets\adapters\imp\components\Log.cpp(35)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: #0, CLoginCup::OnLoginFailed err-code: -1, err-string: cup internel error. request-token:0
2014-06-12 13:01:03,322 DEBUG [0x00001584] [sets\adapters\imp\components\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: #0, CLoginCup::HandleCupHA ha, HandleCupHA
2014-06-12 13:01:03,322 WARN  [0x00001584] [sets\adapters\imp\components\Log.cpp(34)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: ha, invalid HA soap server index:1
2014-06-12 13:01:03,322 DEBUG [0x00001584] [sets\adapters\imp\components\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: #0, CLoginCup::HandleDnsSrv dns, HandleDnsSrv
2014-06-12 13:01:03,322 DEBUG [0x00001584] [sets\adapters\imp\components\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: #0, CLoginContext::ChangeState now:0 auto:0
2014-06-12 13:01:03,322 INFO  [0x00001584] [sets\adapters\imp\components\Log.cpp(33)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: #0, CLoginStop::OnStateChanged CLoginStop::OnStateChanged
2014-06-12 13:01:03,322 INFO  [0x00001584] [sets\adapters\imp\components\Log.cpp(33)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppClient::FinalCleanData
2014-06-12 13:01:03,322 INFO  [0x00001584] [sets\adapters\imp\components\Log.cpp(33)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: #0, CLoginStop::OnStateChanged conn, canceled due to no needs. supposed:0, signning-on:0, signed-on:0
2014-06-12 13:01:03,322 ERROR [0x00001584] [sets\adapters\imp\components\Log.cpp(35)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: #0, CLoginMgrConnectionPointContainer::Fire_OnError login, OnError, 9
2014-06-12 13:01:03,322 ERROR [0x00001584] [sets\adapters\imp\components\Log.cpp(35)] [JabberWerx] [IMPStackCap::Log::log] - [JabberWerxCPP.DLL]: JWLoginSink::OnError, lerr:9
2014-06-12 13:01:03,322 DEBUG [0x00001584] [ts\adapters\imp\components\Login.cpp(88)] [imp.service] [IMPStackCap::Login::OnLoginError] - Entry
2014-06-12 13:01:03,322 INFO  [0x00001584] [ts\adapters\imp\components\Login.cpp(90)] [imp.service] [IMPStackCap::Login::OnLoginError] - ****************************************************************
2014-06-12 13:01:03,322 INFO  [0x00001584] [ts\adapters\imp\components\Login.cpp(91)] [imp.service] [IMPStackCap::Login::OnLoginError] - OnLoginError: (data=0) LERR_CUP_UNREACHABLE <9>:
2014-06-12 13:01:03,322 INFO  [0x00001584] [ts\adapters\imp\components\Login.cpp(92)] [imp.service] [IMPStackCap::Login::OnLoginError] - ****************************************************************
2014-06-12 13:01:03,322 DEBUG [0x00001584] [s\impl\system\CredentialsManager.cpp(91)] [csf-unified.services.system.CredentialsManager] [CredentialsManager::GetCredentialsImplForService] - ScopedLock to protect access to credentialsMap
2014-06-12 13:01:03,322 INFO  [0x00001584] [\impl\system\CredentialsManager.cpp(107)] [csf-unified.services.system.CredentialsManager] [CredentialsManager::GetCredentialsImplForService] - Found credential object associated with the Authenticator ID: WebEx
2014-06-12 13:01:03,322 DEBUG [0x00001584] [apters\imp\components\LoginUtils.cpp(88)] [imp.service] [IMPStackCap::LoginErrortoErrorCode] - LoginErrortoErrorCode: 9 mapped to: UnableToConnectToTheServer
2014-06-12 13:01:03,322 DEBUG [0x00001584] [listeners\LoginEventListenerImpl.cpp(92)] [imp.service] [LoginEventListenerImpl::OnLoginError] - errCode: UnableToConnectToTheServer
2014-06-12 13:01:03,322 INFO  [0x00001584] [ers\imp\lifecycle\LoginExecutor.cpp(375)] [imp.service] [LoginExecutor::OnSignOn] - Entry
2014-06-12 13:01:03,322 INFO  [0x00001584] [ers\imp\lifecycle\LoginExecutor.cpp(376)] [imp.service] [LoginExecutor::OnSignOn] - OnSignOn: false
2014-06-12 13:01:03,322 ERROR [0x00001584] [ers\imp\lifecycle\LoginExecutor.cpp(384)] [imp.service] [LoginExecutor::OnSignOn] - OnSignOn failed while in starting state...
2014-06-12 13:01:03,322 INFO  [0x00001584] [pters\imp\lifecycle\LoginExecutor.cpp(0)] [imp.service] [LoginExecutor::OnSignOn] - Exit

 

Can someone point me in the right direction how to solve this?

 

Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steve Deslandes Mon, 06/30/2014 - 07:34
User Badges:

I don't think you can register the Jabber you are trying to use to a VCS. Only Jabber video can work thru a VCS. The Jabber you are trying to use (version 9.7.1) is built for Call Manager. You need to get Jabber Video (version 4.8.6) if you want to use Jabber with a VCS-E.

Edip Gumuskaya Tue, 08/05/2014 - 07:53
User Badges:

Hi There,

 

Did you find a resolution to this?

 

I too get the [IMPStackCap::Login::OnLoginError] - OnLoginError: (data=0) LERR_CUP_UNREACHABLE <9>: error.

 

Thanks,

 

Ed

Joshua Warcop Tue, 08/05/2014 - 12:13
User Badges:

First, upgrade to 8.2.

Second - create a Unified Communications traversal zone between Core and Edge. If you also need traversal for SIP/H323/B2B calling you need a second traversal zone for this on a different port.

Ensure your Jabber client is connecting fine inside the network.

Verify your neighbor zones are active with CUCM and CUPS.

 

rmoh66300 Fri, 08/08/2014 - 00:50
User Badges:

I'm sorry, what does "If you also need traversal for SIP/H323/B2B calling you need a second traversal zone for this on a different port" mean?

 

I've set up the traversal zone, all my connections to cucm/imp are active. I get the same error. I'm also running 8.2.

 

 

Joshua Warcop Wed, 08/13/2014 - 13:50
User Badges:

You only need the second traversal zone if you intend to do SIP/H323 calling between your Expressway and anyone else on the Internet. You cannot use the UC traversal zone for this purpose.

You have a public verifiable certificate on Expressway-E? Also you have a valid certificates on CUCM and IM&P either by 3rd party or trusted CA?

rmoh66300 Wed, 08/13/2014 - 21:33
User Badges:

I think i know what the problem is, although I can't fix it immediately.

 

My problem - I only have 1 dns server which means everything resolves everywhere!

I've tried entering the expressway-e address in the manual connection details (removing the _collab-edge record) to no avail, thats why I keep getting these errors.

 

Is there any way we can force the jabber client to be in edge mode without actually having a _collab-edge srv record? Its always going to resolve _cisco-uds regardless of it being internal or on the internet. Until, of course, someone here gets the dns zoning issue sorted.

Actions

This Discussion